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A detailed review of the data collection, integration and quality control points within the broadband data gathering
and mapping process are discussed in the subsections that follow. In addition, a diagram showing the overall
process can be seen below.
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PROVIDER OUTREACH

For the each data submission, an e-mail notification is sent to all providers with supporting deliverable dates.
The providers mainly used the Provider Portal web application to submit changes to and/or validate their
current coverage areaf(s).

In support of the data collection effort, providers that did not respond timely to the outreach were contacted
by phone.
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OUTREACH MATERIALS

The original provider packet sent via e-mail to the providers included the following documents and files:

Letter from the State inviting them to participate in the program;
Copy of the Non-Disclosure Agreement (NDA);

Copy of the Mapping NOFA from the NTIA;

Copy of the NOFA Clarification from the NTIA;

Broadband service address example file in CSV format;

Word document describing service address example file;

Broadband service block example file in CSV format;

Word document describing service block example file;

Broadband service street example file in CSV format;

Word document describing service street example file;

Broadband subscriber example file in CSV format;

Word document describing subscriber example file;

Broadband wireless coverage area sample shapefile;

Word document describing wireless coverage area sample shapefile;
Instructions for downloading, installing and using the WinSCP SFTP application.

OUTREACH PROCESS

The provider outreach process is comprised of the following general steps:

Send the provider package and introduction letter to the main point of contact for the provider.
Follow up with e-mail and telephone to verify that the main point of contact is correct.

If necessary, discuss the NDA further and resolve any redlines.

Once the correct primary contact is established, set up a telephone call, if necessary, to learn more
about the provider’s offerings and direct them to the appropriate outreach materials.

If providers are unable to be contacted (non-responsive) or indicate that they are not interested in
participating (non-cooperative), mark them as such on the provider tracking sheet. These providers
will be escalated to the State for further action.

As the providers are collecting the required data, provide instructions on downloading, installing and
using the WinSCP SFTP application, if required.

Arrange with the providers to transfer the data in whatever way they are comfortable: some
providers will find regular email acceptable; others will want to use the SFTP application.

After data is received and reviewed, it may be necessary to contact a provider for clarification or to
address incomplete datasets. In the interest of building and maintaining relationships, care is given
not to push the provider but to work with it to obtain accurate data in the best possible format.

Version 4.0 March 2012 Author: Kristin Rousseau

Page 5




BROADMAP

Beyond The Boundaries

DATA COLLECTION

DATA TRANSFER PROCEDURES

There are three primary ways data is collected from providers. These are:
e Secure FTP (SFTP) using the WinSCP application;

e  Regular e-mail;

e  Mail.

INITIAL DATA REVIEW AND QUALITY ASSURANCE

The initial data review and quality assurance process consists of the following general steps:
1) Access the data from the SFTP site or e-mail.
a. If e-mailed, place copy of original dataset in the appropriate provider folder on the SFTP site.
2) Place copy of raw data on local computer in a working directory.
3) Review data and determine course of action based on type of data received.
4) Ensure data is complete and contact provider to address any gaps.

NOTE:
The goal is to get as many providers as possible to provide subscriber address data in the correct format.
Obviously, this will not be possible with all providers so we will continue to have to process various types of
provider-supplied data.

DATA INGESTION

DATA INGESTION OVERVIEW

The following subsections outline the process steps taken based on the type of input supplied by the data
provider:

e Point Data:
O Subscriber location;
O DSLAM location;
0 Central Office location;
O Broadcast Tower location.
Linear Data:
O TIGER® street segments.

Polygonal Data:

0 Census Blocks;

0 Coverage Area.
Overall, the process is geared toward taking the provider data supplied and creating polygon shapes to
append to the bb_cov feature class. The bb_cov feature class is the interim dataset that is then processed
using the makeDeliverable.py Python script to create the MapConnectT'vI data layers that will be delivered
to the State and, ultimately, to the NTIA. Detailed instructions used in this process can be found in the
subsections below.
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POINT DATA

SUBSCRIBER LOCATION—ADDRESS DATA

In the event that the data provider supplies subscriber address data, the steps are as follows:
1) First, convert the address data to a clean Excel spreadsheet in an appropriate address data
format.

a. Usually, this has the following columns: street address (number, pre-directional, pre-
modifier, street name, street type, post-directional and post-modifier concatenated), city,
state, ZIP.

2) Configure the ArcGIS® geocoding tool to use the TIGER® 2010 streets dataset.

a. In ArcCatalog®, create a new Address Locater by right-clicking in the white space of the
appropriate directory and selecting New>Address Locater from the dropdown menu.

b. Select US Streets with Zone and click OK.

NOTE:
It is likely that multiple Address Locators will have to be set up to handle the variety of provider address data
received.

c. Navigate to the TIGER Streets 2010 file and click OK.
d. Fillin the dialog box, as shown below:

New US Streets with Zone Address Locator

Mame: [ CO_Geacode_TIGER _2009] Input Address Fields

Description: | 1S Streets with Zone The field containing: is recognized if it is named:

Primary table l Zone Addr
Strest

Reference data:
| Ci\Working'Broadband \BaseDataTIGER,_Streets.shp =

[v Store relative path names

Fields

House From Left: |LFROMADD Matching Options

Place Mame Alias Table...

House To Left: |LTOADD

House From Right: |RFROMADD Spelling sensitivity:

House To Right: |RTO.-'-\DD Minimum candidate score:

Minimum match score:

Prefix Direction: | <None >

Prefix Type: | <None> Intersections

Connectors: & @ Separate connectors by a

Street Name: |FuLLNAME space, e.0. "R @, [

Street Type: | <None> COutput Options

. |<None> Side offset: in |Feet

End offset: O
v Match if candidates tie

Left Zone: |ZIP‘L

Lol Lef Lef Lol Lol Lef L] Lo L L L

Right Zone: |ZIPR

Qutput Fields

[~ Xand Y coordinates [~ standardized address
™ Reference data ID [~ Percent along

Advanced...
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e. Click OK.

Open ArcMap® and add the Excel spreadsheet with the address information.

Right-click on the Excel spreadsheet and select Geocode Addresses from the dropdown menu.
Select the appropriate address locator by clicking Add..., then OK.

-

= Choose an Address Locator to use...

| Description
e C0_Geocode_TIGER_2009 LIS Streets with Zone

Cancel
6) Fill out the Geocode Addresses dialog box, as shown below:

r — -
Geocode Addresses: CO_Geocode_TIGER_2009 PX
Address table:
|Fibers | ﬂ
Address Input Fields

Street or Intersection:  |r | appR p—
Zone: 7IP_CODE -

Qutput

{+ Create static snapshot of table inside new feature dass
~

Qutput shapefile or feature dass:

Advanced Geometry Options... |

Geocoding Options. ..
Help oK | Cancel |

7) Geocode the list in batch mode using the geocode service set up in Step 2 above, accepting all
the default parameters.
8) Review results. See example below.
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"
f"é Interactive Rematch - glenwood_try1

Show results: ‘A"Addl’ESSES j Manage result sets... ‘ Refresh Rematch Automatically

B Matched: 97 (88%)

| FID | Shape | Status | Score | Match_type | Side | A | B red: 5 (5%)

r 0] Point 201 CENTENNIAL DR, 81601

Point 201 CENTENNIAL DR, 81801 B Unmatched: 8 (7%)

Point 201 CENTENNIAL DR, 81601

Point 210 CENTER DR, 61601 ——————
Point 15 WARKET DR, 81601

Point 40 MARKET DR, 81601

Point
Point
Point
Point
10 Point
11| Paint
12 | Point

58827 SOCCER FIELD RD, 81601
125 STORM KING RD, 81601
52800 TWO RWERS PLAZA RD, 81601

e~ ;] afw|m] =

w

40 MARKET DR, 31601
2698 GILSTRAP CT, 81601

Record: ﬂj 1 jﬂ Records (of 110)

Address: 1 Candidate Candidate details:
strest or Intersecton [p01 ceEvaA | |2 | Side_| Match_addr | LeftFrom [ LeftTo [ RightFrom | RightTa e 01 | w0

Z0ne W 81 L 201 CENTENMIAL DR, 81601 201 299 200 298 To 299 298
PreDir

PreType

StreetMame CENTENNIAL
StreetType DR

Sufbir

Zone 81601 | 81601
Score 81

Side L
Match_addr |201 CEMTEMNIAL C

»FFPFPFEPPPFEPF P

Standardized Address:
201 | | | CENTENNIAL | ST | | 81501 < >

Geocoding Options. .. | Zoom to Candidates | . Pick Address from Map | Search | Unmatch |

9) Adjust geocoding parameters accordingly and repeat batch to resolve issues.
10) Manually geocode unmatched addresses until target hit rate achieved, generally 90%.
11) Visually inspect the data, as shown below:

-

. provider_data_QAQC.mxd - ArcMap - Arcinfo

File Edit View Bookmarks Insert Selection Tools CHZM Window Help

DSEEHE 2@ v | ad|ime o &% T3 k| edor~
Georeferencng * ,—4| | # E ArcPad Data Manager ~ -E -3 -’ @- a8
30 Analyst ~ ’—_] oz

x

a®

= Geocoding Result: glenwood_tryl
.

= [ TIGER Streets

COUNTIES

KA Wk
Eu oAk

BB_ConnectionPoint_MddleMiie
.

HIGHWAYS

Bl1TO 3

FCROADS

BB_Service_Road_Segment
CITIES

BB_Service_CensusBlode
O
BB_Service_Overview
=

BB_Service_Wireless

%o

communicomm_coverage_area

£

wired_coverage_sample_wgs84

O

_Display [ Sourcs | Selection | a0 i
orawing ~ K o0 &1 O v| A v (@] Anal -l «| B £ O -

-107.326 39.557 Decimal Degrees

12) Follow the steps detailed in Subscriber Location—GIS Data below.
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SUBSCRIBER LOCATION—XY DATA

If the provider supplies a list of subscriber data with accompanying XY data such as latitude and
longitude, the steps are as follows:

1) Refine the format in Excel so that the data can be opened easily using ArcMap®.

a. Remove all font color, highlighting, cell colors and borders, clean up column headers and
make certain there are no merged cells.

Make certain that XY locations are in decimal degrees.

(i.) To convert from degrees, minutes, seconds (392 26’ 45.67”) to decimal degrees, use the
following formula: DD + (MM/60) + (SS5.S55/3600).

b.

NOTE:

If XY locations from some other coordinate system are provided, you can use those in the process below but you
must know what the coordinate system is.

2) Open the Excel worksheet in ArcMap®.
3) From the menu bar, select Tools>Add XY Data...

Add XY Data

Atable cortaining X and Y coordinate data can be added to the
map as a layer

Choose a table from the map or browse for another table:

| ForImport$ ﬂ g

Specify the fields for the X and ¥ coordinates:

¥ Field: |LONG

[
[~

Y Field: ||_.'.\T

Coordinate System of Input Coordinates

Description:

Geographic Coordinate System:
Name: GCS_WGS_1584

[ Show Details

[¥ Wam me if the resulting layer will have restricted functionality

oK | Cancel |

Supply the appropriate fields for the X and Y coordinates, choose the appropriate coordinate
system and click OK.

Results are an event layer, not a true spatial layer. Export the data by right-clicking the event
layer and selecting Data>Export Data... from the dropdown menu.

Follow the steps detailed in Subscriber Location—GIS Data below.
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SUBSCRIBER LOCATION—GIS DATA

If the provider supplies subscriber location in GIS format, the only process step is to load that data

into the appropriate data schema and it will be ready for processing.

1) First, load the data into the Point Address database schema using an empty feature class in that
schema.

2) In ArcCatalog®, right-click on the empty feature class and select Load from the dropdown menu.

3) Navigate to the provider address GIS dataset and then map the attribute fields accordingly, as
shown below:

-
Simple Data Loader

Far each target field, select the source field that should be loaded into it.

Target Field Matching Source Field
street_id [int] <Mone=
zide [ztring] zNone=
feature_id [int] zNone=
point_type [zhort int] <Mone=

add_house_num [string] | vl
add_pre_dir [ztring] PRE_DIR. [ztring]

add_pre_type [ziring] zNone=

add_name_body [ztring] STREET_NM [=tring]

add_suf_type [string] SUF_TPE [ztring]

add =uf dir [ztring] SUF TYPE [=tring]

Reset

< Back | Mext = | Cancel

Once you have successfully loaded the provider address data into the temporary database with
the correct schema, you now will append that data to the overall Point Address database.

In ArcToolbox®, use the Append command (Data Management Tools>General> Append) to add
the features into the overall Point Address database, as shown below:
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DEx

Input Datasets

C:\Working\Broadband\Provider_Data_Example.gdb\Temp_Address

Target Dataset
| C:\Working\Broadband\Provider_Data_Example.gdb\Address_Database

Schema Type {optional)
| TEsT
Field Map {optional)

e [ X |+ e |e]2 x|+ |

v

Cancel | Environments. .. | TShow Help 557

Since the data is already in the Point Address database schema, there is no need to alter the Field
Map in the Append tool.
After appending, calculate metadata reflecting geometry source and representation values.
Break provider-specific points into separate county feature classes and perform the following
steps per county feature class:
a. Within ArcGIS®:
(i.) Summarize download and upload speeds [first,last] to determine all speeds available for
county.
(1) This will save as a DBF table. Keep track of location for future reference.
(ii.) Buffer county address point featureclass to 150°.
(1) During buffer command, dissolve on ad_down; ad_up; provider; dba; frn; tt; all
metadata fields; stctyfips. Save as.... county_fastestdown_fastestup.
(2) Example using Qwest data: boulder_40128 20128, where boulder=county;
40128=ad_down; 20128=ad_up.

NOTE:
These attribute fields are specific to the Point Address database.

(iii.) Select the features that represent the lowest speeds.
b. Using XtoolsPro (http://www.xtoolspro.com/):

(i.) In the XTools Pro toolbar, select XTools Pro>Layer Operations>Erase Features.

(ii.) Use the same feature class for Input and Overlay.

(iii.) Check Use selected features on the Input feature, as shown below.

(iv.) Repeat and erase slowest speeds one speed at a time. Save each new feature class as
the next slowest speed, using the same naming convention as shown in a.(ii.)(1) above.
A general example is shown below:

Version 4.0 March 2012 Author: Kristin Rousseau
Page 12




Beyond The Boundaries

-
Erase Features

Input feature layer:

[ boulder_12128_895 |
[v Use selected features
(1/2 feature selected)
Qutput storage:
| C:Working'\Broadband'\ProviderDat... \boulder_7168_896

v Add output feature dass to current map
v Create spatial index

Qverlay layer:

|[E boulder_12128_g95 |

[ Use selected features (1 feature is selected)

Help oK | Cancel

Return to ArcGIS®:

(i.) Edit/delete speeds from the attribution table of each feature class, so each remaining
feature class has only one speed value.

(ii.) Merge individual speed feature classes using the Merge command in ArcToolbox® (Data
Management Tools>General>Merge). The dialog box is shown below:

@ Input Datasets

l& [ [X |+ |&

@ Output Dataset

Field Map {optional)

X [+ (&

oK ‘ Cancel | Environments... ‘ {Show Help =5 |

(iii.) Merge individual county feature classes using the Merge command in ArcToolbox (Data
Management Tools>General>Merge).

(iv.) Since the county files are all in the same schema, DO NOT alter the Field Map portion of
the command interface.
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(v.) When all the county files are merged into one dataset, use the Append command in
ArcToolbox® (Data Management Tools>General>Append) to add the features to the
bb_cov interim dataset. Use the Field Map portion of the Append tool to map the
appropriate field values to their corresponding fields in the bb_cov feature class.

DSLAM OR CENTRAL OFFICE LOCATION—ADDRESS DATA

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central
Office address data, the steps are as follows:

1) Follow the process for geocoding points in Subscriber Location—Address Data above.

2) Follow the steps detailed in DSLAM or Central Office Location—GIS Data below.

DSLAM OR CENTRAL OFFICE LOCATION—XY DATA

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central
Office XY data, the steps are as follows:

1) Follow the process for creating points from XY data in Subscriber Location—XY Data above.

2) Follow the steps detailed in DSLAM or Central Office Location—GIS Data below.

DSLAM OR CENTRAL OFFICE LOCATION—GIS DATA

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central
Office GIS data, the steps are as follows:
1) Buffer the DSLAM/Central Office points feature class.
a. Add the point feature class to ArcMap®.
Open the ArcToolbox® and go to Analysis Tools>Proximity>Buffer.
Set the buffer distance to 5 miles.
Set the dissolve type to ALL.
Name the output feature class.
Typical Buffer tool is shown below:

Input Features

| Columbine
Qutput Feature Class
| C:\Working'Broadband\ProviderData\Columbine \Columbine_Buffer_2.shp

Distance [value or field]
{* Linear unit

" Field

Side Type (optional)

End Type (optional)

Dissolve Type (optional)

Dissolve Field(s) (optional)
Orm

O company
Ocea
Orru

O excHANGE
Ostate
OrroviDER
Ocu_cooe
MecorT

£

Cancel Environments... | Show Help == |

g. Click OK.
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2) Use the resulting buffer feature class to clip the TIGER® street layer:
a. Add TIGER® street layer to ArcMap®.
b. Open the ArcToolbox® and go to Analysis Tools>Extract>Clip.
c. Complete the dialog box as shown below:

Input Features

| TIGER Streets

Clip Features

| Columbine_Buffer

QOutput Feature Class

| C:\Working\Broadband ProviderData\Columbine \columbine_TIGER. _clip.shp
XY Tolerance (optional)

I Meters

Cancel J Environrnents...‘ Show Help == |

d. Click OK.
3) Using ArcCatalog® and within the file geodatabase:
a. Right-click and create a new Feature Dataset.
(i.) For the Feature Dataset settings:

(1) Name the feature dataset accordingly.

(2) Select horizontal coordinate system by importing the coordinate system associated
with the clipped TIGER® street layer by selecting Import and navigating to the
location of that feature class.

(3) No vertical coordinate system needed.

(4) Leave all x,y,z,m values at default.

(5) Click Finish.

4) Import previously created street feature class into new Feature Dataset.
5) Right-click Feature Dataset and create new Network Dataset—accept all default setting for the
Network Dataset.

NOTE:
The Network Analyst extension must be turned on.

6) In ArcMap® turn on the Network Analyst Toolbar by going to View>Toolbars>Network Analyst.
7) Add the Network Dataset created in Step 5 to ArcMap.
8) Using the Network Analyst Toolbar dropdown, create New Service Area.

9) Open the Network Analyst Window by selecting the E button. See below.
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x

|Service Area ﬂ
Facil'rl:iﬁ (D)

Polygons (0)
Lines {0}
Barriers (0)

10) Right-click Facilities layer, select Load Locations and navigate to the DSLAM/Central Office
facilities feature class.

-
Load Locations

Load From: El columbine_peints
[¥ Orly show point layers

r
Sort Field: |

Location Analysis Properties

Property Field Default Value

Mame
CurbApproach
Attr_Length
Breaks_Length

Either side of vehide
0

Location Position

* Use Geometry

Search Tolerance: Meters

" Use Network Location Fields

Property
SourcelD
SourceQID
PosAlong
SideOfEdge

Advanced. .. Cancel

11) Click OK.

12) Click the Service Area Properties button .
13) For the following tabs, change the following properties:
a. Polygon Generation tab:
(i.) Select Merge by break value.

(ii.) Also disable the Trim Polygons option.
Analysis Settings tab—using and converting the specified DSLAM buffer distance from feet

to meters—input buffer distance value in meters into the Default Breaks location.
(i.) Generally, 18,000 feet (5486 meters) from DSLAM or Central Office location is used as

the buffer distance. See below.
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=

Layer Properties

Line Generation ] Accumulation ] Network Locations
General ] Layers ] Source Analysis Settings l Palygon Generation

Settings Restrictions

Impedance: | Length (Meters) j

Default Breaks: |54551

Direction:
&+ Away From Facility
" Towards Facility

Allow U-Tums: | Evenywhere

¥ Ignore Invalid Locations

c. Click OK.

On the Network Analyst Toolbar, click the Solve button ﬁ to create service area polygons.
Right-click on the created service area polygon in the layer list, and select Data>Export Data from
the dropdown list.
Export to a feature class in the file geodatabase you created earlier.
In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and
load the feature class created in Step 16 into it.
a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class.
Click the Add button, then click Next.
Accept the defaults and click Next.
DO NOT attempt to map any fields, as shown below:
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Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field
|F‘r-:|'.fName [string] <None=>
DBAName [string] <None~
|| FRM [int] =None=
_| GeagUnit [string] <None=>
|| GeogUnitiD [string] <None>
| TransTech [short in] =None=
| MaxAdvDown [ghort inf] <None>
MaxAdvUp [=hort int] <None>
ARPU [float] =None=
SWHNomSpeed [floafl <None=

e. Click Next, then Next again, then Finish.
18) In ArcToolbox®, go to Data Management Tools>General>Append.
19) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

BX

Input Datasets =
| @

C:\Working'Broadband\ProviderData\Columbine \Columbine .gdb\service _area_bb... +

Target Dataset
| C:\Working'\Broadband\ProviderData\Columbine\Columbine. gdb\bb_cov j =

Schema Type {optional)
[TES
Field Map (optional)

b

oK | Cancel Environments. .. | Show Help ==

20) Leave the Schema Type as TEST.
21) Click OK.

22) In ArcMap®, open bb_cov for editing and manually input associated attribution.
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BROADCAST TOWER LOCATION—ADDRESS DATA

In the event that the provider supplies wireless broadcast tower location address data, the steps are
as follows:

1) Follow the process for geocoding points in Subscriber Location—Address Data above.

2) Follow the steps detailed in Broadcast Tower Location—GIS Data below.

BROADCAST TOWER LOCATION—XY DATA

In the event that the provider supplies wireless broadcast tower location XY data, the steps are as
follows:

1) Follow the process for creating points from XY data in Subscriber Location—XY Data above.
2) Follow the steps detailed in Broadcast Tower Location—GIS Data below.

BROADCAST TOWER LOCATION—GIS DATA

In the event that the provider supplies wireless broadcast tower location GIS data, the steps are as

follows:

1) Download the required software (Radio Mobile) from the website:
http://www.cplus.org/rmw/englishl.html

2) Install the software according to the standard directions, found here:
http://www.cplus.org/rmw/download/download.php?S=1

3) Open the application.

4) Load the broadcast tower location and elevation information by selecting File>Unit properties.
The following dialog box appears:

¥ Units properties
prope

A Mame Elevation [m)

s

Bithena [althea 4| [

Caribou
Chipeta
Frankling

Hori £ A0°04'26. 6" 105°30'33.1
arzon-|
Horizareiad Cory DN7OFB Paste

Pasition

Litteraven

b ahzanala-H
b ahzanala
Moonztone Enter LAT LOM ar QRA Mowve up
Firata
Terrapin Move down
Tobago
Turtle

apili Expart

[ Locked

Place unit at cursor pozition

P

Place cursor at unit pozition Imnpart

Style Sort

v Enabled ™ Left * Centre " Right

[ Tranzparent
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&

Apply style

v Small famt
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e

5) Add the information for all the towers supplied by the WISP data provider, including the
elevation. If provider does not supply elevation, this information can be obtained from Google
Earth.

a. If available, use the Import button to import a Google Earth KML of the tower locations.

Go to the National Map Seamless Server (http://seamless.usgs.gov/) and download elevation

data sufficient to contain the tower locations.

a. Atleast the 1/3” NED data is needed. Select this by clicking the Download button in the
upper right of the website and checking the box next to 1/3“ NED.
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Zoom to the area of interest and use the Download tools to define the area to download:

c. Click the Modify Data Request button to request the data in BIL_16INT format, not ESRI
GRID, as shown below:

" ~
) The National Map Seamless Request Summary Page - Mozilla Firefox g@]@|

http: ffextract.cr usgs.govWebsite /distreq/RequestSummary. jsp?PR =0&CU=Native&ZX=-1.08ZY =-1.08ML=C 7_j

The National Map Seamless Server
Request Summary Page

You are logged in as Default Seamless User.

Modify Data Request HELP!

Data Extraction Request Pieces:

Output Parameters

National Elevation Dataset (NED) 1/3 Arc Second

EROS Data Center

< #° ™ 4om frank@gmail.com

d. Download the data and unzip it.
7) Select File>Map Properties to define the map.
8) Enter a latitude and longitude in the center of the tower locations.
9) Set the size (in pixels) and the size (in kilometers) of the map.
10) Set the directory path leading to the BIL elevation data just downloaded.
11) The dialog box is shown below:
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["1: Properties of ..\default.map

— Centre — Size [pixel]
AO°DE268.9'N 105°2927 6w Width{pixels) Height [pixels| Extract

ON7OGE [1000 [1000

Latitude Longitude

|.1 05.491 — Size [km) Cancel

Width{km] Height (k]
[1o0.00 [100.00 Top Left
40°3029°N
0B T4 44w

Usge curgar position

Drive: or path Top layer Top Right

IBIL LI Ic:\geodata\bil\boulder Browese. .. | A0 3029"N
10475477

Enter LAT LON or R4, [More  +| | Browss... | Battom Left
3973629
- B TO0B°04'44"
ISeIect aunit ;I INone —I I &l
| Battom Right
INDI"IE LI I Browze. . AT I

- . : 10475477 %/
[~ Adjust units elevation INDI"IE LI I Browese. .. |
Rezolution

I Merge picturss [ Ignore missing files Bottom laver | qn0 ke
Iv Force giap scale Initialize matris with elewvation (m] IEI 3.24 arcsecond

Select a city name

Wwarld map | - Elevation data zource

12) Click Extract.
13) The elevation data is rendered as a hill shade, as shown below:

" ..\default.net - Radio Mobile - [..\default.tif]
[ﬂﬁle Edit Wiew Tools Options Window Help Sfop

cE@RA @Qa«

[A0°05'54"H 10571713 =573 Y=461 1724 1m

14) Select File>Network properties from the main menu.
15) Create a new network and enter in the frequency range under the Parameters tab, as shown
below:
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Default parameters Copy Met | 0K

‘ Cancel ‘
List of all nets

Mednet
Jade
COuaray
COrobile

Parameters ‘ Topology | tembership ‘ Systems ‘ Style

Met name

Surface refractivity [M-Units] W

Ground conduchivity [S/m) 0

|Nedemet

Minirmurm frequency [MHz] | 2400
hd aximum frequency [MHz] 2400

Paolarization
+ ‘ertical

005

Relative ground permittisity l_
15

Clirnate

" Horizontal Equatarial

Made of variabilty Continental sub-tropical

* Spot
" Accidental
" Mabile

b aritime zub-tropical

% of time
% of lacations
% of gituations |70

Continental temperate
" Broadcast

I aritime temperate over land

~
~
~
" Dezert
o
~
~

I aritime temperate over sea

16) Leave all the other values as they appear, and select the Systems tab.
17) Create enough systems to cover all the varieties of equipment in the provider network. This will
include the antenna type, height and line loss, as shown below:

Default parameters

Copy Met ‘

‘ Cancel ‘

Lizt of all zpstems
G0
120

Parameters ‘ Topology | tMembership ‘ Systems ‘

System

System
System
System
System
System
System
System
System
System
System
System
Systern
Spztem
Spztem
System
System
System
System
System
System
System

o~
Syztem name

Tranzmit power [ att)
Receiver threshold ]
Line loss [dB)

Antenna type

Artenna gain [dBi)
Antenna height [m)

Additional cable lozs [dB/m)

Add to Badiosys01. dat

|Se|ect from Fadiozys01.dat

[T
l‘lﬂﬂi
—
hi
Ve
s (@Bd) [1285
IS— [ Above ground |

IU— [ If antenna height differs |

Remove from Radiozys01.dat

{dBm) |50
(dBm) 107

[ Cable+cavities+connectars |

18)

Now click on the Membership tab, and assign the individual towers to their respective systems,

providing the azimuth for non-omnidirectional antennas, as shown below:
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List of all nets

Diefault pararneters

Copy Met |
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‘ Cancel

hednet
Jade
Ouray
Ok obile
Hedernet

Parameters ‘ Topology ‘ Memberzhip ‘ Systems

List of all unitz

v &lthea

W

| Caribiou

| Chipeta

| Frankling

v| Horizon-E

| Horizonw
| Littleraven
| Manzanala-H
| hanzanalay
v| Moonstone
| Firata

tember of Hedermet
Rale of Athena

| Command

Syztem

|60

Antenna height [m)
{* System

" Other

Antenna direction

v| Terrapin
| Tobago
W] Turtle
v W apiti

|Fived ) |

Azimuth [*] Elervation angle [°)
] o

View pattern

19) Click OK.

20) Select Tools>Radio Coverage>Combined Cartesian from the main menu.

21) Complete the dialog box as shown below, providing the Maximum Range from the highest tower
beam radius supplied by the provider.

22) Set the Pixel Size at 5 (experiment depending on the area covered to get the right level of
granularity), as shown below:

@& Combined cartesian Radio coverage

Freed unit(s] Mobile urit

[Aithea

W apiti Draw

W Althea
W &thena
| Caribiou
| Chipeta
| Frankling
w| HorizonE

| Horizorw/ v
W Littleraven
W ManzanalaH
W Manzanala’
w| Moonstone
| Pirata

[ Draw pattern
w'| Terapin
v Tobaga

View patten
| Turtle

ol apiti Antennha height [m]
9 * Mobile Ry

C r
. m Mobile T«

Antenna pattern

In network Cancel

=
=

‘Nadamat

Use network antenna settings Lo sdllige

Save raster data to file [TXT] .
Save settings

Save raster data to file [SIG)]

Save also units not selected Load data

Comnplete. way

Save coverage pictures in "frames' directory

M axinum range [km]
Link Direction Mode

v Al picture

Signal range to draw

& S-Unit I Best unit

2

[~ Metwork style

" dBm
o
 depvim

M
. Colar

[~ Sold

Draw size [pivels)

s

[ Rainbow

23) Set the Signal range to draw to S-Unit and type 5 in the From (>=) box.
24) Click on Draw. See below.
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.
[ _.\default.net - Radio Mobile - [..\default.tif]
[l Fle Edt View Tools Optons Window Help 3top

|AD’DE‘53”N 10671610 X=702 v=455 1627m

25) Save the resulting image as a TIF by selecting File>Save Picture as.
26) Open ArcMap® and load the BIL elevation data you used in Radio Mobile.
27) Load the TIF image you created and georeference it using the corners of the BIL data.
a. The corners of the data can be seen in the TIF image.
28) Follow the georeferencing directions from the Coverage Area—PDF/JPG/Other Image Format
section below.
29) Use the Georeferencing Toolbar to Update the Georeferencing for the TIF dataset.
30) In ArcToolbox®, select Data Transformations>From Raster>Raster to Polygon and input the
georeferenced TIF you just created.
31) Open the resulting polygon feature class for editing using the Editing toolbar in ArcMap® and
clean up as necessary.
32) In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and
load the feature class created above into it.
a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class.
Click the Add button, then click Next.
Accept the defaults and click Next.
DO NOT attempt to map any fields, as shown below:
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-

. Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field
[FrovName [string] <None=
DBAMame [string] =None=
| FRN [int] <None>
GeogUnit [ztring] =Monex
_| GeogUnitiD [string] =None=
| TraneTech [zhort int] <None>
| MaxadvDown [short int] =Monex
| MaxAdvUp [short int] <Nones
ARPU [float] <None>
SWNomSpeed [floafl =None=

e. Click Next, then Next again, then Finish.
33) In ArcToolbox®, go to Data Management Tools>General>Append.
34) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

EEX

Input Datasets —
| 7 &

C:\Wworking\Broadband'\ProviderData\Columbine\Columbine gdb\service_area_bb... +

Target Dataset

| C:\Working\Broadband\ProviderData \Columbine \Columbine. gdb\bb_cow
Schema Type (optional)

Field Map (optional)

0K | Cancel Environments... | Show Help == |

35) Leave the Schema Type as TEST.
36) Click OK.
37) In ArcMap®, open bb_cov for editing and manually input associated attribution.
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LINEAR DATA

TIGER® STREET SEGMENTS—LIST, SPREADSHEET OR GIS DATA

In the event that the provider supplies TIGER® street segments in list or spreadsheet format, the
steps are as follows:
1) Join TIGER® road segments to 2000 census blocks feature class using one of two methods based
on how the data is provided:
a. Ifthe TIGER® data is provided with a Census Block ID, then join the segments to the Census
Block geometry based on that ID:
(i.) Load both datasets into ArcMap®;
(ii.) In the layer list, right-click on the 2000 census block feature class and select Joins and
Relates>Join;
(iii.) In the dialog box, select the TIGER® road segments data and the proper attribute fields
for joining, as shown below:

-
Join Data

Join lets you append additional data to this layer's attribute table so you can,
for example, symbolize the layer's features using this data.

What do you want to join to this layer?

|J0in attributes from a table

1. Choose the field in this layer that the join will be based on:

|BLTDFROO |

2. Choose the table to join to thiz layer, or load the table from disk:

[ TIGER_Streets [<] ﬂ

[w Show the attribute tables of layers in this list

3. Choose the field in the table to base the join on:
~

Join Options
 Keep all records

All records in the target table are shown in the resulting table.
Unmatched records will contain null values for all fields being
appended into the target table from the join table.

" Keep only matching records

If arecord in the target table doesn't have a match in the join
table, that record is removed from the resulting target table.

About Joining Data oK |

(iv.) Click OK.

If the data provided is a list containing TLIDs, then join to the TIGER®/Line data using the

TLID, and use a spatial join to associate the TIGER® segment with the coterminous block

based on the block ID:

(i.) Load both datasets into ArcMap®;

(ii.) In the layer list, right-click on the 2000 census block feature class and select Joins and
Relates>Join;

(iii.) Select Join data from another layer based on spatial location from the dropdown
menu;

(iv.) Complete the dialog box, as shown below and click OK.
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-
Join Data

Join lets you append additional data to this layer's attribute table so you can,
for example, symbolize the layer's features using this data.

What do you want to join to this layer?

1. Choose the layer to join to this layer, or load spatial data from disk:

[¥ TIGER Streets =] ﬂ

2. You are joining: Lines to Polygons

Select a join feature dass above. You will be given different
options based on geometry types of the source feature dass
and the join feature dass.

{* Each polygon wil be given a summary of the numeric
attributes of the lines thatintersect it, and a count field
showing how many lines intersect it.

How do you want the attributes to be summarized?
[ Average [~ Minimum [ Standard Deviation
™ sum ™ Maximum [~ Variance

Each polygon will be given all the attributes of the line that is
closest toits boundary, and a distance field showing how
dose the line iz (in the units of the target layer).

Mote: A line faling inside a polygon is treated as being closest
to the polygon, {i.e. a distance of 0).

3. The result of the join will be saved into a new layer.
Spedify output shapefile or feature dass for this new layer:

|C:"-.‘.".l'orking"-.Bnoadband"-.Temp"-Join_OLrtput_5.shp

About Joining Data

Export joined records into a temporary feature class.

If joined Census Block geometry is confined to one specific area, then dissolve blocks into one
record. If joined Census Block geometry is distributed throughout a particular State, then dissolve
sub-selections of census blocks for each county.

a. Use the County FIPS code to dissolve by county.

b. In ArcToolbox®, select Data Management Tools>Generalization>Dissolve.

c. Complete the Dissolve dialog box, as shown below:
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v
* Dissolve

Input Features

| blocks L

Qutput Feature Class

| C:Working‘\Broadband\BaseDatablocks_LITM_Dissolve,shp
Dissolve_Field(s) (optional)
OFmo

OstaTerrao
COUNTYFPOD

O mracTcenn
OsLockcenn
[OeLkIDFPoD

O namecn

Owmrrccon

Mirnn

<

Select All | Unselect Al
Statistics Field(s) (optional)

Statistic Type

v

oK | Cancel | Environments... | Show Help =>

d. Click OK.
For each dissolved region, open the feature class for editing using the Editing tool in ArcMap®
and remove unnecessary slivers and other small holes. For general guidance on editing features
in ArcMap®, see http://webhelp.esri.com/arcgisdesktop/9.3/pdf/Editing_Tutorial.pdf
In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and
load the feature class created above into it.
a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class.
Click on the Add button, then click Next.
Accept the defaults and click Next.
DO NOT attempt to map any fields, as shown below:
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-

. Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field
[FrovName [string] <None=
DBAMame [string] =None=
| FRN [int] <None>
GeogUnit [ztring] =Monex
_| GeogUnitiD [string] =None=
| TraneTech [zhort int] <None>
| MaxadvDown [short int] =Monex
| MaxAdvUp [short int] <Nones
ARPU [float] <None>
SWNomSpeed [floafl =None=

e. Click Next, then Next again, then Finish.
6) In ArcToolbox®, go to Data Management Tools>General>Append.
7) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

EEX

Input Datasets —
| 7 &

C:\Wworking\Broadband'\ProviderData\Columbine\Columbine gdb\service_area_bb... +

Target Dataset

| C:\Working\Broadband\ProviderData \Columbine \Columbine. gdb\bb_cow
Schema Type (optional)

Field Map (optional)

0K | Cancel Environments... | Show Help == |

8) Leave the Schema Type as TEST.
9) Click OK.
10) In ArcMap®, open bb_cov for editing and manually input associated attribution if necessary.
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POLYGONAL DATA

COVERAGE AREA—PDF/JPG/OTHER IMAGE FORMAT

In the event that the provider supplies coverage area data in some image format such as PDF or JPG
format, the steps are as follows:
1) If in PDF format, open in Adobe Acrobat and Save As... JPG format.
2) Open the JPG image in ArcMap®.
3) Add the required base map vector data for georeferencing.
a. This generally will be either the CDOT data or TIGER® data.
4) Change the coordinate system of the data frame to the desired end coordinate system.
5) Zoom to the general location of the JPG map image.
a. Thisis the location based on the vector data, not the JPG image itself. For example, if you
know that the JPG image represents an area around the town of Limon, zoom to the town of
Limon in your vector data.
Open the Georeferencing toolbar by selecting View>Toolbars>Georeferencing from the main
menu bar.
Using the Georeferencing toolbar, select Fit to Display; results are shown below:

YtadDstaMaraos v A PP E T =
+H AWM BE-0NELE TN

8) Use the Control Point button "Z'- to add control points to the map.
9) Use common points in the base dataset and the JPG image.
a. Forexample, find major street intersections, county/city boundaries, etc.
b. Try to distribute the points more or less in the four corners on the image for the best
transformation.
10) Click on the location on the image first, then click on the corresponding location on the vector
database map, as shown in the image below:
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After placing each control point, the image transformation will update automatically.
Repeat until satisfied with the transformation.

NOTE:

The transformation may take up to four points, although sometimes only two are necessary.

13)

14)

15)
16)

17)

18)
19)

When satisfied with the transformation, select Update Georeferencing from the Georeferencing

toolbar dropdown.

a. This will create a “world” file (.jgw in the case of JPGs) in the same directory as the image
file.

In ArcCatalog®, create a new polygon shapefile with the appropriate data schema for a provider

coverage area.

Add the shapefile to ArcMap®.

Using the Editor toolbar, select Start Editing. Set the Task to Create New Feature.

Use the Sketch Tool ‘? "lto digitize a new coverage polygon using the coverage area outline
from the georeferenced JPG and add the required attributes manually.

Repeat the above steps for all subscriber speed coverage areas provided.

Follow the steps detailed in Coverage Area—GIS Data below.

COVERAGE AREA—KML/KMZ

In the event that the provider supplies coverage area data in Google Earth KML or KMZ format, the
steps are as follows:

1)
2)
3)
4)

Use a KML to SHP converter to translate file into an Esri® format.
http://arcscripts.esri.com/details.asp?dbid=15603

Download the script and follow the provided instructions for installing it in ArcToolbox®.
Double-click on the script in ArcToolbox® and navigate to the location of the KML file, as shown
below:
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-

% Convert KML to SHP

KML File
| C:\Documents and Settings'forr\Desktop\Google \ftupton. kml

Feature Type

| PoLYGON

Qutput shapefile

| C:'\Documents and Settings\forr\Desktop\Google\flupton_kml_to_shp.shp

oK | Cancel | Environments...| Show Help >> |

5) Add the new shapefile to ArcMap®. Repeat for all KML files provided.
6) Follow the steps detailed in Coverage Area—GIS Data below.

COVERAGE AREA—CAD DATA

In the event that the provider supplies coverage area data in GIS format, the steps are as follows:

1) Transform the CAD dataset into an Esri® format.

2) http://webhelp.esri.com/arcgisdesktop/9.2/index.cfm?TopicName=Transforming_CAD_datase
ts

3) It may be necessary to contact the provider first to determine the coordinate system of the CAD
data.

4) If the CAD data is not in a standard coordinate system, it may be necessary first to use ArcMap®
to georeference the CAD data to a known coordinate system.

a) Todo so, follow the instructions provided above in Coverage Area—PDF/JPG/Other Image
Format.

5) In ArcCatalog®, create a new polygon shapefile with the appropriate data schema for a provider
coverage area.

6) Add the shapefile to ArcMap®.

7) Using the Editor Toolbar, select Start Editing. Set the Task to Create New Feature.

8) Use the Sketch Tool "? Ylto digitize a new coverage polygon using the coverage area outline
from the georeferenced CAD file and add the required attributes manually.
9) Follow the steps detailed in Coverage Area—GIS Data below.

COVERAGE AREA—GIS DATA

In the event that the provider supplies coverage area data in GIS format, the steps are as follows:
1) In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and
load the GIS feature class either created above or supplied by the provider into it.
a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class.
Click on the Add button, then click Next.
Accept the defaults and click Next.
DO NOT attempt to map any fields, as shown below:
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-

. Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field
[FrovName [string] <None=
DBAMame [string] =None=
| FRN [int] <None>
GeogUnit [ztring] =Monex
_| GeogUnitiD [string] =None=
| TraneTech [zhort int] <None>
| MaxadvDown [short int] =Monex
| MaxAdvUp [short int] <Nones
| ARPU [fioat] <None>
SWNomSpeed [floafl =None=

e. Click Next, then Next again, then Finish.
2) In ArcToolbox®, go to Data Management Tools>General>Append.
3) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

=1

Input Datasets =
| -1 =

C:\Working'BroadbandProviderData \Columbine\Columbine .gdb\service_area_bb... +

Target Dataset
| C:\Working \Broadband \ProviderData\Columbine\Columbine.gdb\bb_cov
Schema Type (optional)

Field Map (optional)

oK | Cancel | Environmenis...| Show Help == |

4) Leave the Schema Type as TEST.
5) Click OK.

6) In ArcMap®, open bb_cov for editing and manually input associated attribution, if necessary.
COMPACT POLYGON FROM SUBSCRIBER POINTS

1) Geocode address list using latest State Composite Locator.

2) Verify that your geocoded file has only one TT (Technology Type). If not, export individual
geocoded layers for each Technology Type.

3) For each TT, check for differences in speed values or speed tiers and create separate layers for
each speed value/tier.
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Clean your geocoding results: remove any points that geocode to accuracy levels below ZIP+4

(ZIP centroids, carrier route centroids, etc). Also, verify that outliers with acceptable accuracy

levels are legitimate, i.e., fall in correct city and Zip.

Perform spatial join between county polygons (using stcnyfips field) and the cleaned geocoded

subscriber points in order to carry the county name and stcnty fips.

Summarize the number of subscribers by county and use the subscriber counts by county to

populate the Rate Tier table.

Un-join the county data from the geocode subscribers list.

Create Compact Polygon using cleaned geocoded layer or sub-selection of XtoolsPro—

ConvexHull-DetailedHull option. A sub-selection of geocoded points will be used in areas where

more than one polygon will need to be created for one provider’s service area.

Evaluate output Hull carefully, looking for areas that should not be covered by hull polygon.

a. [Ifitis determined that an area or areas should not be represented in coverage area,
manually reshape hull polygon until coverage area is adequate.
When not obvious and as a general rule, manually resolve compact polygon when the
distance between the subscriber points used to define the outer boundary of the compact
polygon exceeds 5 miles . When reshaping the hull polygon, snap to the outermost
geocoded points. See the three figures below for examples.

Compact Hull: Manual Resolution Required

J u—v\
o G

5/ '/ ‘Compact Hull .
LA @

R4 5 < output U

Original
Compact Hull

As a general rule if the distance between
the subscriber points used to define the outer
boundary of the compact hull exceeds 5 miles,

manually reshape hull.

()
0N

9'® Q0

e

e I
‘e ®,
e,

oo,

0 % 0\ o
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10) To attribute the compact polygon, perform a spatial join where your Target Feature Class is the
compact polygon and the Join Feature Class is your geocoded point layer. Export compact hull
with joined attributes and name file appropriately.

11) Append attributed compact polygon to Broadband TT template Feature Class and, if required,
manually input any provider attribution that may not have carried over in the append process.

12) Intersect compact polygon with county boundaries to create unique records by county and use
the state-county-fips field to populate stcty_fips field. Also use the county name field to populate
the BBCov_Name field.

a. Exception: where a provider’s coverage is distributed throughout more than one area of any
given county where the BBcov_Name should be populated using an appropriate city or other
logical name based on geographical location.

13) Export/load into appropriate BB TT model dataset.

CENSUS BLOCKS—LIST OR SPREADSHEET

In the event that the provider supplies census block data in a list or spreadsheet, the steps are as
follows:
1) Ensure block polygons supplied by the provider are 2000 currency.
2) If other currency, convert to 2000 currency before proceeding.
a. Todo this, remove the trailing letter (a, b, etc.) from the block ID.
b. You will now have two blocks that equate to one block in the 2000 block geometry.
c. Delete duplicate block IDs, retaining the higher service tier in each case.
Prepare the block list in clean Excel format, removing all Excel-only formatting, merged cells,
colors, borders, etc.
Import the spreadsheet into ArcMap®.
Right-click on the 2000 census block feature class in the layer list in ArcMap® and select Joins
and Relates>Join from the dropdown menu. Join the census block list to the 2000 census blocks
feature class using the block ID and export joined records in a new feature class. The Join dialog
box and process can be seen above in the TIGER® Street Segments—List, Spreadsheet or GIS
Data subsection.
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6) Follow the steps in Census Blocks—GIS Data below.
CENSUS BLOCKS—GIS DATA

In the event that the provider supplies census block GIS data, the steps are as follows:

1) Ensure that the blocks supplied by the provider are in the required data schema and are
complete as far as required attribution.

a. If not, manually enter the required attribution or contact the provider to fill gaps.

2) If census block geometry is distributed throughout more than one county, then select Data
Management Tools>Generalization>Dissolve in ArcToolbox® and dissolve based on
County/Provider/TT/Speed Tier so that unique records are created for each unique combination.

The Dissolve dialog box is shown above in the TIGER® Street Segments—List, Spreadsheet
or GIS Data section.
Two examples of undissolved census block polygons are shown below:

YAMHILL COUNTY
Undissolved Census blocks ‘

bl i
Yamhlll County N ,7/'
Pro\uder A L\‘,é g
} | T 7-\’}

Prowder A
“TT10
Spied Tler\ 1
A~y e

Dissolved Census Blocks

will all slivers and holes removed. YAMHILL COUNTY

Yamhill County
Provider A
TT10
Speed Tier 1

‘.MN‘\__]—
Polk County
Provider A
TT10
Speed Tier 1

POLK COUNTY

Census block polygons dissolved by county

3) For each dissolved region use the Editing toolbar in ArcMap® to remove unnecessary slivers and
other small holes.

4) In ArcToolbox®, select Data Management Tools>General>Merge and merge the processed
polygons into a single layer.

5) The merged census blocks will need to have the subscriber’s frn field added and populated.
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6) In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and
load the GIS feature class either created above or supplied by the provider into it.
a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and
navigate to the location of the service area feature class.
Click the Add button, the click Next.
Accept the defaults and click Next.
DO NOT attempt to map any fields, as shown below:

. Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field

[FrovName [string] <None=
_| DBAName [string] =None=
| FRN [int] <None>
| GeogUnit [string] =Monex
_| GeogUnitiD [string] =None=
TranzTech [zhort inf] <None>
MaxAdvDown [=hort int] =Monex
Max&dvUp [zhort int] <Nones
| ARPU [fioat] <None>
SWNomSpeed [floafl =None=

Reset

< Back | Next > | Cancel

e. Click Next, then Next again, then Finish.
7) In ArcToolbox®, go to Data Management Tools>General>Append.
8) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

Input Datasets

Target Dataset
| C:\Working\Broadband\ProviderData\Columbine \Columbine. gdb\bb_cow

Schema Type (optional)

Field Map {optional)

CK | Cancel Environments... | Show Help == |

9) Leave the Schema Type as TEST.
10) Click OK.
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11) In ArcMap®, open bb_cov for editing and manually input associated attribution, if necessary.

METADATA TRANSACTIONS

Following any updates or changes completed within the file geodatabase (fGDB) stored on the GIS-Analysts
staging environment, the GIS-Analyst runs transactions to compare that fGDB with the one stored on the Core
server to ensure metadata on all changes is recorded.

The steps taken to run transactions on the updated Core database are outlined below:
1) Openacommand line window and run generateTransactions.py:
a. Usage: generateTransactions.py [Core fGDB] [Staging Environment fGDB]
b. Example of command line:
<path>generateTransactions.py <path>ST_BB_POLY_SRV_AREAS.gdb <path>ST_BB_POLY_SRV_AREAS.gdb
2) Shown below is an example of the output screen that will be displayed:
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Calculating rec_id field for BBCov_@_BB_POLY_TEMPLATE
value can not he B or less

Trouble creating the progress meter

Calculating rec_id field for BBCov_18_CenturyLink

Merging change: X:“\BDIA_BB_GDBs“MS_BB_POLY_SRU_AREAS .gdb“AddPt

Calculating Transzaction fields for AddPt

#:“\BDIA_BB_GDBs“M3_BB_P

Your transaction FeatureClasses are in
~smichigansAllAccessS\BDIA_BB_GDBs_HIST

_SRU_AREAS .gdb“AddPt .. .changes

elapsed time = 2994_.4 seconds
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iz complete.

;HS_BB_POL":'_S RU_AREAS_HIST.gdh

3) After the process has completed, results can be found in the ST_BB_POLY_SRV_AREAS_HIST.gdb:

a. The transactions scripts records changes at a feature level.

b. Shown below is a screenshot supporting the directory structure of the historical fGDB.

ArcCatalag - ArcView - MABDIA_BE_GDBs_HIST\CO_BE_POLY_SRV_AREAS_HIST.gdb
————

Eile Edit View Go Tools Window Help

&= |53

Location:  [M\BDIA_BB_GDBs_HIST\CO_BE_POLY_SRV_AREAS_HIST gdb

Stylesheet

-] AddPt

BBCov 0_POLY_TEMPLATE
BBCov_10_Agate
BBCov_10_BigSandy
BECov_10_Bijou
BBCov_10_Blanca
BBCov_10_CenturylLink
BBCov_10_Columbine
BBCov_10_Covad
BBCov_10_DuboisTelExchange
BBCov_10_ESRTA
BBCov_10_Farmers
BBCov_10_Glenwood
BBCov_10_HaxtunTele
BBCov 10 Internet_CO
BBCov_10_JED
BBCov_10_Nunn
BBCov_10_PineDrive
BBCov_10_PlainsCoop
BBCov_10_Qwest
BBCov_10_Rico
BBCov_10_Rye

lppppLLERRBRELERRBER BB R

=l

Contents l Preview 1 Metadata ]

Name

Type

Modified

BBCov_10_Nunn

[=] Addpt
BBCov_BO_ATT
BBCov_80_Sprint
BBCov_10_DuboisTelExchange
BECov_70_Mobilelnet
BECov_10_Sunflower
BECov_10_Qwest
BECov_30_XOComm
BECov 41 Comcast
BECov_20_XOComm
BBCov_50_Rye
BBCov 71 SECOM
BECov_50_Glenwood
BBCov_10_Rico
BECov_71_Sanlsabel
BECov_B0_Verizon
BECov 10_Wiggins
BBCov_10_PlainsCoop
BBCov_70_Bijou
BBCov_30_Covad
BBCov_70_SouthPark

oo

File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class
File Geodatabase Feature Class

SIEEREEE =S

8/30/2010 8:57:53 AM
11/30/2010 4:49:46 PM
11/30/2010 4:37:35 PM
8/30/2010 9:24:00 AM
8/30/2010 8:21:41 AM
8/30/2010 8:22:48 AM
8/30/2010 8:22:55 AM
8/30/2010 8:25:11 AM
8/30/2010 8:26:18 AM
8/30/2010 8:27:24 AM
8/30/2010 8:28:32 AM
8/30/2010 §:29:39 AM
9/10/2010 10:59:47 AM
8/30/2010 8:32:01 AM
8/30/2010 8:33:21 AM
8/30/2010 9:31:55 AM
8/26/2010 2:33:20 PM
8/30/2010 8:37:43 AM
11/30/2010 4:35:50 PM
11/30/2010 4:36:30 PM
9/10/2010 11:07:22 AM
8/30/2010 8:42:13 AM

T T R R AN

c. Attribution associated with each added/removed/changed feature is tracked, including the
following additional columns appended to the end of each:
(i.) Commit_by
(1) Records the GIS-Analyst who committed the changes to the historical fGDB.
(ii.) Commit_date
(1) Records the date and time stamp on which the changes were committed.
(iii.) Trans_type
(1) This field reflects the type of change recorded;
(2) Categorized by: Adds/Change/Deletes.
(iv.) New_values
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(1) Records the new values when a change was completed on a feature. Example:
Name or speed change.
d. MD_Process also is transferred from the edited fGDB to the historical f{GDB, which states the

actions completed by the GIS-Analyst.
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DATA PROCESSING

DATA PROCESSING OVERVIEW

The following subsections detail the steps and layout required to process the service provider data further
to meet NTIA requirements:

e  Weighted Nominal Speed;

e Middle Mile;

e Broadband Coverage Template.

WEIGHTED NOMINAL SPEED

The weighted nominal speed is populated in one of the following two ways: subscriber data supplied by
provider or value supplied by provider.

SUBSCRIBER DATA SUPPLIED BY PROVIDER

Where the data provider supplies subscriber speed information, the following formula from the NOFA
is used:
(speed tier-1 in kbps x no. of tier-1 subscribers) + (speed tier-2 in kbps x no. of tier-2 subscribers) + (etc.)
Total average monthly subscribers

Data is initially broken up in the following order:
1) Stcty_fips;
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2) Transmission technology type;
3) Subscriber tiers.

VALUE SUPPLIED BY PROVIDER

Some providers will supply their weighted nominal speed. In these cases, the data supplied will be
populated instead of using the NOFA formula. These obtained or calculated values are used to update
the service overview layer.

This can be done manually or by creating a table with the provider’s FRN and average weighted speed

and joining it to the service overview table in ArcMap®.

1) Tojoin, right-click on the layer to join to and select Joins and Relates>Join from the dropdown
menu.

2) Then navigate to the table to join to and select the join fields from the dropdown list.

3) Then open the source table (the table in ArcMap®) and right-click on the header of the Average
Weighted Speed field and select Calculate Field from the dropdown menu.

4) Use the value of the average weighted speed from the joined table.

MIDDLE MILE

Middle mile information generally is provided in spreadsheet or text file format. The process is to take
what is supplied by the provider and translate it into the required data schema.
1) If the data is supplied with address information, follow the process outlined above in Subscriber
Location—Address Data.
2) If the data is supplied with associated XY coordinates, follow the process outlined above in
Subscriber Location—XY Data.
3) Once the datais in GIS format, use the Append (Data Management Tools>General>Append)
command in ArcToolbox® to append the data to the overall middle mile dataset.
4) Set the schema type to NO_TEST and use the Field Map to map the attribute fields from the
source to the target dataset.
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BROADBAND COVERAGE TEMPLATE

The table below lists descriptions of the fields within the bb_cov layer, which is the interim dataset used

to create the final product deliverable.

ALIAS

DESCRIPTION

SHAPE

Internal Shape storage

OBJECTID

Internal Object ID

RECORD_ID

Unique ID for this record, and is required for Transactional updates
to function properly.

STATE_COUNTY_FIPS

State/County FIPS code

PROVIDER_ID

Unique numeric identifier for each provider (Parent Source ID)

PROVIDER_NAME

Unique name for each provider

DOING_BUSINESS_AS

An alternative "Doing-Business-As" name for the provider

TYPE_OF_PROVIDER

Type of Provider (1:Broadband provider as described in the NOFA,
2:Reseller, 3:Unknown, 4:Business Only)

FCC_REGISTRATION_NUMBER

Provider FCC Registration Number

BBCOV_NAME

BroadMap Broadband Coverage name (usually Place or County
name)

TECHNOLOGY_OF_TRANSMISSION

Unique code for the transmission technology type described by
this layer

SPECTRUM_CODE

Unique code for the spectrum [WIRELESS ONLY]

MAXIMUM_ADVERTISED_DOWNS
TREAM_SPEED

Maximum advertised downstream speed available within given
area (speed tier)

MAXIMUM_ADVERTISED_UPSTRE
AM_SPEED

Maximum advertised upstream speed available within given area
(speed tier)

TYPICAL_DOWNSTREAM_SPEED

Typical downstream speed available within given area (speed tier)

TYPICAL_UPSTREAM_SPEED

Typical upstream speed available within given area (speed tier)

MD_GEOMETRY

Metadata: Comma separated list of source id's from which the
polygon extent was produced

MD_EXISTS

Metadata: Comma separated list of source id's used in
understanding and editing this feature

MD_WHO

Metadata: Name of the editor who last edited this feature at the
time in md_when

MD_WHEN

Metadata: Date/time that this feature was last edited

MD_PROCESS

Metadata: Comma separated list of processed used to create
and/or modify this layer

SHAPE_AREA

Area in square decimal degrees

SHAPE_LENGTH

Length in decimal degrees

VERIFICATION AND VALIDATION

PROVIDER VALIDATION—PROVIDER PORTAL

Following the collection and aggregation of provider data, the aggregated data is validated by the
provider to ensure it is an accurate representation of their coverage area and supporting broadband

information.
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This validation is completed through the Provider Portal web application, which is a secure

interactive map that displays the provider’s coverage areas and allows the provider to

validate, submit feedback or request changes.

0 If changes are requested, then the features on the portal are updated and an automatic
request is sent to the provider to complete the validation process.

Providers that did not use the Provider Portal are asked to validate a PDF map displaying

their coverage area(s). This is accomplished via e-mail notification.

PROVIDER VERIFICATION—THIRD PARTY SOURCE REVIEW

After the provider has validated its coverage areas, a third-party source comparison and analysis is

performed.

e Where anomalies or discrepancies are identified, a “SCAN” point is dropped and descriptive
comments are applied to be reviewed later with the provider.
e During the provider review, the map is displayed along with the “SCAN” points and potential
refinement is completed based on input from the provider.
The table below shows third-party sources used:

THIRD-PARTY SOURCE NAME

SOURCE TYPE

VERIFICATION TYPE

InfoUSA

Consumer and
Business Listings

Community Anchor Institutions;
Can also be used for demographic information
supporting the State websites.

Pitney Bowes (PBBI)

Exchange Info Plus
(Central Office
Locations)

Exchange datasets are used to verify the following
Transmission Technologies (TT):

Asymmetric xDSL (10), Symmetric xDSL (20), Other
Copper Wireline (30), and Optical Carrier/Fiber to the
End User (50).

Media Prints

Cable Boundaries

Used to verify the following TT:
Cable Modem—DOCSIS 3.0 (40) and Cable Modem—
Other (41).

American Roamer

Wireless Coverage
Patterns (EVDO,
GPRS, WISP, HSPA)

Used to verify the following TT:

Terrestrial Fixed Wireless—Unlicensed (70), Terrestrial
Fixed Wireless—Licensed (71) and Terrestrial Mobile
Wireless (80).

ComSearch

Wireless Spectrum
Holdings and Tower
Data

Used to verify the following TT:

Terrestrial Fixed Wireless—Unlicensed (70), Terrestrial
Fixed Wireless—Licensed (71) and Terrestrial Mobile
Wireless (80).
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ASSIGNING CONFIDENCE VALUES

All findings and results from the abovementioned validation and verification activities, plus internal
peer quality reviews, are captured and tracked in a Validation table (see example on the following
page) and form the basis of the confidence value assigned for each provider and then each
technology.

CONFIDENCE VALUE | DESCRIPTION

0 Coverage area has not been reviewed.
10 Extremely Low:
Single Source QC.
20 Very Low:
Needs additional validation\verification.
30 Low:
Even with validation\verification, coverage still is suspect.
40 Acceptable:
Confirm with State prior to shipment.
50 Meets requirements to be included in shipment.
60 Moderate:
Meets NTIA/State’s standards, representative of Technology Type (TT).
70 High:
Accurate representation of coverage based upon TT.
80 Very High:
Multiple validation\verification with most third-party sources.
90 Extremely High:
Multiple validation\verification sources.
Perfect:
Multiple validation\verification sources, with complete alignment with
sources and ground truth verification activities.

The Validation table is maintained as updates or changes occur for each provider, down to
technology type, with the overall goal to improve the confidence values and overall map
representation.

COMMUNITY ANCHOR INSTITUTION (CAI) DATA

DATA COLLECTION

The CAl data was initially collected from the State to create the baseline inventory. All location
information and broadband coverage data supplied also was ingested into the data deliverable.
Additional collection of CAl information was done via data mining and/or webscraping to build out
the inventory further. For example: Collection of additional CAls and location information.

The State-agency-provided CAl inventory was comprehensive but the challenge is collecting
broadband related data: service provider(s), technology and speed data for each CAl. Availability of
the CAl portal has not significantly increased submission of this data. Additional promotion to CAls to
use the CAl portal will be needed to increase this data for subsequent deliverables.

INSTITUTION DATA

Institution data is obtained from a variety of sources and almost always provided in Excel spreadsheet
format. The general process for incorporating this data is as follows:
1) |If the data is provided in Excel or some similar format:
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Clean and standardize the Excel spreadsheet, removing any cell formats, merged cells, etc.
Standardize the address format as defined in the staging CAl database.
If the spreadsheet includes X and Y values, such as latitude and longitude, use the Add XY
Data tool in ArcMap® to create a spatial data layer.
If there are only addresses, then follow the geocoding steps outlined above to create spatial
data points for each of the institutions.
(i.) Institutions that do not geocode based on the TIGER® 2010 dataset will have to be
located manually using Google Maps, Google Earth or some other information source.
2) If the CAl source data is in GIS format, add the Latitude and Longitude fields and use the
Calculate Geometry tool to populate them, using the WGS 84 coordinate system.
3) Using ArcCatalog®, load the new data into the staging CAl database.
4) This database is ready for the makeDeliverable.py script to process the information into the final
State and NTIA deliverables.

COMMUNITY ANCHOR INSTITUTION (CAI) PORTAL UPDATES

A web application has been released to allow for further data collection and validation of anchor
institution location information, broadband coverage and speed test data. Information collected from
the CAl Portal is then ingested into the overall inventory and will be compared later against the
provider coverage areas mapped to locate any potential discrepancies.

PRODUCT EXTRACT

PYTHON SCRIPTS

The following subsections make use of Python scripts. In general, to use a Python script you must have
Python installed on your computer. To download the latest version of Python, go to
http://www.python.org/download/ and download the latest stable version. As of August 2010, this was
version 2.7. Once this is installed, the general way to run a script is to type the following at a command
prompt: C:\Python27\python.exe C:\<location of script>. Many of the scripts provided have environment
variables that must be set before they can be run.

The Python code for BroadMap’s product extract has been incorporated into a Hudson CI System, which is
detailed in the Process Operation and Monitoring section of this document. This was a process
improvement activity so that all processes can be monitored, controlled and will contain historical
tracking on each process.

PRODUCT EXTRACT PROCESS

NOTE:
Specific Python scripts are called out in red font in the subsections below.

The MapConnectWI product extract process, BDIACreateSBDDOutputMigratedBBCov.py, uses our internal
BB_Cov model to create the following layers rolled up to NATL_Broadband_Map in accordnace to the
current NTIA data model specifications.
e BB_Service_RoadSegment
0 This layer contains all broadband services associated with specific street segments for census
blocks larger in area than two square miles.
e  BB_Service_CensusBlock
0 Contains all broadband services associated with census blocks of no greater than two square
miles.
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BB_Service_Wireless

0 This layer contains all wireless services not associated with specific addresses.

BB_Service_Overview

0 This layer contains subscriber-weighted nominal speed for each provider's service area at a
county level and is meant to act as a summarized view.

BB_ConnectionPoint_MiddleMile

0 This layer contains middle-mile and backbone interconnection points.

BB_Service_CAlnstitutions

0 Broadband Service at Community Anchor Institutions (CAl).

0 Community Anchor Institutions consist of schools, libraries, medical and healthcare
providers, public safety entities, community colleges and other institutions of higher
education as well as other community support organizations and entities.

BB_ConnectionPoint_LastMile

0 This layer contains last mile infrastructure points, which is populated only if data cannot be
provided at a more granular level.

BB_Service_Address

O Represents broadband availability for service address points. Address Point availability refers
to those individual addresses at which each facilities-based provider of broadband service
can provide broadband services of minimal characteristics within 7-10 business days.

State_Boundary

0 State boundary supporting topological validation of point feature classes.

NATL_Broadband_Topology

0 Supports basic topology quality checking. Example: No CAls or Middle Mile points outside of
the State boundary.

PRODUCT STATISTICS

Following the completion of a product extract, the product statistics script (BDIA_ReleaseNotesStats.py)
extracts the following information supporting that product deliverable.
e  Provider Statistics:

(o}
o
o

(0]

Collects all provider information, listing by Provider Name.

Provides output of FRN.

Counts the number of features supported within the following layers:

= Census Block;

= Street Segment;

= Max Upstream;

= Wireless Services;

= Infrastructure Points.

These updates were made to support the Data Package required to accompany every NTIA
product deliverable.

e Community Anchor Institution (CAl) Statistics:

(0]

Breaks down CAl to the eight categories:

1: School: K through 12;
: Library;
: Medical/Healthcare;
: Public Safety;
: University/College;
: Other Government;
: Other Community non-government;
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= None: Unknown Category. In cases where this occurs, further investigation is completed
prior to product shipment to ensure all CAls are categorized accurately.
0 Reports out the following counts:
=  Total CAls within that category;
= Total CAls that contain partial BB coverage. Contains any of the following information for a
given CAl: BB Subscriber, Transmission Technology, Speed Down Speed Up;
= Total CAls that contain full BB coverage. Contains all of the abovementioned BB information
for a given CAI.
The output of this script is two CSV files: Anchorlnstitutions.csv and Providers.csv. These files then can be
inspected to ensure that there are the expected number of CAls and providers for every release.

QUALITY ASSURANCE

Quality assurance is supported manually and algorithmically on the interim data, BB_Cov file geodatabase and
on the final product. For scheduled product releases, a test product extract and subsequent manual and
algorithmic QC run is completed along with a release review. The product specifications, project status reports
and previous product release notes are used as references throughout this review.

The following parameters are tested using the methodology listed below each:
e Product Deliverable Format:

0 Correct names and format of data deliverables.
= BDIA_QC_SUITES.

0 Correct Projections/Datum.
=  Manual interaction with product.

0 Metadata Present and Correct.
=  Manual interaction with product.

Table Structure:

0 Allrequired tables included.
= BDIA_QC_SUITES.

0 Extraneous tables identified.
= BDIA_QC_SUITES.

Field Structure:

0 Allfields included.
= BDIA_QC_SUITES.

0 Extraneous fields identified.
= BDIA_QC_SUITES.

0 Correct field names, types and widths.
= BDIA_QC_SUITES.

Field Domains:

0 Values in all tables are constrained to the specified values specified:
= This action is accomplished via BDIA_QC_SUITES and manual review of the product;
= This tends to identify project completeness issues as fields with a null value are identified.

Geometric Representation:

0 Identify if all layers have the correct geometric representation:
=  Manual review of the BB_ServiceOverview layer;
= Dependent on NTIA and client requirements.

Geographic Extent:

0 Product includes the necessary Geography associated with Product?
= Manual Review—ArcGIS®.

0 Isthere extraneous geography included in Product?
= Manual Review—ArcGIS®.
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Completeness:
O Products contain the expected amount of data?
=  Manual review of product statistics relative to weekly State reports and defined expectations.
Accuracy:
0 Product meets the stated accuracy requirements for the deliverable?
= Sampling procedure to manually review source material to resulting product;
= Provider Validation;
= Verification using Third-Party Data;
= Verification against reality, where applicable.
Data Regression:
0 Any unexplainable data loss or change?
= This action is accomplished by comparing results within product statistics script
(BDIA_ReleaseNotesStats.py) from previous releases, as well as manual review of the product.
Confidentiality:
0 Any unauthorized confidential information included in the delivery?
=  Review of NDAs and delivery expectations.
Prior Issues Resolved:
0 Have expected internal issues been resolved?
=  Manual review of data against previous product release notes.
0 Have agreed-upon customer issues been resolved?
=  Manual review of data against previous product release notes, status report and client feedback.
Delivery Medium:
0 Has the product medium been verified?
= Manual review.
0 Allfiles present.
= Manual review of SFTP site is done to ensure all files are copied correctly, including file/directory
size.
Correct location.
=  Manual review—confirmation of SFTP link, username and password.

QC SUITE

The BDIA_QC_SUITES consists of four main types of scripts supporting the overall QC process. These
scripts are all run in concert and are called from the test_runner script and the test_BDIAProductGDB
script.

CONFIGURATION

These scripts establish the configuration for the test_BDIAProductGDB script, which is the core of the
QC Suite.

update_test_config

active_config

config_ PROCESSO1_automated

config_PROCESSO1_manual

set_active_config

LIBRARIES

These scripts provide additional functionality that is called from with the test_BDIAProductGDB
script.

bb_unittest_fixture

bbcov_structure

BC_XmlWriter

file_folder
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search_and_replace
unittst_fixture
validate_BB_DB
validate_BB_GDB
xmlrunner_gui

QC SUITE

This is the core script for performing automated QA/QC on the interim and final data deliverables.
test_BDIAProductGDB

OTHER

These scripts perform other functions detailed below:

test_runner—this is the main script that runs all the other QC scripts and imports all the necessary
scripts and libraries.

which_build—this determines the current build and passes information to the configuration scripts.

PROCESS OPERATION AND MONITORING

Product Extract, BDIACreateSBDDOutputMigratedBBCov.py, is run within BroadMap using a platform called
Hudson that has been enhanced to support BDIA product extraction, process monitoring, as well as product
validation. The same platform can be planned for implementation for the State, if desired.

Below are previous examples of the product create, product validation, product statistics and monitoring
processes that are managed within the BroadMap Hudson CI-System. All of the above-mentioned Python
scripts, with the exception of metadata transactions script, are run via this system.

BDIA PRODUCT CREATE

Below is an example of the main page where the type of product build can be selected.

N buildy in (e queve.

Build Execytor Status

3 ma 23 deys (200)

W
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Selecting based on the type of process that will be initiated is shown below:

Hudson

Hudson » BDIA Product Create » BDIA ProductCreate

4 Back to Dashboard
Oi

\k‘ Status

"2 Changes

& workspace

Configure

Build History (trend)

#123 Dec 9, 2010 12:30:00 PM 186KB
Running for provider portal update

#122 Dec 9, 2010 9:53:37 AM 179KB
Running for provider portal update - Test will rerun
when Midco is complete

#121 Dec7, 2010 6:03:02 PM
SD build for portal test

Project BDIA_ProductCreate

QR on Alaska

Workspace

Last Successful Artifacts

® bdiazntiz.log &
® makeDeliverable.log 5=
® robocopy.log &=

=

o
| —#" Recent Changes
el

Permalinks

build (#123), 4 davs 23 hr ago
stable build (#123), 4 days 23 hr ago

#119 Dec1, 2010 12:41:51 AM
CO Monthly Deliverable w/ Crit Feedback

@ #118 Nov 30, 2010 4:58:46 PM
CO Monthly Deliverable w/ Crit Feedback

asf build (£123), 4 davs 23 hr ago
failed build (#121), 6 days 18 hr ago
unsuccessful build (£121), 6 davs 18 hr ago

Hudsen » UOLA Prodect Create » UCIA_ProductCrasts
# Exchio Dushboard i

Project BDIA_F
This buils saquitas EaFamatare:

State o

The Console Output can be reviewed to see the progress of product create. Following the completion of

each product creation process, an e-mail notification is automatically sent to the team.
Hudso! 3

Hudson + BDIA Produce Crants » BDIA ProductCrance = £117
&=

view 2 plain text

o Console Output
= Chenoss

B consate outpu

[ BT

D o m build vie

e out of aync. This can resslc in inconsisvens check sus Beharicr
baz

ZecairTemp:

e eall Ci\User:
faccess\BDIA B8 GOBs\CO BB POLY XV _AREAS gdb D:\hudson\jebs\EOIk BroduccCreste\vorkspace™\CO S8 BOLY_SHV ABEAS gdb /MIN /L0G:zohosspy.lag

58515 Produectrasce\verkspasest

\Budeom\ Joba\BOTA_ProductCrantaivoriey

ROSOCOPY RSTURN COOZ 3 TALL CORY

All processes run via the BroadMap Hudson CI-System are stored for historical reporting. Each process can

be reviewed, including the Console Output and Build Artifacts from that run.
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- 2151 ESABLE AT REFRES:

() Build #161 (Mar 28, 2011 9:44:40 PM)

O Pre-Rielanse Boild

2

>

Started by user gronpmous
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PRODUCT VALIDATION AND STATISTICS

Once the product creation process is complete, Product Validation and Statistics are then initiated. These
support the BDIA_BBCovStats_ NEWvOLD.py script and the BDIA_QC_SUITES scripts detailed above.

All statistics and reports are stored for historical review with the capability to place violation criticality on
each quality control check, allowing the identification of errors because of project status/completeness
verses project correctness. Example: Typical Speeds populated.

Below is an example of the report provided based on various control points running over a specified
period:

Project BDIA_Product_Validation_CO
This job checks db integrity on file GecCatabase.

Record Error Monitor

4
§

Total Record Emor Cowm

=+ BB_Service_CAlnstitutions Emor  BB_Service_Wireles Error -+ B8_Senice_CensusBlock Ermor
=+ BB_Sanica_Road_Segmant Error -4 Bi_Seanica_Cvandsw Eme

Latest Stats Regression: Lick
Latest Previder Regressen: Liok
=263 Latest Error Regression: Link
e262  aug 5 et descriotion
::: — . . o — [MDisk Usmge: Workspace 23948, Bulds 168
——— . . % e Tast Result Trand
rase |
2357
2356
255
s25¢

|
7l
=153 Auny ]
"

=152

@ =150 s

: Guc,,u[‘];,..;.,.-_,,‘; l__s_é_" Becent Changes
—
Similar to the Product Create process, all results from the process are maintained:

ENABLE AUTO REFRESH
# e [Arrpeey—
\ status | Er——|
Stared 26 days ago
bt

add deseroeon

= Qe
=]
PN

Started by user snonymeus

BOIA STRUCTURE OC SUMMARY
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Results are then reviewed manually to ensure no errors reported are critical or in violation of the NTIA
data model or project completion statements. Any errors of concern are communicated ahead of product
delivery and included within the product release notes. Further detail on the Hudson-Cl System
environment can be found by navigating to the following link:
http://wiki.hudson-ci.org/display/HUDSON/Meet+Hudson

est Errar Regressica:

4 Diseard Old Suik
Configure Discard Old Builds

- A

Q) £ best CAL Regression: <a hrefaito://varmant
Q

F

Dirys to ke buikds
B outs
@ puild History
580 D
s
o o #| Thie build is parameterized
String Parameter
Hame Tastitatl

Cefault valug gois_STRUCTURE

Omuenpten

String Parameter

] GDBLecation

/ReleaseCandidates/C0_20101117.1947

DeSCnEeen  pyrent path for the release candidste GOB

PRODUCT EXTRACT DATA DELIVERY

Product delivery for MapConnectWI Broadband is handled two ways, depending on client requirements:
1) State Submittal:
a. Datais submitted via SFTP site;
b. Product Release Notes and QC Test Report accompany the delivery.
2) NTIA Submittal:
a. Directions for using the NTIA State Broadband Data file submission tool:
(i.) Go to the following website: https://esupport.fcc.gov/statedata;
(ii.) Enter your username and password as provided to you from the NTIA program
administrator;

FCC SUPFORT CENTER

Broadand State Data Managsment Too

Login

Username:*

Paasword: »

(iii.) Click in Upload a file field;
(iv.) Browse to local file for submission using the Browse button. Select file, then select
ATTACH FILE. See example below.
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FCC SUrroRT CENTER
Broadband State Data Management Tool Alaska ligecrgeidenall.gov) Logout

Upload File | View Flles

UPLOAD NEW FILE

Uphosadd Filix

Upload Flle*

CilJaers|20100323142745 _offer20100322 pof CITETam] ATTACHFILE

(v.) Logout/Receipt using the Logout button in the top right of the screen;
(vi.) A receipt of submission is e-mailed to username e-mail address.
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