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This white paper highlights the Submission Summary for this deliverable, as well as describes the Data Gathering,
Data Integration, Data Validation and Verification and Quality Control processes used to create the Broadband
Mapping Project’s October 1%, 2012 data submission. To support varying levels of technical and program
knowledge, both a high-level summary and a detailed process review are supplied.

PROVIDER DETAILS

PROVIDER PARTICIPATION

Providers Included
o |T&E
e MCV

Non-Responsive/Non-Cooperative Providers
e None

Other Provider Comments
e iConnect
e  Currently not a broadband service provider; however they are researching further on
entering the Terrestrial Fixed Wireless market

e GTA
e  Working towards becoming a reseller provider in this area

e Docomo Pacific
e Provided data required for mapping their wireless footprint; however it was removed as
it does not meet the NOFA standards of broadband speeds
Just acquired MCV and we should updated accordingly in the subsequent data
submission

COVERAGE AREA CHANGES

e Coverage Footprint Reductions/Map Refinement —
e |T&E has updated their speeds for this data submission, including their AWNS

e Coverage Footprint Expansion —
e No expansion for this data submission round
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DATA CORRECTIONS

e There were no data corrections required for this data submission
e There was also no NTIA 3™ Party data review results posted on the Broadband State Data
Management Tool that could lead to potential data corrections.

COMMUNITY ANCHOR INSTITUION (CAl) DETIALS

OVERALL STATISTICS

CAIID Count | Transmission Advertised Advertised

Community Anchor Institution - Categories Technology Speed Down speed Up

Category 1 - School K through 12 0 0

Category 2 - Library

Category 3 - Medical/Healthcare

Category 4 - Public Safety

Category 5 - Universities/Colleges

Category 6 - Other: Government

Category 7 - Other: Non-Government

Total

CAl CHANGES

e The CAl's within the following categories were reviewed again against the below-mentioned
databases to identify if any CAIID’s need to be updated or added.

For K-12 institutions (CAl type 1) please add the NCES ID CCD ID value found here:
http://nces.ed.gov/ccd/bat/

For Higher Education (CAl type 5) please add the NCES IPEDS ID value found here:
http://nces.ed.gov/ipeds/datacenter/

For Libraries (CAl type 2) please. Combine (do not add) “FSCSKey” and “FSCs_SEQ” from the
“puout08av2000” file and place them here:
http://harvester.census.gov/imls/data/pls/index.asp_(FYI the LIBID is your state’s unique ID
for libraries)
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SUBMISSION RECEIPT

SUBMISSION RECEIPT RESULTS

e Attached are the results from the NTIA data submission receipt quality script.

=

MP_2012_9_17.txt

e Error Report
The only items detected were for the TT-10 service coverage areas that have a maximum
advertised download speed of 7 and the Middle Mile elevation check.

The technology and speeds were validated by the provider and are within the ranges
communicated in the NTIA data model.

All items are included within the accompanying ReadMe file.

Update: There was an update made to the submission receipt on 09/20/12 that introduced
the longitude issue for Middle Mile layer.
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DATA GATHERING

BROADBAND SERVICE AREAS, MIDDLE MILE AGGREGATION POINTS AND
BROADBAND SERVICE OVERVIEW

The collection of Broadband Service Areas, Middle Mile Aggregation Points and Broadband Service
Overview information is handled through the following Provider Outreach Process:

Build and maintain an inventory of Broadband providers through research and State inputs.

The inventory and everyday interaction with providers is tracked using our Provider Catalog (PCat).
Below are some examples of the web application, which has a shared access between our team and
mapping partner (BroadMap).

.

Edit Clone History AAD

Provider Name

Company Address

Company PO Box

Company House Number

Company Street Name

Company City Name

Company Suite

Company Postal Boundary

Company State

Company Website

Source ID

Child Source

Parent URL

Parent Source ID

User Name

Password

Form 477 Interest

Provider Portal Trained
[Contacts

acmetech (All)

12345
Acme Avenue
Portland

http://www.acmebroadband.com
4909
]

0

]

Source Name acmetech
Source Description
Layer Name TBD
Source Usage Type Tracking
Source Provider Type BroadMap
Source Content Type
Source Restrictions [
Source Restriction Description
TT Types
Asymmetric xDSL
Symmetric xDSL
Other Copper Wireline
Cable Modem-DOCSIS 3.0
Cable Modem-Other
Qptical Carrier/Fiber to the End User
Satellite

Addr Level Data Provided []
Preferred Contact Method

Type Name
P Sourcing
FRN Info

Preferred Phone 1

Phone 2 Position

Provider Name

FRN Number

Name:

FRN: Create FRN

Confidence

TT Type Confidence
Status Tracking

Last Modified

Comment

Non Faciliies Based Provider

Business Only Provider

Reseller

NDA Review - Internal

NDA Review - External
Service Provider Details

]

a
]
]
]

Non Responsive Provider
Non Cooperative Provider
Source Closed

BroadMapper
Initial State Outreach Date
Provider Qrigin

Provider Packet Exchanged
Provider Packet Info Sent
Provider Meeting Status
Technical Meeting Requested
Technical Meeting Scheduled
Number of Subscribers

--None-—

]

--None--
]
]

BroadMap Status Unassigned
Initial Contact Vehicle
Member Association
Initial State Outreach []
NDA Status --None--
NDA Not Required  []
NDA Requested [7]
NDA Exchanged [
NDA Exchange Date
NDA Signed []
NDA Signed Date

Date Loaded
Source Closed Date
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BDIA Delivery 0412 Edit|

Status Provider Data Reviewed []

Outreach Date Provider Data Reviewed Date
Initial Response FootPrint
Meeting Date MiddleMile
No Update Date Subscriber
Waiting For Data Date Provider Login
Data Received Date Provider Login Date

Data Accepted Date
Source Ingested Source Ingested Date

Additional Data

Next Steps

Inactive [ Owner briordan
Created By briordan 2011-06-13 12:06:35 Last Modified By krousseau 2012-03-16 13:41:58

e In order to encourage participation throughout the life of the program, we feel it’s important to
foster relationships with the providers and encourage a collaborative team effort between all
parties for each data submission.

Update provider material that describes the data requirements and logistics for data transfer.
Update Non-Disclosure Agreement (NDA) for use in project, where applicable.
Maintain multiple protocols for the provider to submit data, including Secure File Transfer Protocol
(SFTP) technology when desired.
Conduct one-on-one informational discussions with each provider to communicate the following:
Requirements of this project;
Broadband data required to support the product data model;
Submission protocols available;
0 Capability to validate how the supplied data is aggregated.
Download/receive provider data.
Establish a repeatable process with provider. Maintain provider communication, transaction and data
handling records throughout the project (dates contacted, data received, etc.).

COMMUNITY ANCHOR INSTITUTION (CAl)

The collection of CAl information is handled through the following CAIl Collection Process:
e  Collect and maintain inventory of CAls through data mining, research and State inputs.
e Maintain web-based CAl portal for institutions to add or confirm attribution, location and enter
broadband-specific information.
Upload web-based data to Core Database for standardization.
Perform internal cleansing, such as removing duplicate records, identifying gaps in broadband
attribution and verifying category.
Geocode CAl locations.
Translate Core Database data to deliverable-ready format.
Continue engagement with non-responsive institutions.
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DATA INTEGRATION PROCESS

The data integration and processing mechanisms currently used allow for multiple types of inputs and result in
a standardized output that meets the NTIA deliverable requirements. This flexible process supports data
model changes and project-requested enhancements.
e Receive inputs from providers via submission protocols; upload into Sourcing Database and catalog

with provider information.

Review provider-supplied data for completeness and for potential discrepancies that require

resolution prior to processing and flag as necessary.

Categorize input into data-type category (addresses, block lists, paper maps, etc.).

Standardize input based on data type within Staging Database.

Create Compact Polygons (CP)—(internal methodology for generating area-based feature for

coverage in Staging Database).

Apply broadband attribution to CP; apply metadata to CP.

Perform quality analysis of the CP against the source supplied to identify any completeness or

accuracy issues.

Request additional information from the provider if elements of coverage are missing or contain

discrepancies. This is a second manual quality check to ensure data is complete.

O Process coverage area to build the required NTIA data model layers.

With the deployment of the Provider Portal this round, the data collection and later validation process was
streamlined allowing both activities to occur within a secure web application. The majority of the providers
used this methodology as it’s allows them more visibility into how their data is being represented and gives
them knowledge and ownership of their coverage representation. Below are some bullet points and
supporting screen shots on how the portal is used.

e Each provider is assigned credentials with a strong password to ensure security measures are taken
into consideration

Login

Username

Password

e Collection and confirmation our contact, as well as the company’s DBA Name and FRN accuracy

Contact and Provider Information

Please enter contact information and change provider information if incorrect:

Contactname:  |Kiistin Rousseau
Gontact E-mail:  |Kris rousseau@roadmap.com
ContactPhone: » [603-448-4475

Doing Business As (DBA) Name: + [acmetech [AdaDBEA |

FCC Registration Mumber (FRN): =
Submit

Pleaze note the following:
« Contact info will only be stored when a record is saved

« Provider info will be applied o all service areas
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Capability to review and request changes to the coverage footprint

Broadband Provider Portal

HXQIOP (5 Rl JONNE

L=

Log Qut
Web Application Support
Provider Support

[l Provider Added Area
[l Provider Removed Area

[ Provider ReplacedArea

Select All Zoom to Selected Clear Selection Valid Add Remove Replace Delete Save Edits

The provider can Add/Remove portions, or all, of the footprint requesting that their footprint be

increased or refined.

Broadband Provider Portal
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Middle Mile and Average Weight Nominal Speed (AWNS) collection and validation

= B P Pol
roadband Provider Portal LA VOO
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0 | [ caicuiate awns Save AWNS

File upload functionality to support providers that would prefer a shapefile, spreadsheet, PDF,
KMZ/KML file be used to reflect changes for the data round

Welcome

u Choose a file to upload: Browse_ || UploadFile | (50MB max)

*Uploading a new file with the same name as an existing file vill overwrite the existing file

Uploaded Files

E Please click here to auto-notify BroadMap of your uploads, thanks.

E Logout

e Once the provider has review completed changes to their coverage, middle mile and AWNS, then can
validate them all signing off that everything is accurate.
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DATA VALIDATION AND VERIFICATION

Following the creation of the product, process steps within Data Validation and Verification occur. To ensure
the data collected and processed is as accurate and comprehensive as possible, provider validation and
internal verification activities are employed. After the initial mapping of providers’ coverage areas and
serviceability claims, additional reviews are performed using the methods described in the subsections below
in order of action (Broadband Provider Validation, Third-Party Data Verification, Public Verification, and
Confidence Values).

BROADBAND PROVIDER VALIDATION—PROVIDER PORTAL APPLICATION

Providers are trained on and requested to use a secure interactive web application to review their current
coverage area(s) and supporting broadband attribution and validate their data or submit change requests
to update their data. All provider change requests go through the Data Integration Process and are
reviewed with the provider to complete validation.

With the latest released of the Provider Portal, validation on the coverage area, middle mile and average
could be completed individually. Validation examples are as follows:

Coverage validation can be done on one record/footprint at a time or by selecting footprints and
selecting the ‘Valid’ button. The provider could also print off their coverage for their own tracking
purposes.

Broadband Provider Portal B
L QU9

|| Stastus: Lﬂr

=, T — ) [
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Transmission Technology ~ County AWNSinkbps  Last Modified

DSL Symmetric 2012/03/19 14:39:58

Save AWNS Edits Validate All AWNS Add AWNS Record Delete AWNS Record

All validation results are tracked internally through our Validation Table, which also improves the overall
Confidence Value as mentioned below.

THIRD-PARTY DATA VERIFICATION

For this submission, the NTIA 3™ Party Data summary was reviewed again to ensure any corrections
required were represented in the final product and the supporting documentation. This includes
additional feedback received directly from NTIA, prior to this data submission.

This submission was also compared to the previous data submission, April 2012, as a quality check to
identify and resolve any potential erroneous discrepancies between the two products.

PUBLIC VERIFICATION

The broadband interactive map has been released to the public, which includes functionality to collect
feedback on the provider’s coverage areas, as well as running a speed test. The feedback and speed
results continue to be collected and reviewed with the providers prior to the next data submission to
identify if any map refinement is required.

The public website can be viewed at the following hyperlink:

http://cnmi-bb.broadmap.com/PublicMap/

CONFIDENCE VALUES

All verification, validation and manual quality review results are tracked by provider/technology type and
stored and maintained within a Validation table. A confidence value is assigned, based on internal
assessments of the collected information, to highlight the provider coverage areas and/or attributions
that would benefit from further investigation and/or enhancements.
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With the continued efforts on provider validation, 3" party verification and the release of the public
interactive map with feedback collection functionality, the confidence values will be utilized further to
identify specific areas in need of attention.

QUALITY CONTROL

Following collection, processing and analysis of the provider and CAl data, the product is checked manually
and algorithmically against the NTIA data model. Some of the items included within these checks are:

Format correctness;

Table and field structure;

Valid values, including default values, where applicable;
Geographic extent and topology errors.

Prior to data submission, another quality control script supplied by NTIA is run. This script,
SBDD_CheckSubmission.py, creates an output in text form that is required to be submitted along with the final
deliverable. All errors must come up clean, unless otherwise specified by NTIA.

DETAILED PROCESS REVIEW

To review the detailed process, please review the attached object:

@j

BMap_ProcessDetails
_2012_10_01.docx
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A detailed review of the data collection, integration and quality control points within the broadband data gathering and mapping process are discussed in the subsections that follow. In addition, a diagram showing the overall process can be seen below.









A more detailed process flow can be supplied, upon request.
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For the each data submission, an e-mail notification is sent to all providers with supporting deliverable dates. The providers mainly used the Provider Portal web application to submit changes to and/or validate their current coverage area(s).



In support of the data collection effort, providers that did not respond timely to the outreach were contacted by phone.



[bookmark: _Toc319592860]Outreach Materials

The original provider packet sent via e-mail to the providers included the following documents and files:

Letter from the State inviting them to participate in the program;

Copy of the Non-Disclosure Agreement (NDA);

Copy of the Mapping NOFA from the NTIA;

Copy of the NOFA Clarification from the NTIA;

Broadband service address example file in CSV format;

Word document describing service address example file;

Broadband service block example file in CSV format;

Word document describing service block example file;

Broadband service street example file in CSV format;

Word document describing service street example file;

Broadband subscriber example file in CSV format;

Word document describing subscriber example file;

Broadband wireless coverage area sample shapefile;

Word document describing wireless coverage area sample shapefile;

Instructions for downloading, installing and using the WinSCP SFTP application.



[bookmark: _Toc319592861]Outreach Process

The provider outreach process is comprised of the following general steps:

· Send the provider package and introduction letter to the main point of contact for the provider.

· Follow up with e-mail and telephone to verify that the main point of contact is correct.

· If necessary, discuss the NDA further and resolve any redlines.

· Once the correct primary contact is established, set up a telephone call, if necessary, to learn more about the provider’s offerings and direct them to the appropriate outreach materials.

· If providers are unable to be contacted (non-responsive) or indicate that they are not interested in participating (non-cooperative), mark them as such on the provider tracking sheet. These providers will be escalated to the State for further action.

· As the providers are collecting the required data, provide instructions on downloading, installing and using the WinSCP SFTP application, if required.

· Arrange with the providers to transfer the data in whatever way they are comfortable: some providers will find regular email acceptable; others will want to use the SFTP application.

· After data is received and reviewed, it may be necessary to contact a provider for clarification or to address incomplete datasets. In the interest of building and maintaining relationships, care is given not to push the provider but to work with it to obtain accurate data in the best possible format.




[bookmark: _Toc319592862]Data Collection

[bookmark: _Toc319592863]Data Transfer Procedures

There are three primary ways data is collected from providers. These are:

Secure FTP (SFTP) using the WinSCP application;

Regular e-mail;

Mail.



[bookmark: _Toc319592864]Initial Data Review and Quality Assurance

The initial data review and quality assurance process consists of the following general steps:

1) Access the data from the SFTP site or e-mail.

a. If e-mailed, place copy of original dataset in the appropriate provider folder on the SFTP site.

2) Place copy of raw data on local computer in a working directory.

3) Review data and determine course of action based on type of data received.

4) Ensure data is complete and contact provider to address any gaps.



		NOTE:

The goal is to get as many providers as possible to provide subscriber address data in the correct format. Obviously, this will not be possible with all providers so we will continue to have to process various types of provider-supplied data.







[bookmark: _Toc319592865]Data Ingestion

[bookmark: _Toc319592866]Data Ingestion Overview

The following subsections outline the process steps taken based on the type of input supplied by the data provider:

· Point Data:

· Subscriber location;

· DSLAM location;

· Central Office location;

· Broadcast Tower location.

· Linear Data:

· TIGER® street segments.

· Polygonal Data:

· Census Blocks;

· Coverage Area.

Overall, the process is geared toward taking the provider data supplied and creating polygon shapes to append to the bb_cov feature class. The bb_cov feature class is the interim dataset that is then processed using the makeDeliverable.py Python script to create the MapConnectTM data layers that will be delivered to the State and, ultimately, to the NTIA. Detailed instructions used in this process can be found in the subsections below.
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[bookmark: _subscriber_location—address_data][bookmark: _Toc319592868]subscriber location—address data

In the event that the data provider supplies subscriber address data, the steps are as follows:

1) First, convert the address data to a clean Excel spreadsheet in an appropriate address data format.

a. Usually, this has the following columns: street address (number, pre-directional, pre-modifier, street name, street type, post-directional and post-modifier concatenated), city, state, ZIP.

2) [bookmark: step2subscriber]Configure the ArcGIS® geocoding tool to use the TIGER® 2010 streets dataset.

a. In ArcCatalog®, create a new Address Locater by right-clicking in the white space of the appropriate directory and selecting New>Address Locater from the dropdown menu.

b. Select US Streets with Zone and click OK.



		NOTE:

It is likely that multiple Address Locators will have to be set up to handle the variety of provider address data received.







c. Navigate to the TIGER Streets 2010 file and click OK.

d. Fill in the dialog box, as shown below:

[image: ]




e. Click OK.

3) Open ArcMap® and add the Excel spreadsheet with the address information.

4) Right-click on the Excel spreadsheet and select Geocode Addresses from the dropdown menu.

5) Select the appropriate address locator by clicking Add…, then OK.

[image: ]

6) Fill out the Geocode Addresses dialog box, as shown below:

[image: ]

7) Geocode the list in batch mode using the geocode service set up in Step 2 above, accepting all the default parameters.

8) Review results. See example below.


[image: ]

9) Adjust geocoding parameters accordingly and repeat batch to resolve issues.

10) Manually geocode unmatched addresses until target hit rate achieved, generally 90%.

11) Visually inspect the data, as shown below:

[image: ]

12) Follow the steps detailed in Subscriber Location—GIS Data below.




[bookmark: _subscriber_location—xy_data][bookmark: _Toc319592869]subscriber location—xy data

If the provider supplies a list of subscriber data with accompanying XY data such as latitude and longitude, the steps are as follows:

1) Refine the format in Excel so that the data can be opened easily using ArcMap®.

a. Remove all font color, highlighting, cell colors and borders, clean up column headers and make certain there are no merged cells.

b. Make certain that XY locations are in decimal degrees.

(i.)	To convert from degrees, minutes, seconds (39º 26’ 45.67”) to decimal degrees, use the following formula: DD + (MM/60) + (SS.SSS/3600).



		NOTE:

If XY locations from some other coordinate system are provided, you can use those in the process below but you must know what the coordinate system is.







2) Open the Excel worksheet in ArcMap®.

3) From the menu bar, select Tools>Add XY Data…

[image: ]

4) Supply the appropriate fields for the X and Y coordinates, choose the appropriate coordinate system and click OK.

5) Results are an event layer, not a true spatial layer. Export the data by right-clicking the event layer and selecting Data>Export Data… from the dropdown menu.

6) Follow the steps detailed in Subscriber Location—GIS Data below.




[bookmark: _subscriber_location—gis_data][bookmark: _Toc319592870]subscriber location—gis data

If the provider supplies subscriber location in GIS format, the only process step is to load that data into the appropriate data schema and it will be ready for processing.

1) First, load the data into the Point Address database schema using an empty feature class in that schema.

2) In ArcCatalog®, right-click on the empty feature class and select Load from the dropdown menu.

3) Navigate to the provider address GIS dataset and then map the attribute fields accordingly, as shown below:

[image: ]

4) Once you have successfully loaded the provider address data into the temporary database with the correct schema, you now will append that data to the overall Point Address database.

5) In ArcToolbox®, use the Append command (Data Management Tools>General> Append) to add the features into the overall Point Address database, as shown below:




[image: ]

6) Since the data is already in the Point Address database schema, there is no need to alter the Field Map in the Append tool.

7) After appending, calculate metadata reflecting geometry source and representation values.

8) Break provider-specific points into separate county feature classes and perform the following steps per county feature class:

a. Within ArcGIS®:

(i.) Summarize download and upload speeds [first,last] to determine all speeds available for county.

(1) This will save as a DBF table. Keep track of location for future reference.

(ii.) Buffer county address point featureclass to 150’.

[bookmark: duringbuffercommand](1)	During buffer command, dissolve on ad_down; ad_up; provider; dba; frn; tt; all metadata fields; stctyfips. Save as…. county_fastestdown_fastestup. 

(2) Example using Qwest data: boulder_40128_20128, where boulder=county; 40128=ad_down; 20128=ad_up.



		NOTE:

These attribute fields are specific to the Point Address database.







(iii.) Select the features that represent the lowest speeds.

b. Using XtoolsPro (http://www.xtoolspro.com/):

(i.) In the XTools Pro toolbar, select XTools Pro>Layer Operations>Erase Features.

(ii.) Use the same feature class for Input and Overlay.

(iii.) Check Use selected features on the Input feature, as shown below.

(iv.) Repeat and erase slowest speeds one speed at a time. Save each new feature class as the next slowest speed, using the same naming convention as shown in a.(ii.)(1) above. A general example is shown below:




[image: ]

c. Return to ArcGIS®:

(i.)	Edit/delete speeds from the attribution table of each feature class, so each remaining feature class has only one speed value.

(ii.)	Merge individual speed feature classes using the Merge command in ArcToolbox® (Data Management Tools>General>Merge). The dialog box is shown below: 

[image: ]

(iii.)	Merge individual county feature classes using the Merge command in ArcToolbox (Data Management Tools>General>Merge).

(iv.)	Since the county files are all in the same schema, DO NOT alter the Field Map portion of the command interface.


(v.)	When all the county files are merged into one dataset, use the Append command in ArcToolbox® (Data Management Tools>General>Append) to add the features to the bb_cov interim dataset. Use the Field Map portion of the Append tool to map the appropriate field values to their corresponding fields in the bb_cov feature class.

[bookmark: _Toc319592871]dslam or central office location—address data

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central Office address data, the steps are as follows:

1) Follow the process for geocoding points in Subscriber Location—Address Data above.

2) Follow the steps detailed in DSLAM or Central Office Location—GIS Data below.

[bookmark: _Toc319592872]dslam or central office location—xy data

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central Office XY data, the steps are as follows:

1) Follow the process for creating points from XY data in Subscriber Location—XY Data above.

2) Follow the steps detailed in DSLAM or Central Office Location—GIS Data below.

[bookmark: _dslam_or_central][bookmark: _Toc319592873]dslam or central office location—gis data

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central Office GIS data, the steps are as follows:

1) Buffer the DSLAM/Central Office points feature class.

a. Add the point feature class to ArcMap®.

b. Open the ArcToolbox® and go to Analysis Tools>Proximity>Buffer.

c. Set the buffer distance to 5 miles.

d. Set the dissolve type to ALL.

e. Name the output feature class.

f. Typical Buffer tool is shown below:

[image: ]

g.	Click OK.

2) Use the resulting buffer feature class to clip the TIGER® street layer:

a. Add TIGER® street layer to ArcMap®.

b. Open the ArcToolbox® and go to Analysis Tools>Extract>Clip.

c. Complete the dialog box as shown below:

[image: ]

d. Click OK.

3) Using ArcCatalog® and within the file geodatabase:

a. Right-click and create a new Feature Dataset. 

(i.)	For the Feature Dataset settings:

(1) Name the feature dataset accordingly.

(2) Select horizontal coordinate system by importing the coordinate system associated with the clipped TIGER® street layer by selecting Import and navigating to the location of that feature class.

(3) No vertical coordinate system needed.

(4) Leave all x,y,z,m values at default.

(5) Click Finish.

4) Import previously created street feature class into new Feature Dataset.

5) [bookmark: step5]Right-click Feature Dataset and create new Network Dataset—accept all default setting for the Network Dataset.



		NOTE:

The Network Analyst extension must be turned on.







6) In ArcMap® turn on the Network Analyst Toolbar by going to View>Toolbars>Network Analyst.

7) Add the Network Dataset created in Step 5 to ArcMap.

8) Using the Network Analyst Toolbar dropdown, create New Service Area.

9) Open the Network Analyst Window by selecting the [image: ] button. See below.

[image: ]

10) Right-click Facilities layer, select Load Locations and navigate to the DSLAM/Central Office facilities feature class.

[image: ]

11) Click OK.

12) Click the Service Area Properties button [image: ].

13)  For the following tabs, change the following properties:

a. Polygon Generation tab: 

(i.)	Select Merge by break value. 

(ii.)	Also disable the Trim Polygons option.

b. Analysis Settings tab—using and converting the specified DSLAM buffer distance from feet to meters—input buffer distance value in meters into the Default Breaks location.

(i.)	Generally, 18,000 feet (5486 meters) from DSLAM or Central Office location is used as the buffer distance. See below.

[image: ]

c. Click OK.

14) On the Network Analyst Toolbar, click the Solve button [image: ] to create service area polygons.

15) Right-click on the created service area polygon in the layer list, and select Data>Export Data from the dropdown list.

16) [bookmark: step16]Export to a feature class in the file geodatabase you created earlier.

17) In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and load the feature class created in Step 16 into it.

a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and navigate to the location of the service area feature class.

b. Click the Add button, then click Next.

c. Accept the defaults and click Next.

d. DO NOT attempt to map any fields, as shown below:

[image: ]

e. Click Next, then Next again, then Finish.

18) In ArcToolbox®, go to Data Management Tools>General>Append.

19) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

[image: ]

20) Leave the Schema Type as TEST.

21) Click OK.

22) In ArcMap®, open bb_cov for editing and manually input associated attribution.




[bookmark: _Toc319592874]broadcast tower location—address data

In the event that the provider supplies wireless broadcast tower location address data, the steps are as follows:

1) Follow the process for geocoding points in Subscriber Location—Address Data above.

2) Follow the steps detailed in Broadcast Tower Location—GIS Data below.

[bookmark: _Toc319592875]broadcast tower location—xy data

In the event that the provider supplies wireless broadcast tower location XY data, the steps are as follows:

1) Follow the process for creating points from XY data in Subscriber Location—XY Data above.

2) Follow the steps detailed in Broadcast Tower Location—GIS Data below.

[bookmark: _broadcast_tower_location—gis][bookmark: _Toc319592876]broadcast tower location—gis data

In the event that the provider supplies wireless broadcast tower location GIS data, the steps are as follows:

1) Download the required software (Radio Mobile) from the website: http://www.cplus.org/rmw/english1.html 

2) Install the software according to the standard directions, found here: http://www.cplus.org/rmw/download/download.php?S=1 

3) Open the application.

4) Load the broadcast tower location and elevation information by selecting File>Unit properties. The following dialog box appears:

[image: ]

5) Add the information for all the towers supplied by the WISP data provider, including the elevation. If provider does not supply elevation, this information can be obtained from Google Earth.

a. If available, use the Import button to import a Google Earth KML of the tower locations.

6) Go to the National Map Seamless Server (http://seamless.usgs.gov/) and download elevation data sufficient to contain the tower locations.

a. At least the 1/3” NED data is needed. Select this by clicking the Download button in the upper right of the website and checking the box next to 1/3“ NED.

b. Zoom to the area of interest and use the Download tools to define the area to download:

[image: ]

c. Click the Modify Data Request button to request the data in BIL_16INT format, not ESRI GRID, as shown below:

[image: ]

d. Download the data and unzip it.

7) Select File>Map Properties to define the map.

8) Enter a latitude and longitude in the center of the tower locations.

9) Set the size (in pixels) and the size (in kilometers) of the map.

10) Set the directory path leading to the BIL elevation data just downloaded.

11) The dialog box is shown below:

[image: ]

12) Click Extract.

13) The elevation data is rendered as a hill shade, as shown below:

[image: ]

14) Select File>Network properties from the main menu.

15) Create a new network and enter in the frequency range under the Parameters tab, as shown below:

[image: ]

16) Leave all the other values as they appear, and select the Systems tab.

17) Create enough systems to cover all the varieties of equipment in the provider network. This will include the antenna type, height and line loss, as shown below:

[image: ]



18) Now click on the Membership tab, and assign the individual towers to their respective systems, providing the azimuth for non-omnidirectional antennas, as shown below:

[image: ]

19) Click OK.

20) Select Tools>Radio Coverage>Combined Cartesian from the main menu.

21) Complete the dialog box as shown below, providing the Maximum Range from the highest tower beam radius supplied by the provider.

22) Set the Pixel Size at 5 (experiment depending on the area covered to get the right level of granularity), as shown below:

[image: ]

23) Set the Signal range to draw to S-Unit and type 5 in the From (>=) box.

24) Click on Draw. See below.



[image: ]

25) Save the resulting image as a TIF by selecting File>Save Picture as.

26) Open ArcMap® and load the BIL elevation data you used in Radio Mobile.

27) Load the TIF image you created and georeference it using the corners of the BIL data.

a. The corners of the data can be seen in the TIF image.

28) Follow the georeferencing directions from the Coverage Area—PDF/JPG/Other Image Format section below.

29) Use the Georeferencing Toolbar to Update the Georeferencing for the TIF dataset.

30) In ArcToolbox®, select Data Transformations>From Raster>Raster to Polygon and input the georeferenced TIF you just created.

31) Open the resulting polygon feature class for editing using the Editing toolbar in ArcMap® and clean up as necessary.

32) In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and load the feature class created above into it.

a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and navigate to the location of the service area feature class.

b. Click the Add button, then click Next.

c. Accept the defaults and click Next.

d. DO NOT attempt to map any fields, as shown below:



[image: ]

e. Click Next, then Next again, then Finish.

33) In ArcToolbox®, go to Data Management Tools>General>Append.

34) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

[image: ]

35) Leave the Schema Type as TEST.

36) Click OK.

37) In ArcMap®, open bb_cov for editing and manually input associated attribution.




[bookmark: _Linear_Data][bookmark: _Toc319592877]Linear Data

[bookmark: _tiger_street_segments—list,][bookmark: _Toc319592878]tiger® street segments—list, spreadsheet or gis data

In the event that the provider supplies TIGER® street segments in list or spreadsheet format, the steps are as follows:

1) Join TIGER® road segments to 2000 census blocks feature class using one of two methods based on how the data is provided:

a. If the TIGER® data is provided with a Census Block ID, then join the segments to the Census Block geometry based on that ID:

(i.)	Load both datasets into ArcMap®;

(ii.)	In the layer list, right-click on the 2000 census block feature class and select Joins and Relates>Join;

(iii.)	In the dialog box, select the TIGER® road segments data and the proper attribute fields for joining, as shown below:

[image: ]

(iv.)	Click OK.

b. If the data provided is a list containing TLIDs, then join to the TIGER®/Line data using the TLID, and use a spatial join to associate the TIGER® segment with the coterminous block based on the block ID:

(i.)	Load both datasets into ArcMap®;

(ii.)	In the layer list, right-click on the 2000 census block feature class and select Joins and Relates>Join;

(iii.)	Select Join data from another layer based on spatial location from the dropdown menu;

(iv.)	Complete the dialog box, as shown below and click OK.

[image: ]

2) Export joined records into a temporary feature class.

3) If joined Census Block geometry is confined to one specific area, then dissolve blocks into one record. If joined Census Block geometry is distributed throughout a particular State, then dissolve sub-selections of census blocks for each county.

a. Use the County FIPS code to dissolve by county.

b. In ArcToolbox®, select Data Management Tools>Generalization>Dissolve.

c. Complete the Dissolve dialog box, as shown below:

[image: ]

d. Click OK.

4) For each dissolved region, open the feature class for editing using the Editing tool in ArcMap® and remove unnecessary slivers and other small holes. For general guidance on editing features in ArcMap®, see http://webhelp.esri.com/arcgisdesktop/9.3/pdf/Editing_Tutorial.pdf 

5) In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and load the feature class created above into it.

a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and navigate to the location of the service area feature class.

b. Click on the Add button, then click Next.

c. Accept the defaults and click Next.

d. DO NOT attempt to map any fields, as shown below:



[image: ]

e. Click Next, then Next again, then Finish.

6) In ArcToolbox®, go to Data Management Tools>General>Append.

7) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

[image: ]

8) Leave the Schema Type as TEST.

9) Click OK.

10) In ArcMap®, open bb_cov for editing and manually input associated attribution if necessary.




[bookmark: _Polygonal_Data][bookmark: _Toc319592879]Polygonal Data

[bookmark: _coverage_area—pdf/jpg/other_image][bookmark: _Toc319592880]coverage area—pdf/jpg/other image format

In the event that the provider supplies coverage area data in some image format such as PDF or JPG format, the steps are as follows:

1) If in PDF format, open in Adobe Acrobat and Save As… JPG format.

2) Open the JPG image in ArcMap®.

3) Add the required base map vector data for georeferencing.

a. This generally will be either the CDOT data or TIGER® data.

4) Change the coordinate system of the data frame to the desired end coordinate system.

5) Zoom to the general location of the JPG map image.

a. This is the location based on the vector data, not the JPG image itself. For example, if you know that the JPG image represents an area around the town of Limon, zoom to the town of Limon in your vector data.

6) Open the Georeferencing toolbar by selecting View>Toolbars>Georeferencing from the main menu bar.

7) Using the Georeferencing toolbar, select Fit to Display; results are shown below:

[image: ]

8) Use the Control Point button [image: ] to add control points to the map.

9) Use common points in the base dataset and the JPG image.

a. For example, find major street intersections, county/city boundaries, etc.

b. Try to distribute the points more or less in the four corners on the image for the best transformation.

10) Click on the location on the image first, then click on the corresponding location on the vector database map, as shown in the image below:



[image: ]

11) After placing each control point, the image transformation will update automatically. 

12) Repeat until satisfied with the transformation.



		NOTE:

The transformation may take up to four points, although sometimes only two are necessary.







13) When satisfied with the transformation, select Update Georeferencing from the Georeferencing toolbar dropdown.

a. This will create a “world” file (.jgw in the case of JPGs) in the same directory as the image file.

14) In ArcCatalog®, create a new polygon shapefile with the appropriate data schema for a provider coverage area.

15) Add the shapefile to ArcMap®.

16) Using the Editor toolbar, select Start Editing. Set the Task to Create New Feature.

17) Use the Sketch Tool [image: ] to digitize a new coverage polygon using the coverage area outline from the georeferenced JPG and add the required attributes manually.

18) Repeat the above steps for all subscriber speed coverage areas provided.

19) Follow the steps detailed in Coverage Area—GIS Data below.

[bookmark: _Toc319592881]coverage area—kml/kmz

In the event that the provider supplies coverage area data in Google Earth KML or KMZ format, the steps are as follows:

1) Use a KML to SHP converter to translate file into an Esri® format.

2) http://arcscripts.esri.com/details.asp?dbid=15603 

3) Download the script and follow the provided instructions for installing it in ArcToolbox®.

4) Double-click on the script in ArcToolbox® and navigate to the location of the KML file, as shown below:



[image: ]

5)	Add the new shapefile to ArcMap®. Repeat for all KML files provided.

6)	Follow the steps detailed in Coverage Area—GIS Data below.

[bookmark: _Toc319592882]coverage area—cad data

In the event that the provider supplies coverage area data in GIS format, the steps are as follows:

1) Transform the CAD dataset into an Esri® format.

2) http://webhelp.esri.com/arcgisdesktop/9.2/index.cfm?TopicName=Transforming_CAD_datasets

3) It may be necessary to contact the provider first to determine the coordinate system of the CAD data.

4) If the CAD data is not in a standard coordinate system, it may be necessary first to use ArcMap® to georeference the CAD data to a known coordinate system.

a) To do so, follow the instructions provided above in Coverage Area—PDF/JPG/Other Image Format.

5) In ArcCatalog®, create a new polygon shapefile with the appropriate data schema for a provider coverage area.

6) Add the shapefile to ArcMap®.

7) Using the Editor Toolbar, select Start Editing. Set the Task to Create New Feature.

8) Use the Sketch Tool [image: ] to digitize a new coverage polygon using the coverage area outline from the georeferenced CAD file and add the required attributes manually.

9) Follow the steps detailed in Coverage Area—GIS Data below.

[bookmark: _coverage_area—gis_data][bookmark: _Toc319592883]coverage area—gis data

In the event that the provider supplies coverage area data in GIS format, the steps are as follows:

1) In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and load the GIS feature class either created above or supplied by the provider into it.

a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and navigate to the location of the service area feature class.

b. Click on the Add button, then click Next.

c. Accept the defaults and click Next.

d. DO NOT attempt to map any fields, as shown below:



[image: ]

e. Click Next, then Next again, then Finish.

2) In ArcToolbox®, go to Data Management Tools>General>Append.

3) Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

[image: ]

4) Leave the Schema Type as TEST.

5) Click OK.

6) In ArcMap®, open bb_cov for editing and manually input associated attribution, if necessary.

[bookmark: _Toc319592884]compact polygon from subscriber points 

1) Geocode address list using latest State Composite Locator. 

2) Verify that your geocoded file has only one TT (Technology Type). If not, export individual geocoded layers for each Technology Type.

3) For each TT, check for differences in speed values or speed tiers and create separate layers for each speed value/tier.

4) Clean your geocoding results: remove any points that geocode to accuracy levels below ZIP+4 (ZIP centroids, carrier route centroids, etc). Also, verify that outliers with acceptable accuracy levels are legitimate, i.e., fall in correct city and Zip.

5) Perform spatial join between county polygons (using stcnyfips field) and the cleaned geocoded subscriber points in order to carry the county name and stcnty fips.

6) Summarize the number of subscribers by county and use the subscriber counts by county to populate the Rate Tier table.

7) Un-join the county data from the geocode subscribers list.

8) Create Compact Polygon using cleaned geocoded layer or sub-selection of XtoolsPro—ConvexHull-DetailedHull option. A sub-selection of geocoded points will be used in areas where more than one polygon will need to be created for one provider’s service area.

9) Evaluate output Hull carefully, looking for areas that should not be covered by hull polygon.

a. If it is determined that an area or areas should not be represented in coverage area, manually reshape hull polygon until coverage area is adequate.

b. When not obvious and as a general rule, manually resolve compact polygon when the distance between the subscriber points used to define the outer boundary of the compact polygon exceeds 5 miles . When reshaping the hull polygon, snap to the outermost geocoded points. See the three figures below for examples.

      Compact Hull: Manual Resolution Required           

[image: SD_BBpoly_Ingest6.jpg]



Compact Hull: Manual Resolution Required                                        Compact Hull: After Manual Resolution        [image: CompactHull_Manual_1.jpg]                     [image: CompactHull_Manual_2.jpg]

10) To attribute the compact polygon, perform a spatial join where your Target Feature Class is the compact polygon and the Join Feature Class is your geocoded point layer. Export compact hull with joined attributes and name file appropriately.

11) Append attributed compact polygon to Broadband TT template Feature Class and, if required, manually input any provider attribution that may not have carried over in the append process.

12) Intersect compact polygon with county boundaries to create unique records by county and use the state-county-fips field to populate stcty_fips field. Also use the county name field to populate the BBCov_Name field.

a. Exception: where a provider’s coverage is distributed throughout more than one area of any given county where the BBcov_Name should be populated using an appropriate city or other logical name based on geographical location.

13) Export/load into appropriate BB TT model dataset.

[bookmark: _Toc319592885]census blocks—list or spreadsheet

In the event that the provider supplies census block data in a list or spreadsheet, the steps are as follows:

1) Ensure block polygons supplied by the provider are 2000 currency.

2) If other currency, convert to 2000 currency before proceeding.

a. To do this, remove the trailing letter (a, b, etc.) from the block ID.

b. You will now have two blocks that equate to one block in the 2000 block geometry.

c. Delete duplicate block IDs, retaining the higher service tier in each case.

3) Prepare the block list in clean Excel format, removing all Excel-only formatting, merged cells, colors, borders, etc.

4) Import the spreadsheet into ArcMap®.

5) Right-click on the 2000 census block feature class in the layer list in ArcMap® and select Joins and Relates>Join from the dropdown menu. Join the census block list to the 2000 census blocks feature class using the block ID and export joined records in a new feature class. The Join dialog box and process can be seen above in the TIGER® Street Segments—List, Spreadsheet or GIS Data subsection.

6) Follow the steps in Census Blocks—GIS Data below.

[bookmark: _census_blocks—gis_data][bookmark: _Toc319592886]census blocks—gis data

In the event that the provider supplies census block GIS data, the steps are as follows:

1) Ensure that the blocks supplied by the provider are in the required data schema and are complete as far as required attribution.

a. If not, manually enter the required attribution or contact the provider to fill gaps.

2) If census block geometry is distributed throughout more than one county, then select Data Management Tools>Generalization>Dissolve in ArcToolbox® and dissolve based on County/Provider/TT/Speed Tier so that unique records are created for each unique combination.

a. The Dissolve dialog box is shown above in the TIGER® Street Segments—List, Spreadsheet or GIS Data section.

b. Two examples of undissolved census block polygons are shown below:

[image: BLOCK_unDISS_OR.jpg]

Undissolved census block polygons

[image: BLOCK_DISS_OR.jpg]

Census block polygons dissolved by county

3)	For each dissolved region use the Editing toolbar in ArcMap® to remove unnecessary slivers and other small holes.

4)	In ArcToolbox®, select Data Management Tools>General>Merge and merge the processed polygons into a single layer.

5)	The merged census blocks will need to have the subscriber’s frn field added and populated.

6)	In ArcCatalog®, create an empty feature class with the schema of the bb_cov feature class and load the GIS feature class either created above or supplied by the provider into it.

a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and navigate to the location of the service area feature class.

b. Click the Add button, the click Next.

c. Accept the defaults and click Next.

d. DO NOT attempt to map any fields, as shown below:

[image: ]

e. Click Next, then Next again, then Finish.

7)	In ArcToolbox®, go to Data Management Tools>General>Append.

8)	Append the formerly empty feature class to bb_cov, completing the dialog box, as shown below:

[image: ]

9)	Leave the Schema Type as TEST.

10)	Click OK.

11)	In ArcMap®, open bb_cov for editing and manually input associated attribution, if necessary.



[bookmark: _Toc319592887]Metadata Transactions

Following any updates or changes completed within the file geodatabase (fGDB) stored on the GIS-Analysts staging environment, the GIS-Analyst runs transactions to compare that fGDB with the one stored on the Core server to ensure metadata on all changes is recorded.



The steps taken to run transactions on the updated Core database are outlined below:

1) Open a command line window and run generateTransactions.py: 

a. Usage: generateTransactions.py  [Core fGDB] [Staging Environment fGDB] 

b. Example of command line: 

<path>generateTransactions.py <path>ST_BB_POLY_SRV_AREAS.gdb <path>ST_BB_POLY_SRV_AREAS.gdb 

2) Shown below is an example of the output screen that will be displayed:



[image: ]

[image: ]



3) After the process has completed, results can be found in the ST_BB_POLY_SRV_AREAS_HIST.gdb: 

a. The transactions scripts records changes at a feature level.

b. Shown below is a screenshot supporting the directory structure of the historical fGDB.

[image: ]



c. Attribution associated with each added/removed/changed feature is tracked, including the following additional columns appended to the end of each:

(i.)	Commit_by

(1)	Records the GIS-Analyst who committed the changes to the historical fGDB.

(ii.)	Commit_date

(1)	Records the date and time stamp on which the changes were committed.

(iii.)	Trans_type

(1)	This field reflects the type of change recorded;

(2)	Categorized by: Adds/Change/Deletes.

(iv.)	New_values

(1)	Records the new values when a change was completed on a feature. Example: Name or speed change.

d. MD_Process also is transferred from the edited fGDB to the historical fGDB, which states the actions completed by the GIS-Analyst.

[image: ]



[bookmark: _Toc319592888]Data Processing

[bookmark: _Toc319592889]Data Processing Overview

The following subsections detail the steps and layout required to process the service provider data further to meet NTIA requirements:

· Weighted Nominal Speed;

· Middle Mile;

· Broadband Coverage Template.



[bookmark: _Weighted_Nominal_Speed][bookmark: _Toc319592890]Weighted Nominal Speed

The weighted nominal speed is populated in one of the following two ways: subscriber data supplied by provider or value supplied by provider.

[bookmark: _subscriber_data_supplied][bookmark: _Toc319592891]subscriber data supplied by provider

Where the data provider supplies subscriber speed information, the following formula from the NOFA is used:

(speed tier-1 in kbps × no. of tier-1 subscribers) + (speed tier-2 in kbps × no. of tier-2 subscribers) + (etc.)

Total average monthly subscribers



Data is initially broken up in the following order:

1) Stcty_fips;

2) Transmission technology type;

3) Subscriber tiers.

[bookmark: _value_supplied_by][bookmark: _Toc319592892]value supplied by provider

Some providers will supply their weighted nominal speed. In these cases, the data supplied will be populated instead of using the NOFA formula. These obtained or calculated values are used to update the service overview layer.



This can be done manually or by creating a table with the provider’s FRN and average weighted speed and joining it to the service overview table in ArcMap®.

1) To join, right-click on the layer to join to and select Joins and Relates>Join from the dropdown menu.

2) Then navigate to the table to join to and select the join fields from the dropdown list.

3) Then open the source table (the table in ArcMap®) and right-click on the header of the Average Weighted Speed field and select Calculate Field from the dropdown menu.

4) Use the value of the average weighted speed from the joined table.



[bookmark: _Middle_Mile][bookmark: _Toc319592893]Middle Mile

Middle mile information generally is provided in spreadsheet or text file format. The process is to take what is supplied by the provider and translate it into the required data schema.

1) If the data is supplied with address information, follow the process outlined above in Subscriber Location—Address Data.

2) If the data is supplied with associated XY coordinates, follow the process outlined above in Subscriber Location—XY Data.

3) Once the data is in GIS format, use the Append (Data Management Tools>General>Append) command in ArcToolbox® to append the data to the overall middle mile dataset.

4) Set the schema type to NO_TEST and use the Field Map to map the attribute fields from the source to the target dataset.




[bookmark: _Broadband_Coverage_Template][bookmark: _Toc319592894]Broadband Coverage Template

The table below lists descriptions of the fields within the bb_cov layer, which is the interim dataset used to create the final product deliverable.



		ALIAS

		DESCRIPTION



		SHAPE

		Internal Shape storage



		OBJECTID

		Internal Object ID



		RECORD_ID

		Unique ID for this record, and is required for Transactional updates to function properly.



		STATE_COUNTY_FIPS

		State/County FIPS code



		PROVIDER_ID

		Unique numeric identifier for each provider (Parent Source ID)



		PROVIDER_NAME

		Unique name for each provider



		DOING_BUSINESS_AS

		An alternative "Doing-Business-As" name for the provider



		TYPE_OF_PROVIDER

		Type of Provider (1:Broadband provider as described in the NOFA, 2:Reseller, 3:Unknown, 4:Business Only)



		FCC_REGISTRATION_NUMBER

		Provider FCC Registration Number



		BBCOV_NAME

		BroadMap Broadband Coverage name (usually Place or County name)



		TECHNOLOGY_OF_TRANSMISSION

		Unique code for the transmission technology type described by this layer



		SPECTRUM_CODE

		Unique code for the spectrum [WIRELESS ONLY]



		MAXIMUM_ADVERTISED_DOWNSTREAM_SPEED

		Maximum advertised downstream speed available within given area (speed tier)



		MAXIMUM_ADVERTISED_UPSTREAM_SPEED

		Maximum advertised upstream speed available within given area (speed tier)



		TYPICAL_DOWNSTREAM_SPEED

		Typical downstream speed available within given area (speed tier)



		TYPICAL_UPSTREAM_SPEED

		Typical upstream speed available within given area (speed tier)



		MD_GEOMETRY

		Metadata: Comma separated list of source id's from which the polygon extent was produced



		MD_EXISTS

		Metadata: Comma separated list of source id's used in understanding and editing this feature



		MD_WHO

		Metadata: Name of the editor who last edited this feature at the time in md_when



		MD_WHEN

		Metadata: Date/time that this feature was last edited



		MD_PROCESS

		Metadata: Comma separated list of processed used to create and/or modify this layer



		SHAPE_AREA

		Area in square decimal degrees



		SHAPE_LENGTH

		Length in decimal degrees 







[bookmark: _Verification_and_Validation][bookmark: _Toc319592895]Verification and Validation

[bookmark: _Toc319592896]provider validation—provider portal

Following the collection and aggregation of provider data, the aggregated data is validated by the provider to ensure it is an accurate representation of their coverage area and supporting broadband information.

· This validation is completed through the Provider Portal web application, which is a secure interactive map that displays the provider’s coverage areas and allows the provider to validate, submit feedback or request changes.

· If changes are requested, then the features on the portal are updated and an automatic request is sent to the provider to complete the validation process.

· Providers that did not use the Provider Portal are asked to validate a PDF map displaying their coverage area(s). This is accomplished via e-mail notification.

[bookmark: _Toc319592897]provider verification—third party source review

After the provider has validated its coverage areas, a third-party source comparison and analysis is performed.

· Where anomalies or discrepancies are identified, a “SCAN” point is dropped and descriptive comments are applied to be reviewed later with the provider.

· During the provider review, the map is displayed along with the “SCAN” points and potential refinement is completed based on input from the provider.

The table below shows third-party sources used:

		
THIRD-PARTY SOURCE NAME

		SOURCE TYPE

		VERIFICATION TYPE



		InfoUSA

		Consumer and Business Listings

		Community Anchor Institutions;

Can also be used for demographic information supporting the State websites.



		Pitney Bowes (PBBI)

		Exchange Info Plus (Central Office Locations)

		Exchange datasets are used to verify the following Transmission Technologies (TT):

Asymmetric xDSL (10), Symmetric xDSL (20), Other Copper Wireline (30), and Optical Carrier/Fiber to the End User (50).



		Media Prints

		Cable Boundaries

		Used to verify the following TT:

Cable Modem—DOCSIS 3.0 (40) and Cable Modem—Other (41).



		American Roamer 

		Wireless Coverage Patterns (EVDO, GPRS, WISP, HSPA)

		Used to verify the following TT:

Terrestrial Fixed Wireless—Unlicensed (70), Terrestrial Fixed Wireless—Licensed (71) and Terrestrial Mobile Wireless (80).



		ComSearch

		Wireless Spectrum Holdings and Tower Data

		Used to verify the following TT:

Terrestrial Fixed Wireless—Unlicensed (70), Terrestrial Fixed Wireless—Licensed (71) and Terrestrial Mobile Wireless (80).










[bookmark: _Toc319592898]assigning confidence values

All findings and results from the abovementioned validation and verification activities, plus internal peer quality reviews, are captured and tracked in a Validation table (see example on the following page) and form the basis of the confidence value assigned for each provider and then each technology.

		CONFIDENCE VALUE

		DESCRIPTION



		    0

		Coverage area has not been reviewed.



		  10

		Extremely Low:

Single Source QC.  



		  20

		[bookmark: OLE_LINK3]Very Low:

Needs additional validation\verification.



		  30

		[bookmark: OLE_LINK4]Low:

Even with validation\verification, coverage still is suspect.



		  40

		Acceptable:

Confirm with State prior to shipment.



		  50

		Meets requirements to be included in shipment.



		  60

		[bookmark: OLE_LINK7]Moderate:

Meets NTIA/State’s standards, representative of Technology Type (TT).



		  70

		High:

Accurate representation of coverage based upon TT.



		  80

		[bookmark: OLE_LINK9]Very High:

Multiple validation\verification with most third-party sources.



		  90

		[bookmark: OLE_LINK11]Extremely High:

Multiple validation\verification sources.



		100

		[bookmark: OLE_LINK12]Perfect:

Multiple validation\verification sources, with complete alignment with sources and ground truth verification activities.







The Validation table is maintained as updates or changes occur for each provider, down to technology type, with the overall goal to improve the confidence values and overall map representation. 





[bookmark: _Toc319592899]Community Anchor Institution (CAI) Data

[bookmark: _Toc319592900]data collection

The CAI data was initially collected from the State to create the baseline inventory. All location information and broadband coverage data supplied also was ingested into the data deliverable. Additional collection of CAI information was done via data mining and/or webscraping to build out the inventory further. For example: Collection of additional CAIs and location information.



The State-agency-provided CAI inventory was comprehensive but the challenge is collecting broadband related data: service provider(s), technology and speed data for each CAI. Availability of the CAI portal has not significantly increased submission of this data. Additional promotion to CAIs to use the CAI portal will be needed to increase this data for subsequent deliverables.

[bookmark: _Toc319592901]institution data

Institution data is obtained from a variety of sources and almost always provided in Excel spreadsheet format. The general process for incorporating this data is as follows:

1) If the data is provided in Excel or some similar format:

a. Clean and standardize the Excel spreadsheet, removing any cell formats, merged cells, etc.

b. Standardize the address format as defined in the staging CAI database.

c. If the spreadsheet includes X and Y values, such as latitude and longitude, use the Add XY Data tool in ArcMap® to create a spatial data layer.

d. If there are only addresses, then follow the geocoding steps outlined above to create spatial data points for each of the institutions.

(i.)	Institutions that do not geocode based on the TIGER® 2010 dataset will have to be located manually using Google Maps, Google Earth or some other information source.

2) If the CAI source data is in GIS format, add the Latitude and Longitude fields and use the Calculate Geometry tool to populate them, using the WGS 84 coordinate system.

3) Using ArcCatalog®, load the new data into the staging CAI database.

4) This database is ready for the makeDeliverable.py script to process the information into the final State and NTIA deliverables.

[bookmark: _Toc319592902]community anchor institution (cai) portal updates

A web application has been released to allow for further data collection and validation of anchor institution location information, broadband coverage and speed test data. Information collected from the CAI Portal is then ingested into the overall inventory and will be compared later against the provider coverage areas mapped to locate any potential discrepancies.



[bookmark: _Toc319592903]Product Extract

[bookmark: _Toc319592904]Python Scripts

The following subsections make use of Python scripts. In general, to use a Python script you must have Python installed on your computer. To download the latest version of Python, go to http://www.python.org/download/ and download the latest stable version. As of August 2010, this was version 2.7. Once this is installed, the general way to run a script is to type the following at a command prompt: C:\Python27\python.exe C:\<location of script>. Many of the scripts provided have environment variables that must be set before they can be run.



The Python code for BroadMap’s product extract has been incorporated into a Hudson CI System, which is detailed in the Process Operation and Monitoring section of this document. This was a process improvement activity so that all processes can be monitored, controlled and will contain historical tracking on each process.



[bookmark: _Toc319592905]Product Extract Process

		NOTE:

Specific Python scripts are called out in red font in the subsections below.







[bookmark: OLE_LINK1][bookmark: OLE_LINK2]The MapConnectTM product extract process, BDIACreateSBDDOutputMigratedBBCov.py, uses our internal BB_Cov model to create the following layers rolled up to NATL_Broadband_Map in accordnace to the current NTIA data model specifications.

· BB_Service_RoadSegment

· This layer contains all broadband services associated with specific street segments for census blocks larger in area than two square miles.

· BB_Service_CensusBlock

· Contains all broadband services associated with census blocks of no greater than two square miles.

· BB_Service_Wireless

· This layer contains all wireless services not associated with specific addresses.

· BB_Service_Overview

· This layer contains subscriber-weighted nominal speed for each provider's service area at a county level and is meant to act as a summarized view.

· BB_ConnectionPoint_MiddleMile

· This layer contains middle-mile and backbone interconnection points.

· BB_Service_CAInstitutions

· Broadband Service at Community Anchor Institutions (CAI).

· Community Anchor Institutions consist of schools, libraries, medical and healthcare providers, public safety entities, community colleges and other institutions of higher education as well as other community support organizations and entities.

· BB_ConnectionPoint_LastMile

· This layer contains last mile infrastructure points, which is populated only if data cannot be provided at a more granular level.

· BB_Service_Address

· Represents broadband availability for service address points. Address Point availability refers to those individual addresses at which each facilities-based provider of broadband service can provide broadband services of minimal characteristics within 7-10 business days.

· State_Boundary

· State boundary supporting topological validation of point feature classes.

· NATL_Broadband_Topology

· Supports basic topology quality checking. Example: No CAIs or Middle Mile points outside of the State boundary.





[bookmark: _Toc319592906]Product Statistics

Following the completion of a product extract, the product statistics script (BDIA_ReleaseNotesStats.py) extracts the following information supporting that product deliverable.

· Provider Statistics:

· Collects all provider information, listing by Provider Name.

· Provides output of FRN.

· Counts the number of features supported within the following layers:

· Census Block;

· Street Segment;

· Max Upstream;

· Wireless Services;

· Infrastructure Points.

· These updates were made to support the Data Package required to accompany every NTIA product deliverable.

· Community Anchor Institution (CAI) Statistics:

· Breaks down CAI to the eight categories:

· 1: School: K through 12;

· 2: Library;

· 3: Medical/Healthcare;

· 4: Public Safety;

· 5: University/College;

· 6: Other Government;

· 7: Other Community non-government;

· None: Unknown Category. In cases where this occurs, further investigation is completed prior to product shipment to ensure all CAIs are categorized accurately.

· Reports out the following counts:

· Total CAIs within that category;

· Total CAIs that contain partial BB coverage. Contains any of the following information for a given CAI: BB Subscriber, Transmission Technology, Speed Down Speed Up;

· Total CAIs that contain full BB coverage. Contains all of the abovementioned BB information for a given CAI.

The output of this script is two CSV files: AnchorInstitutions.csv and Providers.csv. These files then can be inspected to ensure that there are the expected number of CAIs and providers for every release.



[bookmark: _Toc319592907]Quality Assurance

Quality assurance is supported manually and algorithmically on the interim data, BB_Cov file geodatabase and on the final product. For scheduled product releases, a test product extract and subsequent manual and algorithmic QC run is completed along with a release review. The product specifications, project status reports and previous product release notes are used as references throughout this review.



The following parameters are tested using the methodology listed below each:

· Product Deliverable Format: 

· Correct names and format of data deliverables.

· BDIA_QC_SUITES.

· Correct Projections/Datum.

· Manual interaction with product.

· Metadata Present and Correct.

· Manual interaction with product.

· Table Structure:

· All required tables included.

· BDIA_QC_SUITES.

· Extraneous tables identified.

· BDIA_QC_SUITES.

· Field Structure:

· All fields included.

· BDIA_QC_SUITES.

· Extraneous fields identified.

· BDIA_QC_SUITES.

· Correct field names, types and widths.

· BDIA_QC_SUITES.

· Field Domains:

· Values in all tables are constrained to the specified values specified:

· This action is accomplished via BDIA_QC_SUITES and manual review of the product;

· This tends to identify project completeness issues as fields with a null value are identified.

· Geometric Representation:

· Identify if all layers have the correct geometric representation:

· Manual review of the BB_ServiceOverview layer;

· Dependent on NTIA and client requirements.

· Geographic Extent:

· Product includes the necessary Geography associated with Product?

· Manual Review—ArcGIS®.

· Is there extraneous geography included in Product?

· Manual Review—ArcGIS®.

· Completeness:

· Products contain the expected amount of data?

· Manual review of product statistics relative to weekly State reports and defined expectations.

· Accuracy:

· Product meets the stated accuracy requirements for the deliverable?

· Sampling procedure to manually review source material to resulting product;

· Provider Validation;

· Verification using Third-Party Data;

· Verification against reality, where applicable.

· Data Regression:

· Any unexplainable data loss or change?

· This action is accomplished by comparing results within product statistics script (BDIA_ReleaseNotesStats.py) from previous releases, as well as manual review of the product.

· Confidentiality:

· Any unauthorized confidential information included in the delivery?

· Review of NDAs and delivery expectations.

· Prior Issues Resolved: 

· Have expected internal issues been resolved?

· Manual review of data against previous product release notes.

· Have agreed-upon customer issues been resolved?

· Manual review of data against previous product release notes, status report and client feedback.

· Delivery Medium:

· Has the product medium been verified?

· Manual review.

· All files present.

· Manual review of SFTP site is done to ensure all files are copied correctly, including file/directory size.

· Correct location.

· Manual review—confirmation of SFTP link, username and password.



[bookmark: _QC_Suite][bookmark: _Toc319592908]QC Suite

The BDIA_QC_SUITES consists of four main types of scripts supporting the overall QC process. These scripts are all run in concert and are called from the test_runner script and the test_BDIAProductGDB script.

[bookmark: _Toc319592909]configuration 

These scripts establish the configuration for the test_BDIAProductGDB script, which is the core of the QC Suite.

update_test_config

active_config

config_PROCESS01_automated

config_PROCESS01_manual

set_active_config

[bookmark: _Toc319592910]libraries

These scripts provide additional functionality that is called from with the test_BDIAProductGDB script.

bb_unittest_fixture

bbcov_structure

BC_XmlWriter

file_folder

search_and_replace

unittst_fixture

validate_BB_DB

validate_BB_GDB

xmlrunner_gui

[bookmark: _Toc319592911]qc suite

This is the core script for performing automated QA/QC on the interim and final data deliverables.

test_BDIAProductGDB

[bookmark: _Toc319592912]other 

These scripts perform other functions detailed below:

test_runner—this is the main script that runs all the other QC scripts and imports all the necessary scripts and libraries.

which_build—this determines the current build and passes information to the configuration scripts.



[bookmark: _Process_Operation_and][bookmark: _Toc319592913]Process Operation and Monitoring

Product Extract, BDIACreateSBDDOutputMigratedBBCov.py, is run within BroadMap using a platform called Hudson that has been enhanced to support BDIA product extraction, process monitoring, as well as product validation. The same platform can be planned for implementation for the State, if desired.



Below are previous examples of the product create, product validation, product statistics and monitoring processes that are managed within the BroadMap Hudson CI-System. All of the above-mentioned Python scripts, with the exception of metadata transactions script, are run via this system.



[bookmark: _Toc319592914]BDIA Product Create

Below is an example of the main page where the type of product build can be selected.



[image: ]








Selecting based on the type of process that will be initiated is shown below:



[image: ] 



[image: ] 



The Console Output can be reviewed to see the progress of product create. Following the completion of each product creation process, an e-mail notification is automatically sent to the team.

[image: ]



All processes run via the BroadMap Hudson CI-System are stored for historical reporting. Each process can be reviewed, including the Console Output and Build Artifacts from that run.

[image: ]




[bookmark: _Toc319592915]Product Validation and Statistics

Once the product creation process is complete, Product Validation and Statistics are then initiated. These support the BDIA_BBCovStats_NEWvOLD.py script and the BDIA_QC_SUITES scripts detailed above.



All statistics and reports are stored for historical review with the capability to place violation criticality on each quality control check, allowing the identification of errors because of project status/completeness verses project correctness. Example: Typical Speeds populated.



Below is an example of the report provided based on various control points running over a specified period:



[image: ]





Similar to the Product Create process, all results from the process are maintained:



[image: ]




Results are then reviewed manually to ensure no errors reported are critical or in violation of the NTIA data model or project completion statements. Any errors of concern are communicated ahead of product delivery and included within the product release notes. Further detail on the Hudson-CI System environment can be found by navigating to the following link:



http://wiki.hudson-ci.org/display/HUDSON/Meet+Hudson



[image: ]



[bookmark: _Toc319592916]Product Extract Data Delivery

Product delivery for MapConnectTM Broadband is handled two ways, depending on client requirements:

1) State Submittal:

a. Data is submitted via SFTP site;

b. Product Release Notes and QC Test Report accompany the delivery.

2) NTIA Submittal:

a. Directions for using the NTIA State Broadband Data file submission tool:

(i.)	Go to the following website: https://esupport.fcc.gov/statedata;

(ii.)	Enter your username and password as provided to you from the NTIA program administrator;

[image: ]

(iii.)	Click in Upload a file field;

(iv.)	Browse to local file for submission using the Browse button. Select file, then select ATTACH FILE. See example below.

[image: ]

(v.)	Logout/Receipt using the Logout button in the top right of the screen;

(vi.)	A receipt of submission is e-mailed to username e-mail address.
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a) Datais submitted via SFTP site

g 7ot Woras 1098 <3

ndor Radio -Liten o Fee te.. | © BroscMap Pogiam Mansgement | & Bush Lined Pant | EddieBaves | 2 BDIA Product Vaidaion O 21 x | % |
Hudson

& Bccormien

roeerore—
O, stots o Build #270 (Nov 18, 2010 9: e
= Coacam

Started 26 days g0

Tk i on maser
B consoc outout [l

o o

(5] ssems

Do e s s comcas

e e
» tetsug

5800 TRANSFERProders i b

Test Regut (2 foures / +1)

_
==
o

ot GOBErorSummar 50146 rSumimaryCass 8014 STRUCTUR sasy

Fage generated: Dec 14, 2010 12150135 P hadaon var, 138







image57.png

mpatibilty \

Home  Insert  Pagelajout  References 0

iy @ A a% s forstion saceio || g o3 o) b l DF E;.::z:{mmn ° @f@fﬁ"'""’"‘ j ] &

8 setLangusge
Speling & Resesrch Thessurus Transiate New Delete previous Newt | Track Ballaons Accept Reect 3 next | Compare Show Source | Protect
Grammar 5] Word Count Comment - Changes~ - [B] Reviewing Pane - = = Documents - || Document

Proofing Comments Tracking Changes Compare Protect

Results are then reviewed manually to ensure no errors reported are critical or in violation of
the NTIA data model or project completion statements. Any errors of concern are
communicated ahead of product delivery and included within the product release notes.

Further detail on the Hudson CI System environment can be found by navigating to the
following link:

http://wiki-hudson-ci.org/display/HUDSON /Meet+Hudson

If desired, BroadMap can set up the entire system within the Colorado environment and
provider training on the utilization and maintenance of processes within the Hudson CI
solution. Following initial setup, most maintenance efforts can be managed within the web
application using the

Product Extract Data Delivery

Product delivery for MapConnect is handled two ways, depending on client requirements:

1) StateSubmittal
a) Datais submitted via SFIP site
b) Product Release Notes and QC Test Report accompanies the delivery

& Clickto Swap 2| Most Vited % Geting Stated . Lotest Headlines | Links & AP
¥ How Does Ms Project Calculate % C... | [P] Pandora Radio - Listen to Free Inter... % | & BDIA Product Validation_CO Con... x

Hudson

Hudson » BDIA Product Validation CO

& Back to Dashboard Project name BD1A_Product Validation_CO
O, status Description <p>This job checks db integrity on file GeoDatabass. </p> ®
_ <img src=hitp://vermont:B080/30b/BDIA.Product-Validation_CO/plot/getPlot?index=08nickh=6508height=350>
= Changes <p>Latest Stats Regression: <a href="htip://vermont:8080/{ob/BDIA._Product_Validation_CO/lestSuccessfulBuild/artifact/SBDD_TRANSFER_counts_dif.htmi">Link</a><p>
= <p>Latest Provider Regression: <a href="http://vermont:8080/job/B1A_Product Validafion_CO/lastSuccessfulBuid/artifact/SEDD_TRANSFERProviders_diff.htmi"> Link</a><p>
& worksosce <p=Latest Error Regression: <a href="hitp://vermont:8080/iob/BDIA_Product_Validation_ CO/lastSuccessfulBuild/artiact/CO_error_summary_dif.hml
“>Links/a><p>

© sutanon <p>Latest CAI Regression: <a href="http://vermont:8080/job/BDIA_Product_Validation_CO/lastSuccessfulBuild/artifact/SBDD_TRANSFERAnchorInsitutions_if.htmi">Links/a><p>
© oeete roject —

Discard Old Builds ®

4, Confiqure

Days to keep builds

B s
ifnot ampty buld records are only kept up to thismumber ofdays
@ Buid vistory (trend)|  Max # of buids to keep 20
Q #20  Deczzzuiosazosan e iénat ampty onlyup tothis number of buld records ar kepe
O #275  pecowooioriensan swe [
Q@ #272  Dec1z 2010 :e132PM same This build is parameterized ®
O SOW deliverable validation String Parameter )
Q #271 Dec1 2008165 AN ssme
Final QC on SOW monthly CO product Name TestMethodPrefix ]
£270 Novio 20105: ssme
@ Default Value BDIA_STRUCTURE ®
O 2265 novis2000: 7ox8
© #268  Nov 18, 20109:22:48 AM 79K8. Deseription ©
© 2267 Nov1s 2010 9:0:05 M e
‘QC on SOW monthly CO product
@ #266  S5ep29.2010 111209 e same
@ 2265 sep26.2010 11zise oM soke -
0 validation build
@ #2604 sep2s. 2010 122008 e 7axe
String Parameter (2}
O #2635 AugaL 2010 peeren a8
Name ‘GDBLocation (2}
© #262  Aua3120101:17:05 M oske
@ #261  Aua31201012:22:02 M 102m8 Default Value //slaska/RelesseCandidates/CO_20101117-1547 ®
ug 25
@ #260  Aua30.20100:25:39 AM 10m8 DESCriBtion  arent path for the release candidate GDB ]
© #25%  Aug27.2010 Liazies M s10m8
@ #25  Aug 242010 5:00:41 AN soame
Q #257  Aua23.2010 s:00:61 An soame
@ =it e -
b foral ) orfures
Choice )
Name productType ]

hitp://vermont:8080/job/BDIA Product Validation_CO/configure

BDIA Product. X ortal-. || [ 10 Microsof.






image58.png

Broadband State Data Management Tool - Windows Internet Explorer EEX

B s ffesumport.fec. gov/bband-statesfoginlinput, action 2} Federal Commurications Commission [U5] 28

Vew Favortes Tooks Help

2 Broadbend State Deta Management Tool ] Page - 5 Tools -

Broadband State Data Management Tool

Login

Username: *

Password:*

TR icirias. o -







image59.png

Broadband State Data Management Tool - Windows Internet Explorer,

&+ [ mpsesuer e ot atesimanageasom scton

B tietredy vorson

Ble et

Vew Favortes Tooks Help

* &

2 Broadbend State Deta Management Tool ]

Upload File | View Files

UPLOAD NEW FILE

* denotes required fiek

Upload File

Upload File*

[CA\Users|20100323142745_offer20100323 poff

'ATTACH FILE

TR icirias.

o -






image1.png

) BROADMAP
) Beyond

The Boundaries







