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1 Overview

The following describes the Data Gathering, Data Integration, Data Validation and Verification and Quality Control
processes utilized to create the Broadband Mapping Project’s April 1%, 2011 data submission.

To support various levels of technical and program knowledge, this white paper supplies both a high level
summary and a detailed process review.

2 High Level Review

2.1 Data Gathering - Providers

Broadband Service Area, Middle Mile Aggregation Points and Broadband Service Overview
The collection of Broadband Service areas, Middle Mile Aggregation points and Broadband Service Overview
information is handled through the following Provider Outreach Process:

e  Build and Maintain an Inventory of Broadband Providers through research and State inputs.
e Update Provider Material that describes the data requirements and logistics for data transfer.
e Update NDA for use in project, where applicable
e Maintain multiple protocols for the provider to submit data, including SFTP technology when desired.
e  Conduct one-on-one informational discussions with each provider to communicate the following:
o Requirements of this project
o Broadband data required to support the product data model
o Submission protocols available
o Capability to validate how the supplied data is aggregated

e Download/receive Provider Data
e  Establish a repeatable process with Provider. Maintain Provider communication, transaction and data
handling records throughout the project (dates contacted, data received, etc.)
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2.2 Data Gathering - Community Anchor Institution (CAI)

The collection of CAl information is handled through the following CAI Collection Process:

Collect and maintain inventory of CAls through Data Mining, research, and State inputs.
Maintain web-based CAIl portal for institutions to add or confirm attribution, location and enter
broadband-specific information.

Upload web-based data to Core Database for standardization.

Perform internal cleansing, such as removing duplicate records, identifying gaps in broadband attribution
and verifying category.

Geocode CAl locations.

Translate Core Database data to deliverable ready format.

Continue engagement with non-responsive institutions.

2.3 Data Integration Process

The data integration and processing mechanisms currently utilized allow for multiple types of inputs and results in

a standardized output that meets the NTIA deliverable requirements. This process is flexible to support data model

changes and project requested enhancements.

Receive inputs from Providers via submission protocols, upload into Sourcing Database and catalog with
provider information.
Review Provider supplied data for completeness and for potential discrepancies that require resolution
prior to processing and flag as necessary.
Categorize input into data type category (addresses, block lists, paper maps, etc.).
Standardize input based on data type within Staging Database.
Create Compact Polygons (CP)—(internal methodology for generating area based feature for coverage in
Staging Database).
Apply broadband attribution to CP, Apply metadata to CP
Perform quality analysis of the CP against the source supplied to identify any completeness or accuracy
issues.
Request additional information from the provider if elements of coverage are missing or contain
discrepancies. This is a second manual quality check to ensure data is complete. Following completion of
CP creation, process steps within Data Validation & Verification occur

o Process coverage area to build the required NTIA data model layers

Process CAl data input into internal standardized format, as mentioned above under CAl Create Product
Deliverable based on NTIA and State-level requirements.
Following the creation of the product, process steps within Data Validation & Verification occur
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2.4 Data Validation & Verification

To ensure the data collected and processed is accurate and comprehensive, a holistic approach has been
developed to further validate and verify the data. Following the initial mapping of providers’ coverage area and
serviceability claims, the project team uses the following methods:

e  Third-Party Data Verification: Visually and programmatically compare the coverage against third-party
data.
Pitney Bowes and American Roamer data are used in cases where a coverage area is questionable. All
anomalies identified during this analysis are reviewed with the providers.

o Broadband Provider Validation — Provider Portal Application: Providers were trained on and requested
to use a secure interactive web application to review their current coverage area(s) and supporting
broadband attribution and validate their data or submit change requests to update their data.

All provider change requests go through the Data Integration Process and a review with the provider to
complete validation.

e Confidence Values: All Verification, Validation, and manual quality reviews are tracked by provider and
then by technology type, which is then stored and maintained within a “Validation” table. A confidence
value is assigned based on the collected information to highlight provider coverage areas that require
further investigation and enhancements.

2.5 Quality Control

Following collection, processing and analysis of the provider and CAl data, the product is checked manually and
algorithmically against the NTIA data model. Some of the items included within these checks are as follows:
e  Format Correctness
e Table & Field Structure
e Valid Values
o Including default values, where applicable
e Geographic Extent and Topology Errors

Prior to data submission, another quality control script supplied by NTIA is run. This script,
SBDD_CheckSubmission.py, creates an output in text form that is required to be submitted along with the final
deliverable. All errors must come up clean, unless otherwise specified from NTIA.

Exceptions to the script as noted by NTIA on the SBDD Workspace on 03/25/11 at the following link:
https://sbdd-granteeworkspace.pbworks.com/w/page/38218329/CheckSubmissionExceptions



https://sbdd-granteeworkspace.pbworks.com/w/page/38218329/CheckSubmissionExceptions

Longitude values for States outside the lower 48 (any table)
CAl results for Transtech, MaxAdUp, MaxAdDown if BBService is ‘No’ or ‘Unknown’
Overview MaxAdDown, MaxAdUp if 100% of record level data has MaxAdDown or MaxAdUp

populated
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Below is a detailed review of the data collection, integration and quality control points along the broadband data

gathering and mapping process.

Diagram of overall process:
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3.1 Provider Outreach

Final Delivery

For the April 2011 data submission, an e-mail notification was sent to all providers with supporting deliverable
dates. The Provider Portal web application was released and training webinars held so providers could use this
application to submit changes to and/or validate their current coverage area(s).

Data was also collected from the providers via e-mail and SFTP, depending on their comfort level to submit data in

time for the April 1% deadline.

In support the data collection effort, providers that did not timely respond to the outreach were contacted by

phone.
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3.2 Outreach Materials

The original provider packet sent via email to the providers included the following documents and files:

1)
2)
3)
4)
5)
6)
7)
8)
9)

Letter from the State inviting them to participate in the program
Copy of the non-disclosure agreement (NDA)

Copy of the Mapping NOFA from the NTIA

Copy of the NOFA Clarification from the NTIA

Broadband service address example file in CSV format

Word document describing service address example file
Broadband service block example file in CSV format

Word document describing service block example file
Broadband service street example file in CSV format

10) Word document describing service street example file

11) Broadband subscriber example file in CSV format

12) Word document describing subscriber example file

13) Broadband wireless coverage area sample shapefile

14) Word document describing wireless coverage area sample shapefile

15) Instructions for downloading, installing, and using the WinSCP secure FTP application

3.3 Outreach Process

The provider outreach process is comprised of the following general steps:

1)
2)
3)
4)

5)

6)

7)

8)

Send the provider package and introduction letter to the main point of contact for the provider

Follow up with email and call to verify that the main point of contact is correct.

If necessary, discuss the NDA further and resolve any redlines.

Once the correct primary contact is established, set up a call, if necessary, to learn more about the
provider’s offerings and direct them to the appropriate outreach materials.

If providers are unable to be contacted (non-responsive) or indicate that they are not interested in
participating (non-cooperative) mark them as such on the provider tracking sheet. These providers will be
escalated to the state for further action.

As the providers are collecting the required data, provide instruction on downloading, installing, and using
the WinSCP secure FTP application, if required.

Arrange with the providers to transfer the data in whatever way they are comfortable. Some providers
will find regular email acceptable. Others will want to use the secure FTP application.

After data is received and reviewed, it may be necessary to contact a provider for clarification or to
address incomplete data sets. In the interest of building and maintaining relationships, care is given not to
push the provider but to work with it to obtain accurate data in the best possible format.
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3.4 Data Collection

3.4.1 Data Transfer Procedures

There are three primary ways data is collected from providers. These are:
1) Secure FTP using the WinSCP application

2) Regular email

3) Mail

3.4.2 Initial Data Review and Quality Assurance

The initial data review and quality assurance process consists of the following general steps:
1) Access the data from the secure FTP site or email

a. If emailed, place copy of original data set in the appropriate provider folder on the secure FTP
site

2) Place copy of raw data on local computer in a working directory.
3) Review data and determine course of action based on type of data received.
4) Ensure data is complete and contact provider to address any gaps.

Note: The goal is to get as many providers as possible to provide subscriber address data in the correct format.
Obviously, this will not be possible with all providers so we will continue to have to process various types of
provider-supplied data.
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3.5 Data Ingestion

3.5.1 Data Ingestion Overview

The following outlines the process steps taken based on the type of input supplied by the data provider:
Point Data

e  Subscriber location

e DSLAM location

e  Central Office location

e Broadcast Tower location

Linear Information
e TIGER street segments

Polygonal Information
e Census Blocks
e Coverage Area

Overall, the process is geared toward taking the provider data supplied and creating polygon shapes to append to
the bb_cov feature class. The bb_cov feature class is the interim data set that is then processed using the
makeDeliverable.py Python scrip to create the MapConnect data layers that will be delivered to the state and,
ultimately, to the NTIA. Following are the detailed instructions used in this process.

3.5.2 Point Data
3.5.2.1 Subscriber Location — Address Data

In the event that the data provider supplies subscriber address data the following actions occur:

1) First, convert the address data to a clean Excel spreadsheet in an appropriate address data format.
a) Usually, this has the following columns: street address (number, pre-directional, pre-modifier, street
name, street type, post-directional, and post-modifier concatenated together), city, state, ZIP.
2) Configure the ArcGIS geocoding tool to use the TIGER 2009 streets dataset
a) In ArcCatalog, create a new Address Locater by right-clicking in the white space of the appropriate
directory and selecting New>Address Locater from the dropdown menu.
b) Select “US Streets with Zone” and press OK.
i)  Note: It is likely that multiple Address Locators will have to set up to handle the variety of
provider address data received.
c) Navigate to the TIGER Streets 2009 file and press OK.
d) Fillin the dialog box as seen below:




New US Streets with Zone Address Locator

3)
4)
5)

Name: [ CO_Geocode_TIGER_2009] Input Address Fields
Besorio | US Strests with Zone The field containing: is recognized if itis named:
Primary table ] Zone ggl_dr . S
ee
Reference data: Delete
| Ci\Working'\Broadband \BaseData \TIGER.,_Streets.shp =
&
[v Store relative path names J J
Fields
Matching Options
House From Left: |LFROMADD ﬂ
Place Mame Alias Table... | <Monex=
House To Left: |LTOADD ﬂ
House From Right: |RFROMADD ﬂ Spelling sensitivity: 80—
- Minimum candidate score: w ——
House To Right: |RTOADD ﬂ = o 8 o 0 0 0 0 o o0 0 o
e |<None> j Minimum match score: 8 . .JT
Prefix Type: | <None> j Intersections
Connectors: &|@ Separate connectors by &
Street Name: [FULLNAME ~| l space, e.0. "B @, [°
Street Type: | <None> ﬂ R
ELHRE |<N°“E> j Side offset: [20 in |Feet j
Left Zone: |zipL | End offset: T
Right Zone: |ZIF‘R j ¥ Match if candidates tie
Cutput Fields
[~ ¥and Y coordinates [ Standardized address
[ Reference data ID [ Percent along
Help | Advanced. .. OK. | Cancel
e) Click OK.

Open up ArcMap, and add the Excel spreadsheet with the address information.
Right-click on the Excel spreadsheet and select Geocode Addresses from the dropdown menu.

Select the appropriate address locator by clicking Add.... then OK

% Choose an Address Locator to use...

| Description

Mame

& C0_Geocode_TIGER_2009

L5 Streets with Zone

i

Add...

Cancel




6) Fill out the Geocode Addresses dialog box as shown below:

Address table:

foms =1 @

— Address Input Fields

Street or Intersection: IFULL_ADDR d
Zone: IZIP_CODE LI
~Output

% Create static snapshot of table inside new feature dass
€ Create dynamic feature class related to bable

QOutput shapefile or feature dass:
C:\Working"Broadband"ProviderDataGlenwood Springs glenwooc

Config keyword: I

Advanced Geometry Options. .. |

Geocoding Options... |
Help | oK I Cancel |

7) Geocode the list in batch mode using the geocode service set up in Step 2 above, accepting all the default
parameters.
8) Review results.




Shaow results: All Addresses j Manage result sets... Refresh Rematch Automatically | 7
Matched: 97 (88%)
FID Shape Status Score | Match_type Side S lg Tied: 5(5%)
3 0] Point " 81 A L 201 CENTEMMIAL DR, 31601
1| Point 1] 81 A L 201 CENTENNIAL DR, 81601 - Unmatched: 8 (7%)
2|Point ] 81]A L 201 CENTENNIAL DR, 81601
3 |Point " 100 A L 210 CENTER DR, 21801
4|Point M a1 A L 15 MARKET DR, 81601
5/ Point 1] 81)A R 40 MARKET DR, 81601
&|Point u 0 A
T|Point T 51 A L 58627 SOCCER FIELD RD, 81601
&|Point 1] 100 A L 125 STORM KING RD, 81601
9| Point M 60 A L 52800 TWO RVERS PLAZA RD, 81601
10 |Point u oA
11| Point 1] 81)A R 40 MARKET DR, 81601
12 |Point T B3 A R 2698 GILSTRAP CT, 21601 -
< i | >
Record: ﬂj 1 jﬂ Records (of 110)
 Address: 1Candidate 1 Candidate details:
Sireetor Intersecton |01 CENTGA | | S0e T Side | Match_addr [ LeftFrom [ LeftTo | RightFrom [ RightTo | | From [201 [ 200
81 L 201CENTENMIALDR, 81501 201 29 0 28 To 250 | 2
Zone ISlSDl
PreDir
PreType
Streetiame | CENTEMMIAL
StreetType DR
Sufbir
Zone 81601 | 81601
Score 81
Side L
Match_addr |201 CENTENNIAL C
# Standardized Address:
201 | | CENTENMIAL | 5T | | 81601 A3 il L
Geocoding Options... | Zoom to Candidates | B pick Aderess from Map | Search | e | Unmatch | 5o Edis Close

9)

Adjust geocoding parameters accordingly and repeat batch to resolve issues.

10) Manually geocode unmatched addresses until target hit rate achieved, generally 90%.
11) Visually inspect the data as seen below:
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.. provider_data_QAQC.mxd - ArcMap - Arcinfo

Elle Edit View Bookmarks Insert Selecton Tools CH2M Window Help
Leds B ) + 1:52.481 A || & & B 3| %2 | edior + - [Geaenenreatre 7]
Georeferendng ¥ - ArcPad Data Manager ~ | 42 4% 48 | Gi Spatial Anal
30 Analyst ¥
& [
= *
L]
= ] Geocoding Result: glenwood_tryl @ *
. e
ar
= [0 TIGER Streets .
— o
= M COUNTIES &
= O BB_ConnectionPoint_MiddleMile @
. -
= M HIGHWAYS
- M FCROADS B ol
= [] 8B_Service_Road_Segment X
- M cImEs i)
= [0 BB_Service_CensusBlock I’:
= wv BB
= [0 BB_service_Overview &
= =
= [ BB_Service_Wireless
O
= O communicomm_coverage_area
o &
= O wired_coverage_sample_wgs34
O
" N /ﬂ
Display | Source | Selection R ”ﬂ j
Drawing ~ & O~ A~ 0] Arial ~| |10 -
-107.326 39.557 Decimal Degrees

12) Follow the steps detailed in Subscriber Location — GIS Data below

3.5.2.2 Subscriber Location — XY Data

If the provider supplies a list of subscriber data with accompanying XY data such as latitude and longitude, the
steps are as follows:
1) Refine the format in Excel so that the data can easily be opened using ArcMap.

a. Remove all font color, highlighting, cell colors and borders, clean up column headers and make
sure there are no merged cells.

b. Make sure that XY locations are in decimal degrees.

i. To convert from degrees, minutes, seconds (392 26’ 45.67”) to decimal degrees us the
following formula: DD + (MM/60) + (SS.5SS/3600).

ii. Note: if XY locations from some other coordinate system are provided, you can use
those in the process below but you must know what the coordinate system is.

2) Open up the Excel worksheet in ArcMap.

3) From the menu bar, select Tools>Add XY Data...
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Add XY Data

Atable containing X and Y coordinate data can be added to the
map as a layer

Choose a table from the map or browse for another table:

| ForImports j g

Specify the fields forthe X and Y coondinates:

¥ Field: | LONG

[
[

Y Field: ||_,'.\T

Coordingte System of Input Coordinates

Description:

Geographic Coordinate System:
MName: GCS_WGS_1584

[ Show Details

W Wam me if the resulting layer will have restricted functionality

0K | Cancel |

4) Supply the appropriate fields for the X and Y coordinates, choose the appropriate coordinate system and
press OK.

5) Results are an event layer, not a true spatial layer. Export the data by right-clicking the event layer and
selecting Data>Export Data... from the dropdown menu.

6) Follow the steps detailed in Subscriber Location — GIS Data below.

3.5.2.3 Subscriber Location — GIS Data

If the provider supplies subscriber location in GIS format, the only process step is to load that data into the
appropriate data schema and it will be ready for processing.
1) First, load the data into the Point Address database schema (please see Appendix D for an example of the
Point Address database schema.) using an empty feature class in that schema.
2) In ArcCatalog, right-click on the empty feature class and select Load from the dropdown menu.

3) Navigate to the provider address GIS data set and then map the attribute fields accordingly, as seen in
general below:
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Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field ~
| =treet_id [int] <Mone= =
| =side [ztring] =Mone>
|| feature_id [in] <Mone>
| point_type [=hort int] <Mone=
| | 2dd_house_num fstring] |BLoG_Num stringl __[Rd|
| add_pre_dir [string] PRE_DIR [=tring]
| add_pre_type [string] <Mone=
| add_name_body [string] STREET_NM [=tring]
| add_suf_type [string] SUF_TPE [=tring]

add =uf dir [2tring] SUF TYPE [=tringl b’

Reset

< Back | Mext = | Cancel

4) Once you have successfully loaded the provider address data into the temporary database with the
correct schema, you will now append that data to the overall Point Address database.

5) In ArcToolbox, use the Append command (Data Management Tools>General> Append) to add the
features into the overall Point Address database, as seen in general below:




BROADMAP

Beyond The Boundaries

CEX
~
Input Datasets i

C:\Working'Broadband\Provider_Data_Example.gdb{Temp_Address

l& [ [X |+ &

Target Dataset
| C:\Working\Broadband\Provider_Data_Example. gdb\Address_Database

Schema Type (optional)
| TEsT
Field Map {optional)

le 2 X |+ 1] |&

v

oK | Cancel | Environments. .. | {Show Felp ==

6) Since the data is already in the Point Address database schema, there is no n need to alter the Field Map
in the Append tool.
7) After appending, calculate metadata reflecting geometry source and representation values.
8) Break provider-specific points into separate county feature classes and perform the following steps per
county feature class:
a. Within ArcGIS
i. Summarize download and upload speeds [first,last] to determine all speeds available for
county.
1. This will save as a DBF table. Keep track of location for future reference.
ii. Buffer county address point featureclass to 150’.
1. During buffer command, dissolve on “ad_down”; “ad_up”; "provider”; “dba”;
“frn”; “tt”; ‘all metadata fields’; “stctyfips”. Save as....
county_fastestdown_fastestup.
2. (Example using Qwest data: boulder_40128_20128, where boulder=county;
40128=ad_down; 20128=ad_up)
3. Note: these attribute fields are specific to the Point Address database.
iii. Select the features that represent the lowest speeds
b. Using XtoolsPro (http.//www.xtoolspro.com/)
i. Inthe XTools Pro toolbar, select XTools Pro>Layer Operations>Erase Features

ii. Use the same feature class for Input and Overlay
iii. Check Use selected features on the Input feature, as seen below.



http://www.xtoolspro.com/

Repeat and erase slowest speeds one speed at a time. Saving each new feature class as
the next slowest speed, using the same naming convention as above. A general example

is seen below:

Erase Features

Input feature layer:

[ boulder_12128_895 |
¥ Use selected features
(12 feature selected)
Qutput storage:
| Ci\Working\Broadband\ProviderDat.. . \boulder_7168 896

¥ Add output feature dass to current map
v Create spatial index

Qverlay layer:

|[E bouider_12128_s96 |

[ Use selected features (1 feature is selected)

Help OK | Cancel

c.  Within ArcGIS

Edit/delete speeds from the attribution table of each feature class, so each remaining
feature class has only one speed value.

Merge individual speed feature classes together using the Merge command in
ArcToolbox (Data Management Tools>General>Merge). The dialog box is seen below:
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4 Input Datasets

L
+
ol
i
3

& Output Dataset

Field Map {optional)

X [+ [

~

OK | Cancel | Environments... | {'Show Help >> I

iii. Merge individual county feature classes together using the Merge command in
ArcToolbox (Data Management Tools>General>Merge).

iv. Since the county files are all in the same schema, do NOT alter the Field Map portion of
the command interface.

v. When all the county files are merged together into one dataset, use the Append
command in ArcToolbox (Data Management Tools>General>Append) to add the
features to the bb_cov interim data set. Use the Field Map portion of the Append tool to
map the appropriate field values to their corresponding fields in the bb_cov feature
class.

3.5.2.4 DSLAM or Central Office Location — Address Data

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central Office address
data please follow the steps below:

1) Follow the process for geocoding points in Subscriber Location — Address Data, above.
2) Follow the steps detailed in DSLAM or Central Office Location — GIS Data below.

3.5.2.5 DSLAM or Central Office Location — XY Data

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central Office XY data
please follow the steps below:

1) Follow the process for creating points from XY data in Subscriber Location — XY Data, above.
2) Follow the steps detailed in DSLAM or Central Office Location — GIS Data below.
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3.5.2.6 DSLAM or Central Office Location — GIS Data

In the event that the provider supplies DSLAM (digital subscriber line access multiplexer) or Central Office GIS data

please follow the steps below:

1) Buffer the DSLAM/Central Office points feature class
a) Add the point feature class to ArcMap
b) Open up ArcToolbox and go to Analysis Tools>Proximity>Buffer
c) Set the buffer distance to 5 miles
d) Set the dissolve type to ALL
e) Name the output feature class
f)  Typical Buffer tool is seen below:

Input Features

| Columbine
Qutput Feature Class

2 @]

| C:\Working'Broadband\ProviderData‘\Columbine \Columbine_Buffer_2.shp ﬂ
[~

I~

[~

[~

A

Distance [value or field]
(+ Linear unit

[ 5 |miles
" Field

Side Type (optional)

End Type (optional)

Dissolve Type (optional)

Dissolve Field(s) (optional)
Ormo

O company

Ooea

Orrn

O excHANGE

Ostate

OrrovIDER
Ocui_cooe

MecorT bt
£

oK | Cancel Environments... | Show Help == |

g) Press OK
2) Use the resulting buffer feature class to clip the TIGER street layer (as described earlier):
a) Add TIGER street layer to ArcMap
b) Open up ArcToolbox and go to Analysis Tools>Extract>Clip
c¢) Complete the dialog box as seen below:




3)

4)
5)

6)
7)
8)

9)
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Input Features
| TIGER _Streets | ﬂ
Clip Features
|COIumbine_Buffer j g
Output Feature Class
| C:\Working\Broadband \ProviderData\Columbine\columbine_TIGER _dip.shp
XY Tolerance (optional)

Meters j

oK Cancel | Environments. .. | Show Help => |

d) Press OK.
Using ArcCatalog and within the file geodatabase:
a) Right Click and create a new Feature Dataset
i)  For the Feature Dataset settings:
(1) Name the feature dataset accordingly
(2) Select horizontal coordinate system by importing the coordinate system associated with the
clipped TIGER street layer by selecting Import and navigating to the location of that feature class
(3) No vertical coordinate system needed
(4) Leave all x,y,z,m values at default.
(5) Press Finish
Import previously created street feature class into new Feature Dataset
Right-click Feature Dataset and create new Network Dataset — accept all default setting for the Network
Dataset
a) Note: the Network Analyst extension must be turned on
In ArcMap Turn on the Network Analyst Toolbar by going to View>Toolbars>Network Analyst
Add the Network Dataset created in Step 5 to ArcMap
Using Network Analyst Toolbar drop down — create “New Service Area”

Open up the Network Analyst Window by selecting the E button.
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|Service Area j
Facilil:iﬁ (D)

Polygons (0)

Lines (D)

Barriers (0)

10) Right click Facilities layer, select Load Locations, and navigate to the DSLAM/Central Office facilities feature

class.

Load Locations IEIFZ\

=
Load From: El columbine_paints j I;

¥ Only show point layers

-

Sort Field: | j

Location Analysis Properties

Property Field Default Value

Mame
CurbApproach Either side of vehide

Attr_Length a
Breaks_Length

Location Position

{+ Use Geometry
Search Tolerance: 5000 Meters j

™ Use Network Location Fields

Property Field
SourcelD

Source0ID

PosAlong

SideOfEdge

Advanced... Cancel

11) Press OK.

12) Click the Service Area Properties button
13) For the following tabs change the following properties:
a) “Polygon Generation” tab
i) Select “Merge by break value”

ii) Also disable the Trim Polygons option
b) “Analysis Settings” tab — using and converting the specified DSLAM buffer distance from feet to meters —

input buffer distance value in meters into the “Default Breaks” location




14
15

16
17

—_— —
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i)  Generally, 18,000 feet (5486 meters) from DSLAM or Central Office location is used as the buffer
distance

Layer Properties

Line Generation ] Accumulation ] Network Locations ]
General ] Layers ] Source Analysis Settings l Polygon Generation ]
Settings Restrictions
Impedance: |Length (Meters) ﬂ
Default Breaks: |54351
Direction:

' Away From Facility
" Towards Facility

Allow U-Tums: |Everywhere ﬂ

¥ Ignore Invalid Locations

QK | Cancel Apphy

c) Click OK.

On the Network Analyst Toolbar click the “Solve” button ﬁ to create service area polygons.

Right-click on the created service are polygon in the layer list, and select Data>Export Data from the dropdown

list.

Export to a feature class in the file geodatabase you created earlier

In ArcCatalog, create an empty feature class with the schema of the bb_cov feature class and load the feature

class created in Step 16 into it.

a) Right-click on the empty feature class, select Load>Load data from the dropdown menu and navigate to
the location of the service area feature class

b) Pressthe Add button, hit Next

c) Accept the defaults and hit Next

d) Do NOT attempt to map any fields, as seen below:
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Simple Data Loader

For each target field, select the source field that should be loaded into it

Target Field Iatching Source Field i

|Pru'.fName [ztring] <None> =
_|DBAName [string] <None>
| FRN [int] <None=
_| GeogUnit [string] <None>
|| GeogUnitiD [string] <None>
| TrangTech [ghort int] <None=
| MaxAdvDown [ghort inf] <Nong>
| MaxAdvUp [short int] =None>
| ARPU [float] <None=

SWhNomSpeed [float] <Nong= bt

Reset

< Back | Mext = | Cancel

e) Press Next, then Next again, then Finish.
18) In ArcToolBox, go to Data Management Tools>General>Append
19) Append the formerly empty feature class to bb_cov, completing the dialog box as seen below:

Input Datasets —

| = @

Target Dataset
| C:\Working'\Broadband\ProviderData\Columbine\Columbine. gdb\bb_cov ﬂ

Schema Type (optional)

=
=
#|

Field Map {optional)

| b

QK | Cancel Environments... | Show Help == |

20) Leave the Schema Type as TEST
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21) Press OK.
22) In ArcMap, open up bb_cov for editing and manually input associated attribution.

3.5.2.7 Broadcast Tower Location — Address Data

In the event that the provider supplies wireless broadcast tower location address data please follow the steps
below:

1) Follow the process for geocoding points in Subscriber Location — Address Data, above.
2) Follow the steps detailed in Broadcast Tower Location — GIS Data below.

3.5.2.8 Broadcast Tower Location — XY Data

In the event that the provider supplies wireless broadcast tower location XY data please follow the steps below:

1) Follow the process for creating points from XY data in Subscriber Location — XY Data, above.
2) Follow the steps detailed in Broadcast Tower Location — GIS Data below.

3.5.2.8.1 Broadcast Tower Location — GIS Data

In the event that the provider supplies wireless broadcast tower location GIS data please follow the steps below:

1) Download the required software (Radio Mobile) from the website:
http://www.cplus.org/rmw/english1.html

2) Install the software according to the standard directions, found here:
http://www.cplus.org/rmw/download/download.php?S=1

3) Open up the application
4) Load the broadcast tower location and elevation information by selecting File>Unit properties. The
following dialog box appears:



http://www.cplus.org/rmw/english1.html
http://www.cplus.org/rmw/download/download.php?S=1
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¥a Units properties Ead
a Mame Elevatian [m)
Athena T |Adthea + 2832
Caribou | J
Chipeta .
- Pazition Clear
EarﬁkhnSE 400426 6"N 105730331 Q
orizon-
Horizonw ﬂ DH7OFE M
Littleraven
M atzanala-H I Locked
M amzanalay
Maonstone Enter LAT LOM or QRA Move up
Firata
Temapin Move down
Rﬁﬁfo Place unit at cursor position
W apiti Export
Place curgor at unit position Import ‘
Shyle Sart
[v¥ Enabled ™ Left * Centre " Right
Apply styule
[ Transparent
™ Mo label BrackColor ‘ ForeColor W Smal fort
lcon 16x1E pixels
I o] aire
v
— [ Show only units that are members of a visible network

5) Add in the information for all the towers supplied by the WISP data provider, including the elevation. If
provider does not supply elevation, this information can be obtained from Google Earth.
a. |Ifavailable, use the Import button to import a Google Earth KML of the tower locations.
6) Go to the National Map Seamless Server (http://seamless.usgs.gov/) and download elevation data

sufficient to contain the tower locations.
a. Atleast the 1/3” NED data is needed. Select this by clicking the Download button in the upper
right of the web site and checking the box nect to 1/3 “ NED.
b. Zoom to the area of interest and use the Download tools:

IDuvmluads
T [l [ e
=

to define the area to download.
c. Click the Modify Data Request button to request the data in BIL_16INT format, not ESRI GRID, as
seen below:



http://seamless.usgs.gov/
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) The National Map Seamless Request Summary Page - Mozilla Firefox

http:/fextract.cr.usgs. gov/Website fdistreq/RequestSummary.jsp?PR=08CU=Native 82X =-1.08ZY =-1.08ML=C 5

The National Map Seamless Server

Request Summary Page
You are logged in as Default Seamless User.

Modify Data Request HELP!

Data Exiraction Requesi Pieces:
Output Parameters e (MB) | Download Links
National Elevation Dataset (NED) 1/3 Arc Second
z

EROS Data Center

Done @ %" M 4o frank@gmail.com

d. Download the data and unzip it.
7) Select File>Map Properties to define the map
8) Enter in a latitude and longitude in the center of the tower locations
9) Set the size (in pixels) and the size (in kilometers) of the map
10) Set the directory path leading to the BIL elevation data just downloaded
11) The dialog box is seen below:

:"‘i Properties of ..\default.map

Centre Size [pixel]
AD'02E. 8N 10572927 5w “Wwidth[pixelz) Height [pixelz] Ewtract
OM7OGE 1000 1000

Latitude Longitude

40,058 -105. 491 Size [km] Cancel
Wwidth(km] Height [km] —_—
|Jse cursor position 100.00 Top Left
4073029
‘Waorld map Elevation data source T0E04447/
Drive or path Top layer Tap Right

Select a city name ‘ |B|L j |c:'\geodata\bil\b0ulder Browsze... 403023

10475417

Enter LAT LON or GRA ‘ Nore || Browse... Battom Left
FTIEZTN

|Select a unit ﬂ |N°”e j | Browse... 10E704'44'
More =] | B gsostaosr'nzg'l'%ht

[~ Adjust units elevation |N0ne j | Browse 10475477

[~ M = s B I Riezolution
BI0% pIGEs [ lgnore missing files ottarn I3Ver |00 0 mepisel

Iw Force gray scale Initizlize matriz with elevation [m) |0 3.24 arcsecond

12) Hit Extract.




| lﬁeady [40°05'34"N 105°17'13"W X=673 Y=4611724.1m

14) Select File>Network properties from the main menu
15) Create a new network and enter in the frequency range under the Parameters tab, as seen below:




Networks properties

Lizt of all rets

Default parameters

Copy Met ‘
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‘ Cancel | [u]4

Hednet
Jade
Qluray
COMobile

Met B
Met 7
Met 8
Met 3
Met 10
Met 11
Met 12
Met 13
Het 14
Het 15
MHet 16
MHet 17
Met 18
Met 19
Met 20
Met 21
Met 22
Met 23
Met 24
Met 25

Parameters ‘ Topology ‘ tembership ‘ Syatems | Style

et name

|Nedemet

tinimurn frequency [MHz] | 2400
t aximum frequency [MHz) (2400

Polarization

f* ‘ertical " Horizantal

Mode of wariability

* Spot % of time
("~ Accidental
% of locations
™ Mobile
% of situations |70

(" Broadcast

Surface refractivity [M-Unitz] W

Ground conductivit [5 /) e

Fielative ground permittivity l—
15

Climate

" Equatonal
" Continental sub-tropical
" Maritime sub-tropical

Desert

DI

Continental temperate

td aritime temperate aver land

.

td aritime temperate over zea

16) Leave all the other values as they appear, and select the Systems tab

17) Create enough systems to cover all the varieties of equipment in the provider network. This will include

the antenna type, height, and line loss, as seen below:




Networks properties

Drefault parameters ‘ Copy Met | ‘ Cancel | ak.
List of all zpstems
O |
g0 Parameters | Topology | tembership ‘ Systems ‘ Style |
120
Syztem 4
Spstem 5
Sﬁstem E |D1 ﬂ |Select from Radiosps01.dat ﬂ
System 7
System 8 System name | Omni
Syztem 3
System 10
Sﬁztgm 1 Tranzmit power (watt] |100 [dBm] |50
System 12
gystem :Ilﬁ Receiver threshald [pv] |1 [dBrm] |-107
Yatem
gﬁz:zm 12 Line lozs [(dB) |1 [ Cable+cavitiez+connectars |
System 17 -
System 18 i R
System 19
e Artenna gain (dBi) [15 [dBd) [12.85
System 22
System 23 Antenna height [m] |3 [ &bove ground |
System 24
System 25 Addiional cable loss (dB/m) [0 [If antenria height difers | —

Add to Badiogy=01.dat Remove from B adiozys01. dat

18) Now click on the Membership tab, and assign the individual towers to their respective systems, providing
the azimuth for non-omnidirectional antennas, as seen below:




Networks properties

Default parameters | Copy Met ‘ ‘ Cancel | Ok
List of all nets
Wednet
Jade Parameters ‘ Topology | Memberzhip ‘ Spstems ‘ Style ‘
COuray
COkobile R
Medernet . . ember of Medemet
Met B List of all units Ruole of &thena
HE: g |Command ﬂ
Het 190 System

&l | Chipeta
5] hd
H:H; | Frankling | J
Met13 v| HarizonE Antenna height [m]
Met14 w| Harizar-w!
Met 15 W Littleraven e f+ Spstem 9
Met 18 | hManzanala-H
Met17 | Manzanalay £ Other
mg::}g | Moonstone
Net 20 | Firata Antenna direction
et 21 | Terrapin - "
Met 22 v| Tobago |F'”Bd[ ! ﬂ
Net 23 L TL”“'_E_ Azimuth [ Elevation angle [*]
Met 24 | W apiti
Net 25 [a0 o
7 Wiews pattern |

19) Press OK.

20) Select Tools>Radio Coverage>Combined Cartesian from the main menu

21) Complete the dialog box as seen below, providing the Maximum Range from the highest tower beam
radius supplied by the provider.

22) Set the Pixel Size at 5 (experiment depending on the area covered to get the right level of granularity) as
seen below:




mbined carte:

wed unitls]

Althea g [

Alhena || ntenna patien
Caribou -

Chipeta ommlant -
Franklins

HarizanE

Huorizarea/

Littleraven

Manzanala-H

Manzanalat' =

Moonstone

F'irata |~ Draw pattein
Tenapin

Tobago “Wiew pattern |
Turtle

Antenna height [m]

| g

[ L

E . Backcolor |
(]

||

[

[

||

[m]

(]

||

[

O |

Mabile unit

o]

e e
In netwark. Cancel I
INedemel ;I

¥ Use netwark antenna seftings
I~ Save raster data to file [T=T)
I~ Save raster data to file [SIG)
I~ Save also units not selected
I~ Complete.way

I Save coverage pictures in "frames" directory

Load settings

Save settings

Load data

1

v Mazimum range [km] B2
i~ Link Direction Mod:

* Mabile Fx Al picture

" Mobile Tx " Selection

i Signal range ta drat

& S-Unit ™ Bestunit
 dBm

[T il

" dBpddm

Diaw size [pixels) I Netwark style
5 I Rainbow

From[»=]
il
To(<) r
[
. Color
I~ Solid

23) Set the signal range to draw to S-Unit and type 5 in the From (>=) box.

24) Press Draw.

i |Ready

[40°05'53"N 105°1510™ X=702 Y=455 1627m 4

25) Save the resulting image as a TIF by selecting File>Save Picture as.

26) Open ArcMap and load the BIL elevation data you used in Radio Mobile.

27) Load the TIF image you created and georeference it using the corners of the BIL data.

a. The corners of the data can be seen in the TIF image.
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28) Follow the georeferencing directions from the Coverage Area — PDF/JPG/Other Image Format section
below.

29) Use the Georeferencing Toolbar to Update the Georeferencing for the TIF data set.

30) In ArcToolbox, select Data Transformations>From Raster>Raster to Polygon and input the georeferenced
TIF you just created as seen below:

31) Open the resulting polygon feature class up for editing using the Editing toolbar in ArcMap and clean up
as necessary.
32) In ArcCatalog, create an empty feature class with the schema of the bb_cov feature class and load the
feature class created above into it.
a. Right-click on the empty feature class, select Load>Load data from the dropdown menu and
navigate to the location of the service area feature class
b. Press the Add button, hit Next
c. Accept the defaults and hit Next
d. Do NOT attempt to map any fields, as seen below:

X

Simple Data Loader

For each target field, select the source field that should be loaded into it.

Target Field Matching Source Field s
|Prquame [ztring] <None=
| DBAName [string] <None>
| FRN [int] =MNonex
_| GeogUnit [string] <None>
|| GeogUnitiD [string] <None>
| TrangTech [ghort int] <None=
| MaxAdvDown [short inf] <None>
| MaxAdvUp [short int] <None>
| ARPU [float] <None=

SWhomSpeed [float] <None= v

Reset

< Back | Mext = | Cancel

e. Press Next, then Next again, then Finish.
33) In ArcToolBox, go to Data Management Tools>General>Append
34) Append the formerly empty feature class to bb_cov, completing the dialog box as seen below:
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BX
~
Input Datasets

| Rl
C:\Warking'\Broadband'\ProviderData\Columbine\Columbine. gdb\service _area_bb... +
X

Target Dataset

| C:\Working\Broadband'\ProviderData\Columbine \Columbine. gdb\bb_cov ﬂ
Schema Type {optional)

Field Map (optional)

E iy

| b

oK | Cancel Environments.. . | Show Help == |

35) Leave the Schema Type as TEST
36) Press OK.
37) In ArcMap, open up bb_cov for editing and manually input associated attribution.

3.5.3 Linear Data
3.5.3.1 TIGER Street Segments — List, Spreadsheet, or GIS Data

In the event that the provider supplies TIGER street segments in list or spreadsheet format please follow the steps
below:

1) Join TIGER road segments to 2000 census blocks feature class using one of two methods based on how
the data is provided:
a) Ifthe TIGER data is provided with a Census Block ID, then join the segments to the Census Block
geometry based on that ID
i) Load both data sets into ArcMap
ii) In the layer list, right-click on the 2000 census block feature class and select Joins and
Relates>Join
iii) In the dialog box, select the TIGER road segments data and the proper attribute fields for joining,
as seen below:




b)

iv)

Join Data

Join lets you append additional data to this layer's attribute table so you can,
for example, symbolize the layer's features using this data.

What do you want to join to this layer?
|J0in attributes from a table ﬂ

1. Choose the field in this layer that the join will be based on:

|BLKIDFPOD ~|

2. Choose the table to join to this layer, or load the table from disk:

(% TIGER_Streets [=] E

[+ Show the attribute tables of layers in this list

3. Choose the field in the table to base the join on:
-

Join Options
 Keep all records

All records in the target table are shown in the resulting table.
Unmatched records will contain null values for all fields being
appended into the target table from the join table.

" Keep only matching records

If a record in the target table doesn't have a match in the join
table, that record is remaved from the resulting target table.

About Joining Data 0K | Cancel

Press OK
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If the data provided is a list containing TLIDs, then join to the TIGER line data using the TLID, and use
a spatial join to associate the TIGER segment with the coterminous block based on the block ID

i)
i)

i)

iv)

Load both data sets into ArcMap

In the layer list, right-click on the 2000 census block feature class and select Joins and

Relates>Join

Select “Join data from another layer based on spatial location” from the dropdown menu

Complete the dialog box as seen below and press OK.




Join Data

Join lets you append additional data to this layer's attribute table so you can,
for example, symbolize the layer's features using this data.

What do you want to join to this layer?

1. Choose the layer to join to this layer, or load spatial data from disk:

[€ TIGER_Streets | =
2. You are joining: Lines to Polygons

Select a join feature dass above. You will be given different
options based on geometry types of the source feature dass
and the join feature dlass.

{* Each polygon will be given a summary of the numeric
attributes of the lines that intersect it, and a count field
showing how many lines intersect it.

How do you want the attributes to be summarized?
[~ Average [~ Minimum [ Standard Deviation
[~ Sum [~ Maximum [~ Variance

" Each polygon will be given all the attributes of the line that is
closest to its boundary, and a distance field showing how
dose the line iz (in the units of the target layer).

Mote: A line falling inside a polygon is treated as being dosest
to the palygon, {i.e. a distance of 0).

3. The result of the join will be saved into a new layer.
Specify output shapefile or feature dass for this new layer:

|C:"-.‘.“.l'orking"-.Broadband"-.Temp"-Join_OutpLrt_5.shp =

About Joining Data oK | Cancel |

2) Export joined records into a temporary feature class.

3) If joined Census Block geometry is confined to one specific area then dissolve blocks into one record. If
joined Census Block geometry is distributed throughout a particular state then dissolve sub-selections of
census blocks for each county.

a) Use the County FIPS code to dissolve by county.
b) In ArcToolbox, select Data Management Tools>Generalization>Dissolve
c) Complete the Dissolve dialog box as seen below:
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* Dissolve rz(
A

Input Features

| blocks_uTM | ﬂ
L

Qutput Feature Class

| C:\Working'\Broadband\BaseData'blocks_UTM_Dissalve.shp

Dissolve_Field(s) (optional)

Orm fad
O staterroo
COUNTYFPOD
OTracTcenn
OeLockcenn
OsLxIoFron
Onaveoo
Owrrocon
Miron b
£

Select All | Unselect All
Statistics Field(s) (optional)

et |
=l
Field Statistic Type ﬂ 0
X
2
[

v

oK | Cancel Environments... | Show Help ==

d) Press OK.

4) For each dissolved region, open up the feature class for editing using the Editing tool in ArcMap and
remove unnecessary slivers and other small holes. For general guidance on editing features in ArcMap,
see http://webhelp.esri.com/arcgisdesktop/9.3/pdf/Editing Tutorial.pdf

5) In ArcCatalog, create an empty feature class with the schema of the bb_cov feature class and load the
feature class created above into it.

a) Right-click on the empty feature class, select Load>Load data from the dropdown menu and navigate
to the location of the service area feature class

b) Pressthe Add button, hit Next

c) Accept the defaults and hit Next

d) Do NOT attempt to map any fields, as seen below:



http://webhelp.esri.com/arcgisdesktop/9.3/pdf/Editing_Tutorial.pdf
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Simple Data Loader

For each target field, select the source field that should be loaded into it

Target Field Iatching Source Field i

|Pru'.fName [ztring] <None> =
_|DBAName [string] <None>
| FRN [int] <None=
_| GeogUnit [string] <None>
|| GeogUnitiD [string] <None>
| TrangTech [ghort int] <None=
| MaxAdvDown [ghort inf] <Nong>
| MaxAdvUp [short int] =None>
| ARPU [float] <None=

SWhNomSpeed [float] <Nong= bt

Reset

< Back | Mext = | Cancel

a) Press Next, then Next again, then Finish.
6) In ArcToolBox, go to Data Management Tools>General>Append
7) Append the formerly empty feature class to bb_cov, completing the dialog box as seen below:

Input Datasets —

| = @

Target Dataset
| C:\Working'\Broadband\ProviderData\Columbine\Columbine. gdb\bb_cov ﬂ

Schema Type (optional)

]
=]
#|

Field Map {optional)

QK | Cancel Environments... | Show Help == |

8) Leave the Schema Type as TEST




BROADMAP

Beyond The Boundaries

9) Press OK.
10) In ArcMap, open up bb_cov for editing and manually input associated attribution if necessary.

3.5.4 Polygonal Data
3.5.4.1 Coverage Area — PDF/JPG/Other Image Format

In the event that the provider supplies coverage area data in some image format such as PDF or JPG format please
follow the steps below:

1) Ifin PDF format, open in Adobe Acrobat and Save As... JPG format.
2) Open up the JPG image in ArcMap.
3) Add the required basemap vector data for georeferencing.
a) This will generally be either the CDOT data or TIGER data
4) Change the coordinate system of the data frame to the desired end coordinate system
5) Zoom to the general location of the JPG map image
a) Thisis the location based on the vector data, not the JPG image itself. For example, if you know that
the JPG image represents an area around the town of Limon, zoom to the town of Limon in your
vector data.
6) Open up the Georeferencing toolbar by selecting View>Toolbars>Georeferencing from the main menu bar.
7) Using the Georeferencing toolbar, select Fit to Display, results seen below:

= promider_data_processing_L.mad - Archap - Arcinio

) A BD W s - o
B LE I IE] =]
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8) Use the Control Point button "Z'- to add control points to the map
9) Use common points in the base data set and the JPG image
a) For example, find major street intersections, county/city boundaries, etc.
b) Try to distribute the points more or less in the four corners on the image for the best transformation
10) Click on the location on the image first, then click on the corresponding location on the vector data base
map, as in the image below:
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11) After placing each control point, the image transformation will update automatically.
12) Repeat until satisfied with the transformation.

a) Note: The transformation may take up to four points, although sometimes only two are necessary.
13
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When satisfied with the transformation, select Update Georeferencing from the Georeferencing toolbar
dropdown.

a) This will create a “world” file (.jgw in the case of JPGs) in the same directory as the image file.

14

-

In ArcCatalog, create a new polygon shapefile with the appropriate data schema for a provider coverage
area, which can be found in Appendix D.

Add the shapefile to ArcMap.

Using the Editor Toolbar, select Start Editing. Set the Task: to “Create New Feature.”

15
16

— —

17) Use the Sketch Tool ‘? bl to digitize a new coverage polygon using the coverage area outline from the

~

georeferenced JPG and add the required attributes manually.
18
19

~

Repeat the above steps for all subscriber speed coverage areas provided.

-

Follow the steps detailed in Coverage Area — GIS Data below.

3.5.4.2 Coverage Area — KML/KMZ

In the event that the provider supplies coverage area data in Google Earth KML or KMZ format please follow the
steps below:

1) Use a KML to SHP converter to translate file into an ESRI format
2) http://arcscripts.esri.com/details.asp?dbid=15603



http://arcscripts.esri.com/details.asp?dbid=15603

3)
4)

5)
6)
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Download the script and follow the provided instructions for installing it in ArcToolbox.
Double-click on the script in ArcToolbox and navigate to the location of the KML file, as seen below:

KML File

| C:'\Documents and Settings\forr \Desktop\Google \fiupton. kml
Feature Type

| PoLYGON =l
=

Output shapefile
|C:\,D0cumenis and Settings\forr \Desktop\Google\fiupton_kml_to_shp.shp

oK | Cancel | Environments...| Show Help >> |

Add the new shapefile to ArcMap. Repeat for all KML files provided.
Follow the steps detailed in Coverage Area — GIS Data below.

3.5.4.3 Coverage Area — CAD Data

In the event that the provider supplies coverage area data in GIS format please follow the steps below:

1)
2)
3)
4)

5)

6)
7)

8)

9)

Transform the CAD dataset into an ESRI format
http://webhelp.esri.com/arcgisdesktop/9.2/index.cfm?TopicName=Transforming CAD datasets

It may be necessary to contact the provider first to determine the coordinate system of the CAD data.

If the CAD data is not in a standard coordinate system, it may be necessary to use ArcMap to
georeference the CAD data to a known coordinate system first.

a) Todo so, follow the instructions provided above in “Coverage Area — PDF/JPG/Other Image Format.”
In ArcCatalog, create a new polygon shapefile with the appropriate data schema for a provider coverage

area, which can be found in Appendix D.
Add the shapefile to ArcMap.
Using the Editor Toolbar, select Start Editing. Set the Task: to “Create New Feature.”

Use the Sketch Tool ‘? bl to digitize a new coverage polygon using the coverage area outline from the
georeferenced CAD file and add the required attributes manually.
Follow the steps detailed in Coverage Area — GIS Data below.

3.5.4.4 Coverage Area — GIS Data

In the event that the provider supplies coverage area data in GIS format please follow the steps below:

1)

In ArcCatalog, create an empty feature class with the schema of the bb_cov feature class and load the GIS
feature class either created above or supplied by the provider into it.



http://webhelp.esri.com/arcgisdesktop/9.2/index.cfm?TopicName=Transforming_CAD_datasets
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a) Right-click on the empty feature class, select Load>Load Data from the dropdown menu and navigate
to the location of the service area feature class

b) Press the Add button, hit Next

c) Accept the defaults and hit Next

d) Do NOT attempt to map any fields, as seen below:

%]

Simple Data Loader

For each target field, select the source field that should be loaded into it

Target Field Matching Source Field =
|Pru'.fName [ztring] <None>
_|DBAName [string] <None>
| FRN [int] <None=
_| GeogUnit [string] <Nong>
| GeogUnitiD [string] =None>
_| TransTech [ghort int] <None=
| MaxAdvDown [ghort inf] <Nong>
| MaxAdvUp [short int] =None>
| ARPU [float] <None=

SWhNomSpeed [float] <Nong= bt

Reset

< Back | Mext = | Cancel

e) Press Next, then Next again, then Finish.
2) In ArcToolBox, go to Data Management Tools>General>Append
3) Append the formerly empty feature class to bb_cov, completing the dialog box as seen below:
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B

Ly

Input Datasets =
| ==
C:\Working'Broadband\ProviderData\Columbine \Columbine.gdb\service_area_bb... +
x

Target Dataset

|C: \Working \Broadband'ProviderData\Columbine \{Columbine. gdb\bb_cov j =
Schema Type (optional)

fTEST, ~|
Field Map (optional)

‘ W

OK | Cancel | Environmenis...| Show Help == |

4) Leave the Schema Type as TEST
5) Press OK.
6) In ArcMap, open up bb_cov for editing and manually input associated attribution, if necessary.

3.5.4.5 Compact Polygon From Subscriber Points

e Geo-code address list using latest state “Composite Locator”

e Verify that your geo-coded file has only one TT (Technology Type). If not export individual geo-coded
layers for each Technology Type.

e  For each TT check for differences in speed values or speed tiers and create separate layers for each speed
value/tier.

e (Clean your geo-coding results - remove any points that geo-code to accuracy levels below ZIP+4 (ZIP
centroids, carrier route centroids, etc). Also, verify that outliers with acceptable accuracy levels are
legitimate, i.e. fall in correct City and Zip.

e Perform spatial join between county polygons (using stcnyfips field) and the cleaned geo-coded subscriber
points, in order to carry the county name and stcnty fips.

e Summarize the number of subscribers by county and use the subscriber counts by county to populate the
Rate Tier table.




Un-join the county data from the geo-code subscribers list.

Create Compact Polygon using cleaned geo-coded layer or sub-selection of using — XtoolsPro —
ConvexHull-DetailedHull option. A sub-selection of geo-coded points will be used in areas where more
than one polygon will need to be created for one provider’s service area.

Evaluate output Hull carefully — looking for areas that should not be covered by hull polygon.

o Ifitis determined that an area or areas should not be represented in coverage area, manually
reshape hull polygon until coverage area is adequate.

o When not obvious and as a general rule, manually resolve compact polygon when the distance
between the subscriber points used to define the outer boundary of the compact polygon
exceeds 5 miles. When reshaping the hull polygon, snap to the outermost geo-coded points.
See figure 2 and 3 for an example.

FIGURE 2- Compact Hull: Manual Resolution Required

Original
Compact Hull

As a general rule if the distance between
the subscriber points used to define the outer
boundary of the compact hull exceeds 5 miles,

manually reshape hull.

)
)




FIGURE 3a- Compact Hull: Manual Resolution Required
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FIGURE 3b- Compact Hull: After Manual Resolution
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e To attribute the compact polygon - Perform a “Spatial Join” where your Target Feature Class is the

compact polygon and the Join Feature Class is your geo-coded point layer. Export compact hull with

joined attributes and name file appropriately.

e Append attributed compact polygon to BroadBand TT template Feature Class and if required manually

input any provider attribution that may not have carried over in the append process.

e Intersect compact polygon with county boundaries to create unique records by county and use the state-

county-fips field to populate “stcty_fips” field. Also use the county name field to populate the

“BBCov_Name” field.

o Exceptions is where a provider’s coverage is distributed throughout more than one area of any

given county where the “BBcov_Name” should be populated using an appropriate city or other

logical name based on geographical location.

e Export/Load into appropriate BB TT model Dataset.

3.5.4.6 Census Blocks — List or Spreadsheet

In the event that the provider supplies census block data in a list or spreadsheet, please follow the steps below:
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1) Ensure block polygons supplied by the provider are 2000 currency

2) If other currency, convert to 2000 currency before proceeding
a. Todo this, remove the trailing letter (a, b, etc.) from the block ID
b. You will now have two blocks that equate to one block in the 2000 block geometry
c. Delete duplicate block IDs, retaining the higher service tier in each case

3) Prepare the block list in clean Excel format, removing all Excel-only formatting, merged cells, colors,
borders, etc.

4) Import the spreadsheet into ArcMap.

5) Right-click on the 2000 census block feature class in the layer list in ArcMap and select Joins and
Relates>Join from the drop down menu. Join the census block list to the 2000 census blocks feature class
using the block ID and export joined records in a new feature class. The Join dialog box and process can be
seen above in the TIGER Street Segments — List, Spreadsheet, or GIS Data section.

6) Follow the steps in Census Blocks — GIS Data below.

3.5.4.7 Census Blocks — GIS Data

In the event that the provider supplies census block GIS data please follow the steps below:

1) Ensure that the blocks supplied by the provider are in the required data schema and are complete as far
as require attribution.

a. If not, manually enter the required attribution or contact the provider to fill gaps.

2) If census block geometry is distributed throughout more than one county then select Data Management
Tools>Generalization>Dissolve in ArcToolbox and dissolve based on County/Provider/TT/Speed Tier so
that unique records are created for each unique combination.

a. The dissolve dialog box can be seen above in the TIGER Street Segments — List, Spreadsheet, or
GIS Data section.

YAMHILL COUNTY 5 N
Undissolved Census blocks V4 r

~Yamhill County,
p ,__ | Provider A ey
Do Ay [ TT10 P
= i - | [Speed Tieri1, s <

)
Polk County
Provider ASs———=4% 7

110 3 f
Speed Tier 1

POLK COUNTY

Figure 1: Undissolved census block polygons




2)

3)

4)
5)
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Dissolved Census Blocks
will all slivers and holes removed.

YAMHILL COUNTY

Yamhill County
Provider A
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2= S
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e ——— ke S IR o= i e == I,
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— Provider A
i 1710
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Figure 2: Census block polygons dissolved by county

For each dissolved region use the Editing toolbar in ArcMap to remove unnecessary slivers and other

small holes.

In ArcToolbox, select Data Management Tools>General>Merge and merge the processed polygons

together into single layer.

The merged census blocks will need to have the subscriber’s “frn” field added and populated.
In ArcCatalog, create an empty feature class with the schema of the bb_cov feature class and load the GIS

feature class either created above or supplied by the provider into it.

a. Right-click on the empty feature class, select Load>Load Data from the dropdown menu and

navigate to the location of the service area feature class
b. Pressthe Add button, hit Next
c. Accept the defaults and hit Next
d. Do NOT attempt to map any fields, as seen below:
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Simple Data Loader

For each target field, select the source field that should be loaded into it

Target Field Iatching Source Field i

|Pru'.fName [ztring] <None> =
_|DBAName [string] <None>
| FRN [int] <None=
_| GeogUnit [string] <None>
|| GeogUnitiD [string] <None>
| TrangTech [ghort int] <None=
| MaxAdvDown [ghort inf] <Nong>
| MaxAdvUp [short int] =None>
| ARPU [float] <None=

SWhNomSpeed [float] <Nong= bt

Reset

< Back | Mext = | Cancel

e. Press Next, then Next again, then Finish.
6) In ArcToolBox, go to Data Management Tools>General>Append
7) Append the formerly empty feature class to bb_cov, completing the dialog box as seen below:

Input Datasets —

| = @

Target Dataset
| C:\Working'\Broadband\ProviderData\Columbine\Columbine. gdb\bb_cov ﬂ

Schema Type (optional)

]
=]
#|

Field Map {optional)

| b

QK | Cancel Environments... | Show Help == |

8) Leave the Schema Type as TEST
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9) Press OK.
10) In ArcMap, open up bb_cov for editing and manually input associated attribution, if necessary.

3.6 Metadata Transactions

Following any updates or changes completed within the file geodatabase (fGDB) stored on the GIS-Analysts staging
environment, the GIS-Analyst runs transactions to compare that f{GDB with the one stored on the Core server to
ensure metadata on all changes are recorded.

Below outlines the steps taken to run transactions on the updated Core database:

1. Openacommand line window and run generateTransactions.py
a. Usage: generateTransactions.py [Core fGDB] [Staging Environment fGDB]

b. Example of command line:
<path>generateTransactions.py <path>ST_BB_POLY_SRV_AREAS.gdb <path>ST_BB_POLY_SRV_AREAS.gdb

2. Below is an example of the output screen that will be displayed:

Collecting Transactions

Calculating rec_id field for BBCov_W_BBE_FPOLY_TEMPLATE
value can not he B or less
Troubhle creating the progress meter

Calculating rec_id field for BBCov_18_CenturyLink

Merging change: X:~BDIA_BE_GDBE=-M5_BB_POLY_SRU_AREAS .gdb~AddPt
Calculating Tranzaction fields for AddPt

W :~BDIA_BB_GDB=~MS_BB_POLY_SRU_AREAS .gdb~AddPt.. .changesz is complete.

Your transaction FeatureClasses are in:
~smichigansAllAccess“BDIA_BB_GDB=_HIST-MS_BBE_POLY_SRU_AREAS_HIST .gdh

elapsed time = 2994.4 seconds




3. After process has completed, results can be found in the ST_BB_POLY_SRV_AREAS_HIST.gdb

a. The transactions scripts records changes at a feature level.

b. Below is a screen shot supporting the directory structure of the historical fGDB.

Bl ArcCatalog - ArcView - M:\BDIA_EB

STVWCO_BB_POLY SRV _AREAS HIST.gdb

File Edit View Go Tools Window Help
@ BEX|[LEER S @OR V| a2 0en |0 |E|
Location: IM:\BDI.F\_BB_GDBS_HIST\CO_BB_POLY_SR\I’_AREAS_HIST.gdb LI ‘
oot [Fe0CESR o] of 5 L% 5 |
|| Contents | Preview I Metadata I
55 CO_BB_POLY_SRV_AREAS HIST.gdb - —
Ll Addpe agnaec 10N HPZ database F cl I ;1;:;2;:0 8:57:53 AM
oV unn ile Geodatabase Feature Class =TH
gggz:‘gap%:gwpm“ [ Addpt File Geodatabase Feature Class 11/30/2010 4:49:46 PM
T BECov 80_ATT File Geodatabase Feature Class 11/30/2010 4:37:35 PM
- 88Cov 10 BigSandy BBCov_80_Sprint File Geodatabase Feature Class 8/30/2010 9:24:00 AM
ggg”"—ig—g?”” — | Bl BBCov_10_DuboisTelExchange File Geodatabase Feature Class 8/30/2010 8:21:41 AM
ovb_blanca [Ell BBCOV_70_Mobilelnet File Geodatabase Feature Class §/30/2010 8:22:48 AM
Bl BBCov_10_Centurylink BBCov_10_Sunflower File Geodatabase Feature Class §/30/2010 8:23:55 AM
& BBCov_10_Columbine BBCov_10_Qwest File Geodatabase Feature Class 8/30/2010 8:25:11 AM
-[El] BBCov_10_Covad BBCov_30_XOComm File Geodatabase Feature Class 8/30/2010 8:26:18 AM
BBCov_10_DuboisTelExchange BBCDV_41_CDmCESt File Geodatabase Feature Class 8/30/2010 8:27:24 AM
..[El| BBCov_10_ESRTA = BBCov_20_XOComm File Geodatabase Feature Class 8/30/2010 8:28:32 AM
..[El BBCov_10_Farmers BBCov_50_Rye File Geodatabase Feature Class 8/30/2010 8:29:39 AM
../l BBCov_10_Glenwood BBCowv_71_SECOM File Geodatabase Feature Class 9/10/2010 10:59:47 AM
/5l BBCov_10_HaxtunTele BBCov_50_Glenwood File Geodatabase Feature Class 8/30/2010 8:32:01 AM
BBCov_10_Internet_CO BECov_ 10_Rico File Geodatabase Feature Class 8/30/2010 8:33:21 AM
[ BBCov_10_JED BBCov_71_Sanlsabel File Geodatabase Feature Class 8/30/2010 9:31:55 AM
BBCDV_].U_NUHH | BBCov_80_Verizon File Geodatabase Feature Class 8/26/2010 2:33:20 PM
BBCDV_IU_PineDri\.re BBCov_10_Wiggins File Geodatabase Feature Class 8/30/2010 8:37:43 AM
[E] BBCov_10_PlsinsCoop BBCDV_IU_P!.EIHSCDDFJ F!Ie Geodatabase Feature Class 11/30/2010 4:35:50 PM
BBCDV_].U_QWESt BBCov_70_Bijou File Geodatabase Feature Class 11/30/2010 4:36:30 PM
. BBCov_30_Covad File Geodatabase Feature Class 9/10/2010 11:07:22 AM
&l BBCov 10 Rico BBCov_70_SouthPark File Geodatabase Feature Class 8/30/2010 8:42:13 AM
{5 BBCov 10 Rye [EN BB 10 HavtinTal Eil Jatal Ecatirs Clace 202010 84247 AKA

c. Attribution associated with each added/removed/changed features is tracked, including the
following additional columns appended to the end of each:
i. Commit_by
1. Records the GIS-Analyst that committed the changes to the historical f{GDB.

ii. Commit_date
1. Records the date and time stamp that the changes were committed.

iii. Trans_type
1. This field reflects the type of change recorded.
2. Categorized by:
a. Adds/Change/Deletes

iv. New_values




1. Records the new values when a change was completed on a feature. Example:
Name or speed change

d. MD_Process is also transferred from the edited fGDB to the historical fGDB, which states the
actions completed by the GIS-Analyst.

&) ArcCatalog - ArcView
File Edit View Go Tools Window Help
NEL LR R T L R R TR
Location: [ M:\BDIA_BB_GDBs_HIST\CO_BB_POLY_SRV_AREAS_HIST gdb'AddPt ~]
Stylesheet:  [FGOC £5RI HRE TR |
2| Conterts Previen | Metadata |
.5 CO_BB_POLY_SRV_AREAS_HIST.gdb -

[ Addpt md_address md_process commit_by commit_date trans_type new_values
B8Cov 0_POLY TEMPLATE by_v12, added Jab Mid Mile points back into db per critigen cmabey 82412010 4:43:5 | change 5767]
B8eon 10, Agate addBas BB Hetadata elds.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 872472010 4435 | change 5768]

104 addBascBBMetadataFields.py_v1 2, added Jab Mid Mie points back info db per critigen cmabey /2472010 4435 | change 5769]
BBCov_10_BigSandy addBaseBBMetadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey 802412010 4:43:5 | change 5770
BBCov 10 Bijou addBaseBEMetadataFields.py_v1.2, added Jab Mid Mie points back info db per critigen cmabey 812412010 4:43:5 | change 57711
BECov_10_Blanca addBascBBMetadataFields.py_v1 2, added Jab Mid Mie points back info db per critigen cmabs /2472010 4435 | change 5772]

py_v12, 3 per criti ey g
BBCov_10_CenturyLink addBaseBBMetadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey BI2412010 4:43:5 | change 577
BBCov_10_Columbine addBas BB Hetadata elds.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 872472010 4435 | change 5774
B8Cov 10 Covad addBascBBMetadataFields.py_v1 2, added Jab Mid Mie points back info db per critigen cmabey /2472010 4435 | change 577"
B8Cov_10_DuboisTelExchange a09BaseBBHetadataFielss py_v1 2, added Jab i e points back mo db per criigen cmabey BI2412010 4:43:5 | change 5776)
BBCor 10 ESRTA addBascBEBHetadataFields.py_v1 2, added Jab Wid ik points back info db per critigen cmabey 872472010 4435 | change 5777)

o addBaseBBMetadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey BI2412010 4:43:5 | change 577
BBCov_10_Farmers addBas BB Hetadata elds.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 82472010 4435 | change 5779
BBCov_10_Glenwood addBaseBBletadataFields py_v12, added Jab Mid Mie points back into db per riigen cmabey 802412010 4:43:5 | change 5780]
BBCov_10_HaxtunTele addBaseBBMetadatarields. py_v1 2, added Jab Wid Mie points back into db per criigen cmabey 82412010 4435 | change 5781]

ov_10_Internet_ addBaseBEetadataFields.py_v12, added Jat e points back into db per critigen cmabey change
Il BECov_10_] co ddBaseBEMetadataFields.py_v1.2, added Jab Wid Hie points back into db per crit 2 872472010 4435 | ch 5782)
BECov_10_ED addBascBBMetadataFields.py_v1 2, added Jab Mid Mie points back info db per critigen cmabey /2472010 4435 | change 5783]
BECov_10_Nunn addBaseBBMetadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey BI2412010 4:43:5 | change 5784]
B8Cav 10 PincDrive 2dd8aseBBlictadslaF elis oy 1.2, added Jab e e ponts back nlo do per crifgen cmabey 872472010 4435 | change 5785]
BBCon 10 PlomsCan addBascBBMetadataFields.py_v1 2, added Jab Mid Mie points back info db per critigen cmabey /2472010 4435 | change 5788]

- P addBaseBBHetadataF elds.py_v1.2, added Jab Hid Wi points back info db per critgen cmabey 872472010 4435 | change 5787)

-] BBCov_10_Qwest addBaseBBMetadataFields.py_v1.2, added Jab Mid Mie points back into db per criigen cmabey 22472010 4435 | change 5738]

BBCov_10_Rico addBaseBBMetadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey BI2412010 4:43:5 | change 5789]
BBCov_10_Rye addBas BB Hetadata elds.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 872472010 4435 | change 5790]
BBCov_10_SandT addBascBBMetadataFields.py_v1 2, added Jab Mid Mie points back info db per critigen cmabey /2472010 4435 | change 5791]
BBCov_10_Sunflower addBaseBEMetadataFields. py_v1.2, added Jab Mid Mie points back into db per critigen cmabey @/2412010 4435 | change 5792]
BBCov 10 TDS addBas BB Hetadata elds.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 872472010 4435 | change 57931
BBCow 10 Wiggins addBascBBMetadataFields.py_v1 2, added Jab Mid Mie points back info db per critigen cmabey /2472010 4435 | change 5794]
[ ggd addBaseBBMetadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey BI2412010 4:43:5 | change 5795]
v tova addBaseBEetadataFields. py_v1.2, added Jab 1id Mie points back info db per critigen cmabey 872472010 4435 | change 5796]
BBCov_20 Internet CO addBaseBBMetadataFields.py_v1.2, added Jab Mid Mie points back into db per criigen cmabey 82472010 £.435 | change 5797]
BECov_20 NewEdge addBaseBBMetadataFields.py_v1.2, added Jab Mid Mie points back into db per criigen cmabey 82472010 4:43:5 | change 5798]
BBCov_20 XOComm addBascBBMetadataFields.py_v1 2, added Jab Mid Mie points back info db per critigen cmabey 87242010 4:43:5 | change 5799]
BBCov_30_Covad addBaseBBMetadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey BI2412010 4:43:5 | change 15800]
B8BCov_30_Internet CO addBas BB Hetadata elds.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 872472010 4435 | change [5801)
BBCov_20_NenEdge addBascBBMetadataFields.py_v1 2, added Jab Mid Mie points back info db per critigen cmabey /2472010 4435 | change 5802
BBCov 30 TWTelecam addBaseBBMetadataFields. py_v1 2, added Jab Mid Mie points back into db per criigen cmabey BI2412010 4:43:5 | change 15803]
B8Con 30 X0C addBas BB Hetadata elds.py_v1.2, added Jab Hid Mie points back info db per critgen cmabey 872472010 4435 | change [5804]
ovtAULomm addBaseBBMetadataFields.py_v1.2, added Jab Mid Mie points back into db per critigen cmabey 22472010 4:435 | change [5805]
BBCov_40_CommComm a00BaseBBMetadataFields.py_v1.2, added Jab Wid Mie points back into b per criigen cmabey B2412010 £.43:5 | change [5806]
BBCov_41_Baja < AARiao aRBlatariataFialie mi 19 addad |2h Ui His nninte hark inin An nar ~inen e 2PAPNN 447 | mhanns reanm
BECov_41_Bresnan k!
BECov_41_Comcast Record: ﬂ j 1 j ﬂ show: [l Selectzd Records (of 29424) Options -
BECov_41_FagleCom —
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3.7 Data Processing

3.7.1 Data Processing Overview

The following items outline the actions required to process the service provider data further to meet the NTIA
requirements.

e Weighted Nominal Speed

e  Middle Mile

e Broadband Coverage Template

3.7.2 Weighted Nominal Speed
The weighted nominal speed is populated one of the following two ways:
3.7.2.1 Subscriber Data Supplied by Provider

Where we are supplied with subscriber speed information by the data provider, we use the following formula from
the NOFA:
(speed tier-1 in kbps x no. of tier-1 subscribers) + (speed tier-2 in kbps x no. of tier-2 subscribers) + (etc.)

Total average monthly subscribers

Data is initially broken up in the following order:
1) Stcty_fips
2) Transmission technology type
3) Subscriber tiers

3.7.2.2 Value Supplied by Provider

Some providers will supply their weighted nominal speed. In these cases, the data supplied will be populated
instead of using the NOFA formula.

When these values have been obtained or calculated, they are used to update the service overview layer. This can
be done manually or by creating a table with the provider’s FRN and average weighted speed and joining it to the
service overview table in ArcMap. To Join, right-click on the layer you would like to join to and select Joins and
Relates>Join... from the dropdown menu. Then navigate to the table you want to join and select the join fields
from the drop down lists. Then open up the source table (the table in ArcMap) and right-click on the header of the
Average Weighted Speed field and select Calculate Field from the drop down menu. Use the value of the average
weighted speed from the joined table.

3.7.3 Middle Mile

Middle mile information is generally provided in spreadsheet or text file format. The process is to take what is
supplied by the provider and translate it into the required data schema.
1) If the data is supplied with address information, follow the process outlined above in Subscriber Location
— Address Data.
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2) If the data is supplied with associated XY coordinates, follow the process outlined above in Subscriber
Location — XY Data.

3) Once the data is in GIS format, use the Append (Data Management Tools>General>Append) command in
ArcToolbox to append the data to the overall middle mile dataset.

4) Set the schema type to NO_TEST and use the Field Map to map the attribute fields from the source to the

target dataset.

3.7.4 Broadband Coverage Template

Below is the description of the fields within the BB_Cov layer, which is the interim data set that is used to create

the final product deliverable.

Description

.

objectid OBJECTID Internal Object ID

shape SHAPE Internal Shape storage

prov_id PROVIDER_ID Unique numeric identifier for each provider

prov_name PROVIDER_NAME Unigue name for each provider

dba_name DOING_BUSINESS_AS An alternative "Doing-Business-As" name for the provider
FCC_REGISTRATION_NUMBE . . .

frn R Provider FCC Registration Number

bbcov_name BBCOV_NAME BroadMap Broadband Coverage name

trans_code

TRANSMISSION_CODE

Unique code for the transmission technology type described by
this layer

trans_name

TRANSMISSION_NAME

Name for the transmissions technology type

trans_desc

TRANSMISSION_DESC

Description for the transmissions technology type

spect_code

SPECTRUM_CODE

Unique code for the spectrum [WIRELESS ONLY]

spect_name

SPECTRUM_NAME

Name for the spectrum [WIRELESS ONLY]

spect_desc SPECTRUM_DESC Description for the spectrum [WIRELESS ONLY]

Maximum advertised downstream speed available within given
mad_dwn_t MAX_AD _DOWN_TIER .

-7 - T - area (speed tier)

Maximum advertised upstream speed available within given
mad_up_t MAX_AD_UP_TIER _

area (speed tier)

Typical downstream speed available within given area (speed
typ_dwn_t TYPICAL_DOWN_TIER _

tier)
typ_up_t TYPICAL_UP_TIER Typical upstream speed available within given area (speed tier)

Maximum advertised downstream speed available within given
mad_dwn_k | MAX_AD_DOWN_KBPS

area (kbps)

Maximum advertised upstream speed available within given
mad_up_k MAX_AD_UP_KBPS

area (kbps)




BROADMAP

Beyond The Boundaries
Name Alias ‘ Description
typ_dwn_k TYPICAL_DOWN_KBPS Typical downstream speed available within given area (kbps)
typ_up_k TYPICAL_UP_KBPS Typical upstream speed available within given area (kbps)
Total average monthly subscribers for this provider for this
subs SUBSCRIBERS ,
technology for this coverage polygon
Metadata: Comma separated list of source id's from which the
md_geom MD_GEOMETRY
polygon extent was produced
. Metadata: Comma separated list of source id's used in
md_exists MD_EXISTS . . . .
- - understanding and editing the provider data for this polygon
Metadata: Name of the editor who last edited this feature at
md_who MD_WHO .
the time in md_when
md_when MD_WHEN Metadata: Date/timethat this feature was last edited
Metadata: Comma separated list of processed used to create
md_process MD_PROCESS . .
and/or modify this layer
stcty_fips STATE_COUNTY_FIPS State/County FIPS code
Compound Key formed from
rec_id RECORD_ID STCTY_FIPS+"|"+Provider_ID+"|"+Trans_Code+"|"+BBCov_Nam
e
st_area ST_AREA(SHAPE) Area in square decimal degrees
st_length ST_LENGTH(SHAPE) Length in decimal degrees

Provider_Typ
e

Type of Provider

Has Subtype (1:Broadband provider as described in the
NOFA,2:Reseller,3:Unknown), default value =1 (New 04/11
Model)

3.7.5 Verification and Validation

3.7.5.1 Provider Validation — Provider Portal/PDF Map Review

Following the collection and aggregation of provider data, the data is then validated by the provider to ensure the

data aggregated is an accurate representation of their coverage area and supporting broadband information.

This is completed through the Provider Portal web application, which is a secure interactive map displaying their

coverage areas and allows the user to validate, submit feedback or request changes. If changes are requested,

then the features on the portal are then updated and an automatic request is sent to the provider to complete the

validation effort.

For some providers that did not use the Provider Portal, a PDF was sent displaying their coverage map and

validation was then completed via e-mail notification.
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3.7.5.2 Provider Verification — 3™ Party Source Review

Once the provider has validated their coverage areas, a 3" party source comparison and analysis is then

performed. Where anomalies or discrepancies are identified, a ‘SCAN’ point is dropped and descriptive comments

applied so they can later be reviewed with the provider.

During the provider review, the map is displayed along with the ‘SCAN’ points and potential refinement is

completed based on input from the Provider.

3" Party Sources Utilized

3 Party Source Name

Source Type

Verification Type

InfoUSA

Consumer and Business
Listings

Community Anchor Institutions
Can also be used for demographic information supporting
the State websites

Pitney Bowes (PBBI)

Exchange Info Plus
(Central Office Locations)

Exchange datasets are used to verify the following
Transmission Technologies (TT):

Asymmetric xDSL (10), Symmetric xDSL (20), Other Copper
Wireline (30), and Optical Carrier/Fiber to the End User
(50).

Media Prints

Cable Boundaries

Used to verify the following TT:
Cable Modem—DOCSIS 3.0 (40) and Cable Modem—Other
(41)

American Roamer

Wireless Coverage
Patterns (EVDO, GPRS,
WISP, HSPA)

Used to verify the following TT:

Terrestrial Fixed Wireless—Unlicensed (70), Terrestrial
Fixed Wireless—Licensed (71) and Terrestrial Mobile
Wireless (80)

ComSearch

Wireless Spectrum
Holdings and Tower Data

Used to verify the following TT:

Terrestrial Fixed Wireless—Unlicensed (70), Terrestrial
Fixed Wireless—Licensed (71) and Terrestrial Mobile
Wireless (80)
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3.7.5.3 Assigning Confidence Values

All efforts from the above-mentioned validation and verification activities, plus internal peer quality reviews are
combined and tracked in a Validation table. Based on the results of this analysis, a confidence value is assigned for
each provider and then each technology.

The confidence values are as follows:
0 = Coverage area has not been reviewed
10 =Extremely Low. Single Source QC.
20 =Very Low. Needs Additional Validation\Verification
30 =Llow. Even with Validation\Verification, Coverage is still suspect.
40 = Acceptable, confirm with State prior to shipment.
50 = Meets requirements to be included in shipment.
60 = Moderate. Meets NTIA/State’s standards, representative of Technology Type (TT)
70 =High. Accurate representation of coverage based upon TT.
80 =Very High. Multiple validation\verification with most 3™ party sources
90 = Extremely High. Multiple validation\verification sources
100 = Perfect. Multiple validation\verification sources, with complete alignment with sources and ground
truth verification activities

This Validation table is then maintained as updates or changes occur for each provider, down to technology type,
with the overall goal to improve the confidence values and overall map representation.

Example of the Validation table:
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H| Conterts Preview | Metadats |
OBJECTID * BBCOV CONFIDENCE_COQDE PROVIDER_ID PEER_QC | PROVIDER_QC THIRD_PARTY_VERIFICATION THIRD_PARTY_ID

1 | BBCov_10_Axxis 40 771 | 114472010 | 82742010 117472010 3070

2 | BBCov_10_BeaverTelCo 80 850 | 10¢18/2010 | 3/9/2011 &/712010 2010

3 | BBCov_10_CanbyTelcom 80 705 | 10/18/2010 | 8/21/2010 &/712010 2010

4 | BBCov_10_CascadeUtil 70 3005 | 114412010 117412010 3070

5 | BBCov_10_CenturyLink 70 710 | 114412010 | 9/23/2010 117412010 3070

8 | BBCov_10_ColtonTel 20 713 | 114412010 | 9/18/2010 117412010 3070

7 | BBCov_10_Covad 80 717 | 114412010 | 9/23/2010 117412010 3070

8 | BBCov_10_DataVision 30 767 | 114412010 117412010 3070

S | BBCov_10_EasternOregonTelcom 80 899 | 114412010 | 9/20/2010 117412010 3070
10 | BBCov_10_Frontier 70 784 | 114412010 | 9/16/2010 117412010 3070
11 | BBCov_10_Gervais. 90 767 | 10/18/2010 | 9/22/2010 8712010 2010
12 | BBCov_10_Helix 70 726 | 114412010 | 92242010 117412010 3070
13 | BBCov_10_integra 30 790 | 10/18/2010 | 9/27/2010 8712010 2010
14 | BBCov_10_McMinnville 60 732 | 114512010 | 927/2010 11/5/2010 3070
15 | BBCov_10_Molalla 50 734 | 10/18/2010 | 2/8/2010 8712010 2010
16 | BBCov_10_MoniterCOOP 70 1100 | 10418/2010 | 9417/2010 &72010 2010
17 | BBCov_10_Monroe_Telephone &0 736 | 10/18/2010 | 9/20/2010 &72010 2010
18 | BBCov_10_Mtangel 90 707 | 1018/2010 | 3/9/2011 &72010 2010
19 | BBCov_10_Nehalem &0 795 | 10/18/2010 | 92842010 &72010 2010
20 | BBCov_10_NerthStateTel 40 738 | 31182011 | 3182011 11752010 3070
21 | BBCov_10_OregonTeleCo 20 739 | 114572010 | 8/14/2010 11782010 3070
22 | BBCov_10_People 80 1012 | 11452010 | 9417/2010 11/5/2010 3070
23 | BBCov_10_PingTelephone 70 757 | 1041572010 | 31752011 /972010 2010
24 | BBCov_10_Pioneer 70 740 | 114572010 | 972042010 11/5/2010 3070
25 | BBCov_10_Qwest 80 1102 | 11482010 | 772010 117812010 3070
26 | BBCov_10_Rionet 50 807 | 114872010 | 9/27/2010 117812010 3070
27 | BBCov_10_Roome 90 746 | 1041872010 | 9/10/2010 6712010 2010
28 | BBCov_10_Sandy 80 873 | 114812010 | 9/17/2010 117812010 3070
29 | BBCov_10_Scio 90 800 | 10/15/2010 | 311772011 8i9/2010 2010
30 | BBCov_10_SCS 80 1030 | 114872010 | 9/17/2010 117812010 3070
31 | BBCov_10_SCTC 70 803 | 10/18/2010 | 9/17/2010 11/10/2010 3070
32 | BBCov_10_StPaulTel 20 750 | 3152011 | 311572011 8712010 2010
33 | BBCov_10_TDS 40 752 | 1011812010 8712010 2010
34 | BBCov_10_TransCascade 40 709 | 11/8/2010 | 9/21/2010 11/8/2010 3070
35 | BBCov_20_CanbyTelcom 80 706 | 10/18/2010 | 9/21/2010 8712010 2010
36 | BBCov_20_ClearCreek 80 712 | 10/18/2010 | 9/17/2010 8712010 2010
37 | BBCov_20_Covad 60 717 | 114412010 | 9/23/2010 117412010 3070
38 | BBCov_20_integra 30 790 | 10/18/2010 | 9/27/2010 8712010 2010
39 | BBCov_20_NewEdge 20 796 | 11482010 11782010 3070
40 | BECov_20_QuantumComm &0 1021 | 11/8/2010 | 423/2010 11782010 3070
41 | BBCov_20_Rionet 50 807 | 11482010 | /2742010 11782010 3070
42 | BBCov_30_CanbyTelcom &0 706 | 10/18/2010 | 9/21/2010 &72010 2010
43 | BBCOV_30_Covad &0 717 | 114472010 | 972342010 117412010 3070
44 | BBCOV_30_Integra 30 790 | 10/18/2010 | 9/27/2010 &72010 2010
45 | BBCov_30_Lightspaed 20 793 | 11482010 117812010 3070

< . ]
Record: ﬂﬂ 1 jﬂ Show: [A_Selected Records (of 122) Options ~
Preview: | Table -

3.7.6 Community Anchor Institution (CAl) Data

3.7.6.1 Data Collection

The CAl data was initially collected from the State to create the baseline inventory. All location information and
broadband coverage data supplied was also ingested into the data deliverable.

Additional collection of CAl information was done via data mining and/or webscraping to build out the inventory
further. For example: Collection of additional CAls, address and broadband data.

The state-agency-provided CAl inventory was comprehensive but the challenge is collecting broadband related
data; service provider(s), technology and speed data for each CAI. Availability of the CAl portal has not significantly
increase submission of this data. Additional promotion to CAls to utilize the CAl portal will be needed to increase
this data for subsequent deliverables.

3.7.6.2 Institution Data

Institution data is obtained from a variety of sources and almost always provided in Excel spreadsheet format. The
general process for incorporating this data is below:
1) If the datais provided in Excel or some similar format:

a. Clean and standardize the Excel spreadsheet, removing any cell formats, merged cells, etc.
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b. Standardize the address format as defined in the staging CAl database

c. Ifthe spreadsheet includes X and Y values, such as latitude and longitude, use the Add XY Data
tool in ArcMap to create a spatial data layer.

d. [Ifthere are only addresses, then follow the geocoding steps outlined above to create spatial data
points for each of the institutions.

i. Institutions that do not geocode based on the TIGER 2009 data set will have to be
manually located using Google Maps, Google Earth, or some other information source.

2) If the CAl source data is in GIS format, add the Latitude and Longitude fields and use the Calculate
Geometry tool to populate them, using the WGS 84 coordinate system.

3) Using ArcCatalog, load the new data into the staging CAl database.

4) This database is ready for the makeDeliverable.py script to process the information into the final state
and NTIA deliverables.

3.7.6.3 Community Anchor Institution (CAl) Portal Updates

A web application has been released to allow for further data collection and validation of anchor institution
location information, broadband coverage, and speed test data.

Information collected from the CAl Portal is then ingested into the overall inventory and will later be compared
against the provider coverage areas mapped for any potential discrepancies.
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3.8 Product Extract
3.8.1 Python Scripts

The following sections make use of Python scripts. In general, to use a Python scrip, you must have Python
installed on your computer. To download the latest version of Python, go to http://www.python.org/download/

and download the latest stable version. As of August 2010, this was version 2.7. Once this is installed, the general
way to run a script is to type the following at a command prompt: C:\Python27\python.exe C:\<location of script>.
Many of the scripts provided have environment variables that must be set before they can be run.

The python code for BroadMap’s product extract has been incorporated into a Hudson Cl System, which is detailed
in the Process Operation and Monitoring section of this document. This was a process improvement activity so all
processes can be monitored, controlled and contain historical tracking on each process.

3.8.2 Product Extract Process

Note: specific Python scripts are called out in red font in the sections below.
The MapConnect product extract process, makeDeliverable.py, uses the BB_Cov and BROADMAP_POINTS interim
data sets to create the following layers according to the current specifications:
e BB_Service_Road_Segment
- This layer contains all broadband services associated with specific street segments for census 2000
blocks larger in area than two square miles
e  BB_ServiceCensusBlock
- Contains all broadband services associated with census blocks of no greater than two square miles.
e BB_Service_Wireless
- This layer contains all wireless services not associated with specific addresses.
e BB_ServiceOverview
- This layer contains subscriber-weighted nominal speed for each provider's service area at a county
level and is meant to act as a summarized view.
e BB_ConnectionPoint_MiddleMile
- This layer contains middle-mile and backbone interconnection points
e  BB_Service_CAlnstitutions
- Broadband Service at Community Anchor Institutions (CAl)
= Community Anchor Institutions consist of schools, libraries, medical and healthcare providers,
public safety entities, community colleges and other institutions of higher education, and other
community support organizations and entities.

Due to a NTIA model change for the October 2010 data deliverable, an addition to this code was created to
support both models in the case a comparison is later desired or a request is made to revert back to the original
model. This script name is bdia2ntia.py and creates the following layers in addition to the layers mentioned above,
rolled up to NATL_Broadband_Map.
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e BB_ConnectionPoint_LastMile
- This layer contains last mile infrastructure points, which is only populated if data cannot be provided
at a more granular level.
e BB_Service_Address
- Represents broadband availability for service address points. Address Point availability refers to
those individual addresses at which each facilities-based provider of broadband service can provide
broadband services of minimal characteristics within 7 - 10 business days.
e State_Boundary
- State boundary supporting topological validation of point feature classes.
e NATL_Broadband_Topology
- Supports basic topology quality checking. Example: No CAl’s or Middle Mile points outside of the
state boundary

The following process flow provides a view of how the Core fGDB is extrapolated to the NTIA final deliverable via
the makeDeliverable.py script. Following that, the bdia2ntia.py script is run, which limits what’s placed in the final
layers based on the NTIA modeling standards.

The product scripts and supporting extract were originally created separately per request, in case data model
comparisons were to be completed.

3.8.3 Product Statistics

Following the completion of a product extract, the product statistics script (BDIA_ReleaseNotesStats.py) extracts
the following information supporting that product deliverable.
e Provider Statistics
- Collects all provider information, listing by Provider Name
- Provides output of FRN
- Counts the number of features supported within the following layers:
=  Census Block
= Street Segment
=  Max Upstream
= Wireless Services
= Infrastructure Points
- These updates were made to support the Data Package required to accompany every NTIA product
deliverable.
e Community Anchor Institution (CAl) Statistics
- Breaks CAl down to the 8 categories
= 1: School: K through 12
= 2: Library
=  3: Medical/Healthcare
= 4: Public Safety
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= 5: University/College
= 6: Other Government
= 7: Other Community non-government
= None: Unknown Category
e In cases where this occurs, further investigation is completed prior to product shipment to
ensure all CAl's are categorized accurately
- Reports out the following counts
=  Total CAls within that category
=  Total CAls that contain partial BB coverage
e  Contains any of the following information for given CAl:
¢ BB Subscriber, Transmission Technology, Speed Down Speed Up
= Total CAls that contain full BB coverage
e Contains all of the above-mentioned BB information for given CAI.

The output of this script is two CSV files: Anchorlinstitutions.csv and Providers.csv. These files can then be
inspected to ensure that there are the expected number of CAls and providers for every release.

3.9 Quality Assurance

Quality assurance is supported manually and algorithmically on the interim data, BB_Cov file geodatabase, and on
the final product. For scheduled product releases, a test product extract and subsequent manual and algorithmic
QC run is completed along with a release review. The product specifications, project status reports, previous
product release notes are used as references throughout this review.

The following parameters are tested using the methodology listed below each:

e  Product Deliverable Format
- Correct names and format of data deliverables
=  BDIA_QC_SUITES (please see below for details)
- Correct Projections/Datum
=  Manual interaction with product
- Metadata Present and Correct
=  Manual interaction with product
e Table Structure
- Allrequired tables included
= BDIA_QC_SUITES
- Extraneous tables identified
= BDIA_QC_SUITES
e  Field Structure
- Allfields included
= BDIA_QC_SUITES
- Extraneous fields identified
= BDIA_QC_SUITES
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- Correct field names, types and widths
= BDIA_QC_SUITES
e Field Domains
- Values in all tables are constrained to the specified values specified
= This action is accomplished via BDIA_QC_SUITES and manual review of the product
= This tends to identify project completeness issues as fields with a null value are identified.
e  Geometric Representation
- Identify if all layers have the correct geometric representation
=  Manual review of the BB_ServiceOverview layer
=  Dependent on NTIA and client requirements
e Geographic Extent
- Product includes the necessary Geography associated with Product?
=  Manual Review - ArcGIS
- Isthere extraneous geography included in Product?
=  Manual Review - ArcGIS
e Completeness
- Products contain the expected amount of data?
=  Manual review of product stats relative to weekly State reports and defined expectations.
e Accuracy
- Product meets the stated accuracy requirements for the deliverable?
=  Sampling procedure to manually review source material to resulting product
=  Provider Validation
= Verification using 3™ Party Data
= Verification against reality, where applicable
e  Data Regression
- Any unexplainable data loss or change?
= This action is accomplished by comparing results within product statistics script
(BDIA_ReleaseNotesStats.py) from previous releases, as well as manual review of the product
e Confidentiality
- Any unauthorized confidential information included in the delivery?
= Review of NDAs and delivery expectations
e  Prior Issues Resolved
- Have expected internal issues been resolved?
=  Manual review of data against previous product release notes
- Have agreed upon customer issues been resolved?
=  Manual review of data against previous product release notes, status report and client feedback
o Delivery Medium
- Has the product medium been verified?
=  Manual review
- Allfiles present
=  Manual review of SFTP site to ensure all files are copied correctly, including file/directory size
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- Correct location
=  Manual review — confirmation of SFTP link, username and password

3.9.1 QC Suite

The BDIA_QC_SUITES consists of four main types of scripts supporting the overall QC process. These scripts are all
run in concert and are called from the test_runner script and the test_BDIAProductGDB script.

3.9.1.1 Configuration
These scripts establish the configuration for the test_BDIAProductGDB script which is the core of the QC Suite.

- update_test_config

- active_config

- config_PROCESS01_automated
- config_PROCESS01_manual

- set_active_config

3.9.1.2 Libraries
These scripts provide additional functionality that is called from with the test_ BDIAProductGDB script.

- bb_unittest_fixture
- bbcov_structure

- BC_XmlWriter

- file_folder

- search_and_replace
- unittst_fixture

- validate_BB_DB

- validate_BB_GDB

- xmlrunner_gui

3.9.1.3 QC Suite

This is the core script for performing automated QA/QC on the interim and final data deliverables.
- test_BDIAProductGDB

3.9.1.4 Other

These scripts perform other functions detailed below:
- test_runner —this is the main script that runs all the other QC scripts and imports all the necessary scripts
and libraries
- which_build —this determines the current build and passes information to the configuration scripts




3.10 Process Operation and Monitoring

Product Extract, makeDeliverable.py and bdia2ntia.py, is run within BroadMap using a platform called Hudson that

has been enhanced to support BDIA product extraction, process monitoring, as well as product validation. The
same platform can be planned for implementation for the State, if desired.

Below are examples of the product create, product validation, product statistics and monitoring processes which
are managed within the BroadMap Hudson CI-System. All of the above-mentioned python scripts, with the
exception of metadata transactions script, are run via this system.

3.10.1 BDIA Product Create

Below is an example of the main page where the type of product build can be selected.

Hudson

Hudson

@ Newlob

Manage Hudson

people

1895

= Build History

Build Queue

No builds in the queue.

Build Executor Status

# Master
1/ 1dle

2 Bulding WL bechivakerlocks Stream? 22
3 gylding Postal Geocodeprep Streams £2

4 1dle
5 ldle
Suilding pocta

@ BROADMAP

All | BDIA Product Creste | BDIA Product Validation | BDIA_Sourcing  Core Database Validstion FCC Product Validation | MCE Froduct Validation  Map Connect Enterprise | Mesh Creation | Postal Product Create | Fostal Product Prep  WebPortalerep +

s w J0b |

Q BDIA Build

KK

BDIA Product Validation AS

BDIA Product Validation CNMI

BDIA Product Validation €O

(et description

Last Success Last Failure Last Duration
12 hr (£197) A 12 sec
2mo 10 days (2157) N/A &min 10 sec

3mo 22 days (281) 3 mo 23 days (280) 2 min 16 sec

[SHoRCH S}

13 days (2271) A 37 min

Selecting based on the type of process that will be initiated.

Hudson » BDIA Product Create » BDIA ProductCreate

), status
"> Changes
Workspace

[ Build Now

@ Delete Project

& Configure

% Build History

4 Back to Dashboard

@ #123 Dec9, 2010 12:30:00 PM /an0anong,
Running for provider portal update =
@ #122 Dec9,20109:53:37 AM
Running for provider portal update - Test will rerun
when Midco is complete
@ #121 Dec7, 2010 6:09:02 PM
SO build for portal test
@ #119 Dec1,201012:41:51 AM
CO Menthly Deliverable wf Crit Feedback - Round 2
@ #118 Nov 30, 2010 4:58:46 PM
CO Monthly Deliverable w/ Crit Fesdback

Project BDIA_ProductCreate

OR on Alaska

=

(trend)

186KB

179KB

Workspace

Last Successful Artifacts

* bdia2ntia.log &=
® makeDeliversble.loq &=
® robocopy.log &=

Recent Changes

Permalinks
46KB
® Last build (£123). 4 days 23 hr sa0
- @ Lact stable build (2123), 4 days 23 hr ago
® Last successful build (£123), 4 days 23 hr ago
® Last failed build (#121), 6 days 18 hr ago
S0KB ® Last build (#121), 6 days 18 hr ago

Hudson > BDIA Product Create » BDIA_ProductCreate

4 Back to Dashboard

Project BDIA_ ProductCreate

O, status

= changes
@ workspace
() suild now
© Delete Project

#C Confiaure

The Console Output can be reviewed to see the progress of product create. Following the completion of each

product creation process, an e-mail notification is automatically sent to the team.




OConsole Output

Started by user anonymsus

stent check cur behavies.

WABMTEC PRgE— t2 ba cut of ayne. This can result in inc:
Ivorkepace] § omd 43 call r L bat

Leg Fila : D:\hudses\jeba\EDIA DredustCreste’warkspacse\zobocopy.log
D:\nuS20m\3eBE\BDIA_ProuctCreste\usrkspacesaf srrorlevel 16 echo ROSOCOFY RETURN CODE 3 ~**FATAL SRR0R*~+ & goss ERROR

0:\hudsom\ 3obm\BDIA_ProdustCreate\workspacesif ercorlevel 15 scho RCBOCOPY RETURN CODE 3 FAIL MISM XTRA COFY & goto ERROR

. B0TA val 14 wche CBOCOPY RETURN CODE 3 FAIL MISM XTHA & geme ERROR

D:\nudsom\3eBa\SDTA_PraaustCraate\usrisp: rlavel 13 acho ROSOCOPY RETURN CODE 3 FAIL MISM COPY & goto ERROR

D \hadsom\obs\BDIA_FroductCreate\worksp: wcho ROBOCOFY RETURN CODE 3 FAIL MISM & guvo ZRROR

D: \nudaon: jebw\BOTA_PradustCe

\werkeps vml i1 wche BOBOCOPY RETURN COOE 3 FAIL KTRA COFY & goes EARGR

D:\nugsse\Jeba\BDTA_PradustCeasta\usskapaces

rlaval 10 acho ROSOCOPY RETURN CODE 3 FAIL XTRA & gota SRROR

D:\hadaos\cba\BIIA_TraduetCreate\workspaceif ercorlevel 3 echo AOBOCOPY AETURM CODE 3 FAIL COFY & goue ERROR

o 801A, arrorievel 8 scho AGBOGOPY ASTURN COGS 3 FAIL & goto BRAOR

D B0IA \_88_COB#A\CO_BE_DOLY_SAV_AREAE.gdb *D:thudese’jskatBOIA ProduceCesata\vazkapase”\CO_BB_OLY_SAV_AREAS.gés /MIR /LG:ssbecopy.leg

All processes run via the BroadMap Hudson CI-System are stored for historical reporting. Each process can be

reviewed, including the Console Output and Build Artifacts from that run.

Hudson

Hudson » BDIA Product Create » BDIA ProductCreate > £161

4 Backto Project
Q staus () Build #161 (Mar 28, 2011 9:44:40 PM)

= Changes

OR Pre-Release Build
B console outout

. Parameters Buid Artfacts
Taq this build @ ® bdiaontia.log &=
 makeDeliverable.log &

[7] Downstresm buid view  robocopy.log &=
4 Previous Build ey

=5 Revision: 3099

=
Next Build = o changes.

» g

‘{.f ? Started by user anonvmous

ENABLE AUTO REFRESH]

Delste this buid

Started 1 day 1 hr ago
Took 2 hr 31 min on Alaska

(edit description

3.10.2 Product Validation and Statistics

Once the product creation process is complete, Product Validation and Statistics are then initiated. These support

the BDIA_ReleaseNotesStats.py script and the BDIA_QC_SUITES scripts detailed above.

All statistics and reports are stored for historical review with the capability to place violation criticality on each
quality control check allowing the identification of errors due to project status/completeness verses project

correctness. Example: Typical Speeds populated.




Hudson

Hudson * BDIA Produst Validation » BDIA Product Validation CO ENABLE AUTO REFRESH
4 Back to Dashboard
O Status Project BDIA_Product_Validation_CO
o
2 Chances This job checks db integrity on fils GeoDatabase.
& workspace Record Error Monitor
Build Now _ 250000 =
© Dslete proect & e ll
o contius & oo /
B Bl g f
S 100000
3 g |
Build Hist. trend 5
uild History (rend)| 5 o0
Final QC on SOW monthly CO product = 5 5 5 5 F 8 5 5 2 5 5 S @ 3 2 5 & &
#270  MNov 18, 2010 9:56:35 AM 55MB T T = = o o R O -
i %2 & &2 & 2 2 & 3 3 3 3 & & & & 2 8§ 2 ¢
#2609 Nov 18, 2010 8:45:08 AM e (A =
i %2 % ¥ 2 B R 8§ B % 8 8B 5B 2B R B R G
#2668 Nov 18, 2010 9:22:49 AM 79KB @ R R ¥ 8 ¥ ¥ ¥ ¥ ¥ 8 ¥ ¥ 8 ¥ 8 & & %
0 #267  Nov 18, 2010 5:08:05 AM 77K8 D
QC on SOW monthly CO product [<+-BB_Senice_CAnstitutions Error — BB_Service_Wireles Error -+ BB_Senice_CensusBlock Emor
#266  Sep 29,2010 11:12:00 PM 4
< e |- BB_senice_Road_Segment Error -4~ BB_Service_Oveniew Error
#265  Sep 26,2010 11:17:56 BM S0k
€O validation build Latest Stats Regression: Link
#264  Sep 24, 2010 12:22:28 PM 78KE Latest Provider Regression: Link
#263  Aug 31, 20101:29:41PM 48KB Latest Error Regression: Link
#262  Aug 31, 2010 1:17:05 M 65KB [edit description
#261  Aug 31, 2010 12:22:02 BM 102M8
o ®Disk Usage: Workspace 233M8, Builds 1GB.
#260  Aug 30, 2010 8:25:39 AM 110MB ="
( Workspace
#259  Aug 27, 2010 1:33:49 AW 110MB . Test Result Trend
#258  Aug 24, 2010 5:00:41 AM 108M8 Lost Sucoessful Artifacts
#257  Aug 23, 2010 5:00:41 AM 108MB @ ® EDIA STRUCTURE QC.log &
* SB OC OUTPUT.7z &=
L #256  Aug22, 2010 5:00:41 AN 1osMB ® SBDD TRANSFER counts.csv & ]
#255  Aug 21, 2010 5:00:41 AM 108MB ® SBDD TRANSFER counts diff.html &= Rl
* SBOD TRANSFERAnchorInstitutions.csv 4=
F25¢ AuQ20.2010 5:00:41 41 1oane ® 580D TRANSFERAnchor diff.html =
#253  Aug 19, 2010 5:00:41 AM 10888 ® SEDD TRANSFERProviders.csv &-
o 252 Augis. 70105:00:41 AN . * SBOD TRANSFERProviders diff.html - .
@ #151  1ul9, 20101:47:28 PM 41k8 ]
) for all ) for failures Recent Changes ust show failures) enlarge

Similar to the Product Create process, all results from the process are maintained:

‘Hudson » BOIA Proguct validation » BDIA Product Validation CO » 5270 ENABLE AIT0 REFRESH
4 Backio Projct Kawa s budk foraver

Build #270 (Nov 18, 2010 9:56:35 AM) | e |

fuld anifscts

Mo changes.
[t

P

(¥ Stanted by user A000vmoy

Test Resul {2 failures / +1)
Dlasamest siteste5 BOIAPrOdUCGDBEmarSUmMary, A0IAPreduR G OB ErrarSummanyClass.B0LA STRUCTURE GC SUMMARY

Results are then reviewed manually to ensure no errors reported are critical or in violation of the NTIA data model
or project completion statements. Any errors of concern are communicated ahead of product delivery and
included within the product release notes.

Further detail on the Hudson CI System environment can be found by navigating to the following link:
http://wiki.hudson-ci.org/display/HUDSON/Meet+Hudson



http://wiki.hudson-ci.org/display/HUDSON/Meet+Hudson
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Hudson = BDIA Product Validation CO

0, stetus

4 Back to Dashboard Project name BDIA_Product_Validation_CO
Description <p=This job checks db integrity on file GeoDatabase. </p>
<img src=http://vermont:8080/job/BDIA_Product_Validation_CO/pl
<peLatest Stats Reg! 1 <a href="http:, g

"> Changes
& workspace

Build Now

) Delete Project
& Configure
g Bt

@ Build History

£280  Dec 22,2010 9:47:05 AM
£279  Dec21,201011:41:46 AM

DIA_Product_Validation CO/lastSuccessfulBuild/artifact/SSDD_TRANSFER_counts_diff.htm|">Link</az <pz-
DIA_Product_Validation_CO; DD_TRAI :_diff.html">Link
D1A_Product_validation_CO/lastSuccessfulBuild/artifact/CO_error_summary_diff.html

<p=Latest Provider Reg P

<p>Latest CAI Reg <a href="http: DIA_Product_Validation_CO/lastSuccessfulBuild/artifact/SSDD_TRANSFERAnchorInstitutions_diff html">Link=/a><p>

Discard Old Builds
Days to keep builds

ifnot empty, build records are only kept up to this number of days
(trend)|  Max # of builds to keep 2o

if ot empty, only up to this number of build records are kept

#272  Dec17,20108:41:12 PN 84MB This build is parameterized

€O SOW deliverable validation
#271  Dec1,20108:16:568 AM

Final QC on SOW monthly CO product
#270  Nov 18, 2010 8:56:35 AM

£269  Nov 18, 2010 9:49:09 AM 79KB

String Parameter

Name TestMethodPrefix

Default value BpIA_STRUCTURE

#268  Nov 18, 2010 8:22:49 AM 75KB Deseription
#267  Nov 18, 2010 8:08:05 AM 77KB

QC on SOW monthly CO product
#266  Sep 29,2010 11:12:09 P 84MB

#265  Sep 26,2010 11:17:56 PM S0KB

€O validation build

£264  Sep 24, 201012:22:28 PM
£263  Aug 31,2010 1:29:41 PM
#262  Aug31,20101:17:05PM
#261  Aug31,201012:22:02 M
#260  Aug 30, 2010 8:25:35 AM

String Parameter

Name GDBLocation

Default Value //alaska/ReleaseCandidates/CO_20101117-1947

Description  parent path for the release candidate GDB

® e 08

®e 08

3.11 Product Extract Data Delivery

Product delivery for MapConnect Broadband is handled two ways, depending on client requirements:

1)

2)

State Submittal
a) Datais submitted via SFTP site
b) Product Release Notes and QC Test Report accompanies the delivery

NTIA Submittal

a) Directions for using the NTIA State Broadband Data file submission tool
b) Go to the following WWW web site: https://esupport.fcc.gov/statedata

c) Enter your username and password as provided to you from the NTIA program administrator.

FCC SUPPORT CENTER

Broadband State Data Management Tool

Broadband State Data Management Tool

Login
Username: * =

d) Clickin Upload afile field

e) Browse to local file for submission using the ‘Browse’ button. Select file then select ATTACH FILE.



https://esupport.fcc.gov/statedata
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FCC SUPPORT CENTER

Broadband State Data Management Tool Alaska (jgeorge@denali.gov) Logout

Upload File | View Files

UPLOAD NEW FILE

* denotes required field.

Upload File

Upload File* T
C:\Users\20100323142745_offer20100323.pdf [ IEETEEM) ATTACH FILE

f)  Logout / Receipt using the Logout button in the Top Right of the screen
g) Areceipt of submission is emailed to username e-mail address




